aboutsummaryrefslogtreecommitdiff
path: root/www/rss-bridge/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2019-12-28 17:37:16 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2019-12-28 17:37:16 +0000
commit93e156aefa1c554bc1a155f5222f33d289cd68d5 (patch)
tree1c99571fb319358a56b2bfce0cce9afd7f04cfe2 /www/rss-bridge/Makefile
parent58d69a54da8c059cfa7a0e279758fef4435224dc (diff)
downloadports-93e156aefa1c554bc1a155f5222f33d289cd68d5.tar.gz
ports-93e156aefa1c554bc1a155f5222f33d289cd68d5.zip
- Update to 2019-12-01
- Simplify the port PR: 242586 Submitted by: osidorkin@gmail.com (maintainer)
Notes
Notes: svn path=/head/; revision=521226
Diffstat (limited to 'www/rss-bridge/Makefile')
-rw-r--r--www/rss-bridge/Makefile28
1 files changed, 11 insertions, 17 deletions
diff --git a/www/rss-bridge/Makefile b/www/rss-bridge/Makefile
index 9e48714fda8e..e77d788c412a 100644
--- a/www/rss-bridge/Makefile
+++ b/www/rss-bridge/Makefile
@@ -1,7 +1,8 @@
# $FreeBSD$
PORTNAME= rss-bridge
-PORTVERSION= 20190912
+DISTVERSION= 2019-12-01
+PORTEPOCH= 1
CATEGORIES= www
MAINTAINER= osidorkin@gmail.com
@@ -13,7 +14,6 @@ USES= php:web
USE_GITHUB= yes
GH_ACCOUNT= RSS-Bridge
-GH_TAGNAME= 2019-09-12
NO_BUILD= yes
NO_ARCH= yes
@@ -23,22 +23,16 @@ PLIST_SUB= WWWOWN=${WWWOWN} WWWGRP=${WWWGRP}
USE_PHP= curl json mbstring openssl simplexml
OPTIONS_DEFINE= SQLITE
-OPTIONS_DEFAULT= SQLITE
-SQLITE_DESC= Enable sqlite-based cache support (requires sqlite)
-
-.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MSQLITE}
-USE_PHP+= sqlite3
-COPY_SKIP_OPT=
-PLIST_SUB+= SQLITE=""
-.else
-COPY_SKIP_OPT= -or -name SQLiteCache.php
-PLIST_SUB+= SQLITE="@comment "
-.endif
+OPTIONS_DEFAULT=SQLITE
+OPTIONS_SUB= yes
+
+SQLITE_DESC= Enable sqlite-based cache support (requires sqlite)
+
+SQLITE_USE= PHP=sqlite3
do-install:
- ${MKDIR} ${STAGEDIR}${WWWDIR}
- (cd ${WRKSRC} && ${COPYTREE_SHARE} "*" ${STAGEDIR}${WWWDIR} "-not ( \
- -name LICENSE -or -name .gitkeep ${COPY_SKIP_OPT} )" )
+ @${MKDIR} ${STAGEDIR}${WWWDIR}
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} "." ${STAGEDIR}${WWWDIR} "-not ( \
+ -name LICENSE -or -name .gitkeep )" )
.include <bsd.port.mk>