aboutsummaryrefslogtreecommitdiff
path: root/www/rt44/Makefile
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2017-03-08 12:18:57 +0000
committerRene Ladan <rene@FreeBSD.org>2017-03-08 12:18:57 +0000
commitb94208b86933c80e8446abb7398d41e778e0a6d0 (patch)
tree7a1d89f5152bf6f63abc84624f16575feef6e202 /www/rt44/Makefile
parent0062a39db9825e1dd900f7c6716cb175e8121991 (diff)
downloadports-b94208b86933c80e8446abb7398d41e778e0a6d0.tar.gz
ports-b94208b86933c80e8446abb7398d41e778e0a6d0.zip
www/rt44: remove optional dependency on expired databases/p5-DBD-Oracle
Notes
Notes: svn path=/head/; revision=435679
Diffstat (limited to 'www/rt44/Makefile')
-rw-r--r--www/rt44/Makefile14
1 files changed, 4 insertions, 10 deletions
diff --git a/www/rt44/Makefile b/www/rt44/Makefile
index 08d81bc8179a..dd08da83ca6a 100644
--- a/www/rt44/Makefile
+++ b/www/rt44/Makefile
@@ -29,14 +29,14 @@ NO_ARCH= yes
# builtin webserver, simply deselect all of the web options.
#
# See doc/full_text_indexing.pod if you need to set up full text
-# indexes on your ticket database. PostgreSQL or Oracle are
+# indexes on your ticket database. PostgreSQL is
# recommended in this case: the MYSQL / SphinxSearch combination
# mentioned in the docs is currently unsupported in the ports, but see
# http://www.infracaninophile.co.uk/articles/sphinxse.html
OPTIONS_DEFINE= DEVELOPER GD GPG GRAPHVIZ SMIME DOCS
OPTIONS_SINGLE= DB
-OPTIONS_SINGLE_DB= MYSQL ORACLE PGSQL SQLITE
+OPTIONS_SINGLE_DB= MYSQL PGSQL SQLITE
OPTIONS_RADIO= WEB
OPTIONS_RADIO_WEB= AP_MODFASTCGI AP_MODPERL LIGHTTPD SPAWN_FCGI
@@ -86,8 +86,6 @@ MYSQL_RUN_DEPENDS= ${MYSQL_DEPS}
PGSQL_RUN_DEPENDS= ${PGSQL_DEPS}
-ORACLE_RUN_DEPENDS= ${ORACLE_DEPS}
-
SQLITE_RUN_DEPENDS= ${SQLITE_DEPS}
DEVELOPER_DESC= Configure for developers
@@ -114,8 +112,8 @@ BUILD_DEPENDS+= ${RUN_DEPENDS}
.include <bsd.port.options.mk>
.if !${PORT_OPTIONS:MMYSQL} && !${PORT_OPTIONS:MPGSQL} && \
- ! ${PORT_OPTIONS:MORACLE} && !${PORT_OPTIONS:MSQLITE}
-IGNORE= please select one of MYSQL, PGSQL, ORACLE or SQLITE
+ !${PORT_OPTIONS:MSQLITE}
+IGNORE= please select one of MYSQL, PGSQL or SQLITE
.endif
.if ${PORT_OPTIONS:MMYSQL}
@@ -126,10 +124,6 @@ DB_TYPE= mysql
DB_TYPE= Pg
.endif
-.if ${PORT_OPTIONS:MORACLE}
-DB_TYPE= Oracle
-.endif
-
.if ${PORT_OPTIONS:MSQLITE}
DB_TYPE= SQLite
.endif