aboutsummaryrefslogtreecommitdiff
path: root/www/ruby-gtkmozembed
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2010-10-24 21:25:02 +0000
committerStanislav Sedov <stas@FreeBSD.org>2010-10-24 21:25:02 +0000
commit311f6bd1ca72643a16ba94d0da94a64d38be3353 (patch)
tree3f4ddd5bc1b89c660e9f7ba754386a64da7a0114 /www/ruby-gtkmozembed
parent56502845717790d9ba8d7764f2dfbc0d51526f07 (diff)
downloadports-311f6bd1ca72643a16ba94d0da94a64d38be3353.tar.gz
ports-311f6bd1ca72643a16ba94d0da94a64d38be3353.zip
- Swiftch to libxul engine, because seamonkey is going to be deprecated
soon.
Notes
Notes: svn path=/head/; revision=263531
Diffstat (limited to 'www/ruby-gtkmozembed')
-rw-r--r--www/ruby-gtkmozembed/Makefile3
-rw-r--r--www/ruby-gtkmozembed/files/patch-extconf-rb16
-rw-r--r--www/ruby-gtkmozembed/files/patch-extconf.rb10
3 files changed, 12 insertions, 17 deletions
diff --git a/www/ruby-gtkmozembed/Makefile b/www/ruby-gtkmozembed/Makefile
index 9472cbb12917..0407005b0615 100644
--- a/www/ruby-gtkmozembed/Makefile
+++ b/www/ruby-gtkmozembed/Makefile
@@ -8,6 +8,7 @@
PORTNAME= gtkmozembed
PORTVERSION= ${RUBY_GNOME_PORTVERSION}
+PORTREVISION= 1
CATEGORIES= www ruby
MASTER_SITES= ${RUBY_GNOME_MASTER_SITES}
MASTER_SITE_SUBDIR= ${RUBY_GNOME_MASTER_SITE_SUBDIR}
@@ -22,7 +23,7 @@ BUILD_DEPENDS+= rubygem-pkg-config>=1.0.7:${PORTSDIR}/devel/rubygem-pkg-config
RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR:S/${PREFIX}/${LOCALBASE}/}/gtk2.so:${PORTSDIR}/x11-toolkits/ruby-gtk2
USE_RUBY= yes
-USE_GECKO= seamonkey
+USE_GECKO= libxul
USE_RUBY_EXTCONF= yes
.include "${.CURDIR}/../../x11/ruby-gnome2/Makefile.common"
diff --git a/www/ruby-gtkmozembed/files/patch-extconf-rb b/www/ruby-gtkmozembed/files/patch-extconf-rb
deleted file mode 100644
index c2bd782dce6e..000000000000
--- a/www/ruby-gtkmozembed/files/patch-extconf-rb
+++ /dev/null
@@ -1,16 +0,0 @@
---- extconf.rb.orig 2010-09-25 04:26:28.000000000 -0400
-+++ extconf.rb 2010-10-06 21:09:27.986446199 -0400
-@@ -20,12 +20,7 @@
- $LOAD_PATH.unshift(mkmf_gnome2_dir.to_s)
-
- module_name = "gtkmozembed"
--package_ids = ["libxul-embedding-unstable",
-- "libxul-embedding",
-- "xulrunner-gtkmozembed",
-- "firefox-gtkmozembed",
-- "seamonkey-gtkmozembed",
-- "mozilla-gtkmozembed"]
-+package_ids = ["seamonkey-gtkmozembed"]
-
- require 'mkmf-gnome2'
-
diff --git a/www/ruby-gtkmozembed/files/patch-extconf.rb b/www/ruby-gtkmozembed/files/patch-extconf.rb
new file mode 100644
index 000000000000..e50cf71ee74d
--- /dev/null
+++ b/www/ruby-gtkmozembed/files/patch-extconf.rb
@@ -0,0 +1,10 @@
+--- extconf.rb.orig 2010-10-24 14:12:43.000000000 -0700
++++ extconf.rb 2010-10-24 14:12:53.000000000 -0700
+@@ -57,6 +57,7 @@
+
+ mozilla_library_path = PKGConfig.libs_only_L(package_id)
+ mozilla_path = mozilla_library_path.strip.sub(/^-L/, "")
++$CFLAGS << " " + PKGConfig.cflags(package_id) + " " + PKGConfig.cflags("libxul")
+
+ if mozilla_path
+ # please comment the CFLAGS line if you don't want a default comp_path