aboutsummaryrefslogtreecommitdiff
path: root/www/rubygem-actionwebservice
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-07-20 14:05:09 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-07-20 14:05:09 +0000
commit725a287178381d6436fd9b52cc0aff8ef01231a3 (patch)
treebbf542ad68ffa97115106cb1b0e567c5ae8084ed /www/rubygem-actionwebservice
parent83a42a071cd8b18b60cae983b4b773f220787c5d (diff)
downloadports-725a287178381d6436fd9b52cc0aff8ef01231a3.tar.gz
ports-725a287178381d6436fd9b52cc0aff8ef01231a3.zip
Action Web Service provides a way to publish interoperable web service APIs with
Rails without spending a lot of time delving into protocol details. PR: ports/82397 Submitted by: Jonathan Weiss <jw@innerewut.de>
Notes
Notes: svn path=/head/; revision=139698
Diffstat (limited to 'www/rubygem-actionwebservice')
-rw-r--r--www/rubygem-actionwebservice/Makefile20
-rw-r--r--www/rubygem-actionwebservice/distinfo2
-rw-r--r--www/rubygem-actionwebservice/pkg-descr19
-rw-r--r--www/rubygem-actionwebservice/pkg-plist232
4 files changed, 273 insertions, 0 deletions
diff --git a/www/rubygem-actionwebservice/Makefile b/www/rubygem-actionwebservice/Makefile
new file mode 100644
index 000000000000..7e425dd8ca3a
--- /dev/null
+++ b/www/rubygem-actionwebservice/Makefile
@@ -0,0 +1,20 @@
+# Ports collection makefile for: rubygem-actionwebservice
+# Date created: 27 May 2005
+# Whom: Jonathan Weiss (<jw@innerewut.net>)
+#
+# $FreeBSD$
+
+PORTNAME= actionwebservice
+PORTVERSION= 0.7.1
+CATEGORIES= www ruby
+MASTER_SITES= http://rubyforge.org/frs/download.php/4155/
+
+MAINTAINER= jw@innerewut.net
+COMMENT= Simple support for publishing Web Service APIs for Rails applications
+
+BUILD_DEPENDS= ${LOCALBASE}/${SPEC_DIR}/actionpack-1.8.1.gemspec:${PORTSDIR}/www/rubygem-actionpack
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
+.include <bsd.port.post.mk>
diff --git a/www/rubygem-actionwebservice/distinfo b/www/rubygem-actionwebservice/distinfo
new file mode 100644
index 000000000000..8005872c9143
--- /dev/null
+++ b/www/rubygem-actionwebservice/distinfo
@@ -0,0 +1,2 @@
+MD5 (rubygem/actionwebservice-0.7.1.gem) = 4b9b1c99c831db73acf8f718ce33eb3d
+SIZE (rubygem/actionwebservice-0.7.1.gem) = 58880
diff --git a/www/rubygem-actionwebservice/pkg-descr b/www/rubygem-actionwebservice/pkg-descr
new file mode 100644
index 000000000000..3acd2d3aeca2
--- /dev/null
+++ b/www/rubygem-actionwebservice/pkg-descr
@@ -0,0 +1,19 @@
+Action Web Service
+
+Action Web Service provides a way to publish interoperable web service APIs with
+Rails without spending a lot of time delving into protocol details.
+
+Features
+
+* SOAP RPC protocol support
+* Dynamic WSDL generation for APIs
+* XML-RPC protocol support
+* Clients that use the same API definitions as the server for
+ easy interoperability with other Action Web Service based applications
+* Type signature hints to improve interoperability with static languages
+* Active Record model class support in signatures
+
+WWW: http://www.rubyonrails.com
+
+- Jonathan Weiss
+jw@innerewut.de
diff --git a/www/rubygem-actionwebservice/pkg-plist b/www/rubygem-actionwebservice/pkg-plist
new file mode 100644
index 000000000000..0a31c4e67410
--- /dev/null
+++ b/www/rubygem-actionwebservice/pkg-plist
@@ -0,0 +1,232 @@
+%%CACHE_DIR%%/actionwebservice-%%PORTVERSION%%.gem
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/API/Base.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/API/Base.src/M000034.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/API/Base.src/M000035.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/API/Base.src/M000036.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/API/Base.src/M000037.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/API/Base.src/M000038.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/API/Base.src/M000039.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/API/Base.src/M000040.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/API/Base.src/M000041.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/API/Base.src/M000042.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/API/Method.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/API/Method.src/M000026.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/API/Method.src/M000027.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/API/Method.src/M000028.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/API/Method.src/M000029.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/API/Method.src/M000030.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/API/Method.src/M000031.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/API/Method.src/M000032.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/API/Method.src/M000033.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/Base.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/Casting/BaseCaster.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/Casting/BaseCaster.src/M000021.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/Casting/BaseCaster.src/M000022.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/Casting/BaseCaster.src/M000023.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/Client/Soap.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/Client/Soap.src/M000024.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/Client/XmlRpc.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/Client/XmlRpc.src/M000025.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/Container/ActionController/ClassMethods.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/Container/ActionController/ClassMethods.src/M000001.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/Container/Delegated/ClassMethods.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/Container/Delegated/ClassMethods.src/M000003.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/Container/Delegated/ClassMethods.src/M000004.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/Container/Direct/ClassMethods.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/Container/Direct/ClassMethods.src/M000002.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/Invocation/ClassMethods.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/Invocation/ClassMethods.src/M000044.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/Invocation/ClassMethods.src/M000045.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/Invocation/ClassMethods.src/M000047.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/Invocation/ClassMethods.src/M000048.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/Protocol/Soap/SoapActiveRecordStructFactory.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/Protocol/Soap/SoapActiveRecordStructFactory.src/M000005.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/Protocol/Soap/SoapActiveRecordStructFactory.src/M000006.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/Protocol/Soap/SoapBinding.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/Protocol/Soap/SoapBinding.src/M000007.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/Protocol/Soap/SoapBinding.src/M000008.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/Protocol/Soap/SoapBinding.src/M000009.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/Protocol/Soap/SoapBinding.src/M000010.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/Protocol/Soap/SoapBinding.src/M000012.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/Protocol/Soap/SoapMarshaler.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/Protocol/Soap/SoapMarshaler.src/M000013.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/Protocol/Soap/SoapMarshaler.src/M000014.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/Protocol/Soap/SoapMarshaler.src/M000015.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/Protocol/Soap/SoapMarshaler.src/M000016.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/Protocol/Soap/SoapMarshaler.src/M000018.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/Protocol/Soap/SoapTypedArrayFactory.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/Protocol/Soap/SoapTypedArrayFactory.src/M000019.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/Protocol/Soap/SoapTypedArrayFactory.src/M000020.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/Scaffolding/ClassMethods.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/Scaffolding/ClassMethods.src/M000043.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/Struct.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/Struct.src/M000050.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/Struct.src/M000051.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/Struct.src/M000052.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/Struct.src/M000053.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/XMLRPC.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/XMLRPC/FaultException.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/created.rid
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/files/lib/action_web_service/api_rb.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/files/lib/action_web_service/base_rb.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/files/lib/action_web_service/casting_rb.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/files/lib/action_web_service/client/base_rb.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/files/lib/action_web_service/client/soap_client_rb.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/files/lib/action_web_service/client/xmlrpc_client_rb.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/files/lib/action_web_service/client_rb.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/files/lib/action_web_service/container/action_controller_container_rb.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/files/lib/action_web_service/container/delegated_container_rb.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/files/lib/action_web_service/container/direct_container_rb.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/files/lib/action_web_service/container_rb.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/files/lib/action_web_service/dispatcher/abstract_rb.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/files/lib/action_web_service/dispatcher/action_controller_dispatcher_rb.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/files/lib/action_web_service/dispatcher_rb.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/files/lib/action_web_service/invocation_rb.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/files/lib/action_web_service/protocol/abstract_rb.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/files/lib/action_web_service/protocol/discovery_rb.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/files/lib/action_web_service/protocol/soap_protocol/marshaler_rb.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/files/lib/action_web_service/protocol/soap_protocol_rb.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/files/lib/action_web_service/protocol/xmlrpc_protocol_rb.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/files/lib/action_web_service/protocol_rb.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/files/lib/action_web_service/scaffolding_rb.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/files/lib/action_web_service/struct_rb.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/files/lib/action_web_service/support/class_inheritable_options_rb.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/files/lib/action_web_service/support/signature_types_rb.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/files/lib/action_web_service/test_invoke_rb.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/files/lib/action_web_service_rb.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/fr_class_index.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/fr_file_index.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/fr_method_index.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/index.html
+%%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/rdoc-style.css
+%%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/CHANGELOG
+%%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/MIT-LICENSE
+%%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/README
+%%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/Rakefile
+%%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/TODO
+%%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/examples/googlesearch/README
+%%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/examples/googlesearch/autoloading/google_search_api.rb
+%%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/examples/googlesearch/autoloading/google_search_controller.rb
+%%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/examples/googlesearch/delegated/google_search_service.rb
+%%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/examples/googlesearch/delegated/search_controller.rb
+%%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/examples/googlesearch/direct/google_search_api.rb
+%%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/examples/googlesearch/direct/search_controller.rb
+%%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/examples/metaWeblog/README
+%%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/examples/metaWeblog/apis/blogger_api.rb
+%%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/examples/metaWeblog/apis/blogger_service.rb
+%%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/examples/metaWeblog/apis/meta_weblog_api.rb
+%%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/examples/metaWeblog/apis/meta_weblog_service.rb
+%%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/examples/metaWeblog/controllers/xmlrpc_controller.rb
+%%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/lib/action_web_service.rb
+%%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/lib/action_web_service/api.rb
+%%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/lib/action_web_service/base.rb
+%%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/lib/action_web_service/casting.rb
+%%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/lib/action_web_service/client.rb
+%%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/lib/action_web_service/client/base.rb
+%%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/lib/action_web_service/client/soap_client.rb
+%%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/lib/action_web_service/client/xmlrpc_client.rb
+%%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/lib/action_web_service/container.rb
+%%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/lib/action_web_service/container/action_controller_container.rb
+%%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/lib/action_web_service/container/delegated_container.rb
+%%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/lib/action_web_service/container/direct_container.rb
+%%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/lib/action_web_service/dispatcher.rb
+%%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/lib/action_web_service/dispatcher/abstract.rb
+%%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/lib/action_web_service/dispatcher/action_controller_dispatcher.rb
+%%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/lib/action_web_service/invocation.rb
+%%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/lib/action_web_service/protocol.rb
+%%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/lib/action_web_service/protocol/abstract.rb
+%%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/lib/action_web_service/protocol/discovery.rb
+%%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/lib/action_web_service/protocol/soap_protocol.rb
+%%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/lib/action_web_service/protocol/soap_protocol/marshaler.rb
+%%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/lib/action_web_service/protocol/xmlrpc_protocol.rb
+%%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/lib/action_web_service/scaffolding.rb
+%%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/lib/action_web_service/struct.rb
+%%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/lib/action_web_service/support/class_inheritable_options.rb
+%%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/lib/action_web_service/support/signature_types.rb
+%%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/lib/action_web_service/templates/scaffolds/layout.rhtml
+%%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/lib/action_web_service/templates/scaffolds/methods.rhtml
+%%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/lib/action_web_service/templates/scaffolds/parameters.rhtml
+%%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/lib/action_web_service/templates/scaffolds/result.rhtml
+%%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/lib/action_web_service/test_invoke.rb
+%%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/setup.rb
+%%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/test/abstract_client.rb
+%%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/test/abstract_dispatcher.rb
+%%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/test/abstract_unit.rb
+%%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/test/api_test.rb
+%%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/test/apis/auto_load_api.rb
+%%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/test/apis/broken_auto_load_api.rb
+%%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/test/base_test.rb
+%%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/test/casting_test.rb
+%%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/test/client_soap_test.rb
+%%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/test/client_xmlrpc_test.rb
+%%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/test/container_test.rb
+%%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/test/dispatcher_action_controller_soap_test.rb
+%%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/test/dispatcher_action_controller_xmlrpc_test.rb
+%%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/test/gencov
+%%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/test/invocation_test.rb
+%%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/test/run
+%%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/test/scaffolded_controller_test.rb
+%%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/test/struct_test.rb
+%%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/test/test_invoke_test.rb
+%%SPEC_DIR%%/actionwebservice-%%PORTVERSION%%.gemspec
+@dirrm %%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/test/apis
+@dirrm %%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/test
+@dirrm %%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/lib/action_web_service/templates/scaffolds
+@dirrm %%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/lib/action_web_service/templates
+@dirrm %%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/lib/action_web_service/support
+@dirrm %%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/lib/action_web_service/protocol/soap_protocol
+@dirrm %%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/lib/action_web_service/protocol
+@dirrm %%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/lib/action_web_service/dispatcher
+@dirrm %%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/lib/action_web_service/container
+@dirrm %%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/lib/action_web_service/client
+@dirrm %%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/lib/action_web_service
+@dirrm %%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/lib
+@dirrm %%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/examples/metaWeblog/controllers
+@dirrm %%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/examples/metaWeblog/apis
+@dirrm %%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/examples/metaWeblog
+@dirrm %%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/examples/googlesearch/direct
+@dirrm %%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/examples/googlesearch/delegated
+@dirrm %%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/examples/googlesearch/autoloading
+@dirrm %%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/examples/googlesearch
+@dirrm %%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%/examples
+@dirrm %%GEMS_DIR%%/actionwebservice-%%PORTVERSION%%
+@dirrm %%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/files/lib/action_web_service/support
+@dirrm %%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/files/lib/action_web_service/protocol/soap_protocol
+@dirrm %%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/files/lib/action_web_service/protocol
+@dirrm %%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/files/lib/action_web_service/dispatcher
+@dirrm %%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/files/lib/action_web_service/container
+@dirrm %%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/files/lib/action_web_service/client
+@dirrm %%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/files/lib/action_web_service
+@dirrm %%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/files/lib
+@dirrm %%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/files
+@dirrm %%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/XMLRPC
+@dirrm %%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/Struct.src
+@dirrm %%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/Scaffolding/ClassMethods.src
+@dirrm %%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/Scaffolding
+@dirrm %%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/Protocol/Soap/SoapTypedArrayFactory.src
+@dirrm %%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/Protocol/Soap/SoapMarshaler.src
+@dirrm %%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/Protocol/Soap/SoapBinding.src
+@dirrm %%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/Protocol/Soap/SoapActiveRecordStructFactory.src
+@dirrm %%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/Protocol/Soap
+@dirrm %%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/Protocol
+@dirrm %%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/Invocation/ClassMethods.src
+@dirrm %%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/Invocation
+@dirrm %%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/Container/Direct/ClassMethods.src
+@dirrm %%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/Container/Direct
+@dirrm %%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/Container/Delegated/ClassMethods.src
+@dirrm %%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/Container/Delegated
+@dirrm %%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/Container/ActionController/ClassMethods.src
+@dirrm %%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/Container/ActionController
+@dirrm %%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/Container
+@dirrm %%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/Client/XmlRpc.src
+@dirrm %%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/Client/Soap.src
+@dirrm %%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/Client
+@dirrm %%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/Casting/BaseCaster.src
+@dirrm %%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/Casting
+@dirrm %%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/API/Method.src
+@dirrm %%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/API/Base.src
+@dirrm %%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService/API
+@dirrm %%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes/ActionWebService
+@dirrm %%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc/classes
+@dirrm %%DOC_DIR%%/actionwebservice-%%PORTVERSION%%/rdoc
+@dirrm %%DOC_DIR%%/actionwebservice-%%PORTVERSION%%