aboutsummaryrefslogtreecommitdiff
path: root/www/rubygem-async_sinatra/Makefile
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2013-01-23 02:43:16 +0000
committerSteve Wills <swills@FreeBSD.org>2013-01-23 02:43:16 +0000
commit29430dedada67766b11e82ec7ed415d580d872e9 (patch)
tree736abcaed5ee12a281cae3483d9904954a00b370 /www/rubygem-async_sinatra/Makefile
parent5b7b677c628e6da26cd5a47f17cc907925d2cb8e (diff)
downloadports-29430dedada67766b11e82ec7ed415d580d872e9.tar.gz
ports-29430dedada67766b11e82ec7ed415d580d872e9.zip
Add rubygem-async_sinatra 1.0.0, a Sinatra plugin to provide async
responses. PR: ports/172117 Submitted by: Kimo <kimor79@yahoo.com>
Notes
Notes: svn path=/head/; revision=310849
Diffstat (limited to 'www/rubygem-async_sinatra/Makefile')
-rw-r--r--www/rubygem-async_sinatra/Makefile19
1 files changed, 19 insertions, 0 deletions
diff --git a/www/rubygem-async_sinatra/Makefile b/www/rubygem-async_sinatra/Makefile
new file mode 100644
index 000000000000..491d3ea8766d
--- /dev/null
+++ b/www/rubygem-async_sinatra/Makefile
@@ -0,0 +1,19 @@
+# Created by: Kimo <kimor79@yahoo.com>
+# $FreeBSD$
+
+PORTNAME= async_sinatra
+PORTVERSION= 1.0.0
+CATEGORIES= www rubygems
+MASTER_SITES= RG
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= A Sinatra plugin to provide async responses
+
+RUN_DEPENDS= rubygem-rack>=1.4.1:${PORTSDIR}/www/rubygem-rack \
+ rubygem-sinatra>=1.3.2:${PORTSDIR}/www/rubygem-sinatra
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>