aboutsummaryrefslogtreecommitdiff
path: root/www/rubygem-chromedriver-helper/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-08-12 19:39:53 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-08-12 19:39:53 +0000
commit3625a6bec176cdda69b7a0855d4820a08fd91d7a (patch)
tree1d5a70e1bbce0402c8d7f647e13b7de5aa1ad2af /www/rubygem-chromedriver-helper/Makefile
parent1e834c8875143fab10a722509ecb894c07e6e93f (diff)
downloadports-3625a6bec176cdda69b7a0855d4820a08fd91d7a.tar.gz
ports-3625a6bec176cdda69b7a0855d4820a08fd91d7a.zip
Add rubygem-chromedriver-helper 2.1.1
chromedriver-helper installs an executable, chromedriver-helper, in your gem path, and configures Selenium to invoke it as the web driver. This script will, if necessary, download the appropriate binary for your platform and install it into ~/.chromedriver-helper, then exec it. Easy peasy! Individual projects can even select which version of chromedriver they want to run. WWW: https://github.com/flavorjones/chromedriver-helper
Notes
Notes: svn path=/head/; revision=508765
Diffstat (limited to 'www/rubygem-chromedriver-helper/Makefile')
-rw-r--r--www/rubygem-chromedriver-helper/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/www/rubygem-chromedriver-helper/Makefile b/www/rubygem-chromedriver-helper/Makefile
new file mode 100644
index 000000000000..93c58d90c63a
--- /dev/null
+++ b/www/rubygem-chromedriver-helper/Makefile
@@ -0,0 +1,26 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= chromedriver-helper
+PORTVERSION= 2.1.1
+CATEGORIES= www rubygems
+MASTER_SITES= RG
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Easy installation and use of chromedriver
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= rubygem-archive-zip>=0.10:archivers/rubygem-archive-zip \
+ rubygem-nokogiri>=1.8:textproc/rubygem-nokogiri
+
+USES= gem
+USE_RUBY= yes
+
+NO_ARCH= yes
+
+PLIST_FILES= bin/chromedriver-helper \
+ bin/chromedriver-update
+
+.include <bsd.port.mk>