aboutsummaryrefslogtreecommitdiff
path: root/www/rubygem-rails4
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2014-09-14 02:06:58 +0000
committerSteve Wills <swills@FreeBSD.org>2014-09-14 02:06:58 +0000
commit28071e639803800705a6938642ba75b31f925b45 (patch)
tree80b3dcb025ec943583a478981072ebc0ef107aa8 /www/rubygem-rails4
parentec6354100bcad612065a1c296b7176385d726ed5 (diff)
downloadports-28071e639803800705a6938642ba75b31f925b45.tar.gz
ports-28071e639803800705a6938642ba75b31f925b45.zip
www/rubygem-rails4: create port for rails4
This port required creating a number of new ports, old versions of existing ports and other adjustments, so do all that while here too. Rails is a web-application framework for the MVC pattern that includes both a template engine, controller framework, and object-relational mapping package. Everything needed to develop web-apps that can run on CGI, FastCGI, and mod_ruby Being a full-stack framework means that all layers are built to work seamlessly together. That way you Don't Repeat Yourself (DRY) and you can use a single language from top to bottom. Everything from templates to control flow to business logic is written in Ruby - The language of love for industry heavy-weights. WWW: http://www.rubyonrails.org Submitted by: xmj (based on)
Notes
Notes: svn path=/head/; revision=368156
Diffstat (limited to 'www/rubygem-rails4')
-rw-r--r--www/rubygem-rails4/Makefile62
-rw-r--r--www/rubygem-rails4/distinfo2
-rw-r--r--www/rubygem-rails4/pkg-descr12
3 files changed, 76 insertions, 0 deletions
diff --git a/www/rubygem-rails4/Makefile b/www/rubygem-rails4/Makefile
new file mode 100644
index 000000000000..759d23d6f2d7
--- /dev/null
+++ b/www/rubygem-rails4/Makefile
@@ -0,0 +1,62 @@
+# Created by: Johannes Meixner <xmj@chaot.net>
+# $FreeBSD$
+
+PORTNAME= rails
+PORTVERSION= 4.1.6
+CATEGORIES= www rubygems
+MASTER_SITES= RG
+PKGNAMESUFFIX= 4
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= MVC web application framework
+
+LICENSE= MIT
+
+RUN_DEPENDS= rubygem-actionmailer4>=${PORTVERSION}:${PORTSDIR}/mail/rubygem-actionmailer4 \
+ rubygem-actionpack4>=${PORTVERSION}:${PORTSDIR}/www/rubygem-actionpack4 \
+ rubygem-actionview>=${PORTVERSION}:${PORTSDIR}/devel/rubygem-actionview \
+ rubygem-activemodel4>=${PORTVERSION}:${PORTSDIR}/databases/rubygem-activemodel4 \
+ rubygem-activerecord4>=${PORTVERSION}:${PORTSDIR}/databases/rubygem-activerecord4 \
+ rubygem-activesupport4>=${PORTVERSION}:${PORTSDIR}/devel/rubygem-activesupport4 \
+ rubygem-bundler>=1.0:${PORTSDIR}/sysutils/rubygem-bundler \
+ rubygem-railties4>=${PORTVERSION}:${PORTSDIR}/www/rubygem-railties4 \
+ rubygem-activeresource4>=4.0.0:${PORTSDIR}/www/rubygem-activeresource4 \
+ rubygem-builder32>=3.2.2:${PORTSDIR}/devel/rubygem-builder32 \
+ rubygem-sprockets-rails>=2.0:${PORTSDIR}/devel/rubygem-sprockets-rails \
+ rubygem-rake>=10.1.1:${PORTSDIR}/devel/rubygem-rake \
+ rubygem-sqlite3>=1.3.9:${PORTSDIR}/databases/rubygem-sqlite3 \
+ rubygem-execjs>=2.2.1:${PORTSDIR}/devel/rubygem-execjs \
+ rubygem-coffee-rails4>=4.0.1:${PORTSDIR}/devel/rubygem-coffee-rails4 \
+ rubygem-sass-rails>=4.0.3:${PORTSDIR}/textproc/rubygem-sass-rails4 \
+ rubygem-spring>=1.1.3:${PORTSDIR}/devel/rubygem-spring \
+ rubygem-jquery-rails4>=3.1.2:${PORTSDIR}/www/rubygem-jquery-rails4 \
+ rubygem-jbuilder>=2.1.3:${PORTSDIR}/devel/rubygem-jbuilder \
+ rubygem-uglifier>=2.5.0:${PORTSDIR}/www/rubygem-uglifier \
+ rubygem-sprockets211>=2.11.0:${PORTSDIR}/devel/rubygem-sprockets211 \
+ rubygem-rdoc>=0:${PORTSDIR}/devel/rubygem-rdoc \
+ rubygem-thread_safe>=0.3.4:${PORTSDIR}/devel/rubygem-thread_safe \
+ rubygem-turbolinks>=2.3.0:${PORTSDIR}/www/rubygem-turbolinks \
+ rubygem-sass>=3.4.1:${PORTSDIR}/textproc/rubygem-sass \
+ rubygem-sdoc>=0.4.1:${PORTSDIR}/devel/rubygem-sdoc
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+USES= cpe
+
+CPE_VENDOR= rubyonrails
+CPE_PRODUCT= ruby_on_rails
+
+OPTIONS_DEFINE= FCGI PASSENGER MEMCACHE_CLIENT
+FCGI_DESC= FastCGI backend
+MONGRELCLUSTER_DESC= Mongrel Cluster backend
+PASSENGER_DESC= Passenger backend
+MEMCACHE_CLIENT_DESC= MemCache-Client support
+OPTIONSFILE= ${PORT_DBDIR}/rubygem-${PORTNAME}/options
+
+FCGI_RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/fcgi.so:${PORTSDIR}/www/ruby-fcgi
+MEMCACHE_CLIENT_RUN_DEPENDS= rubygem-memcache-client>=1.2.0:${PORTSDIR}/databases/rubygem-memcache-client
+PASSENGER_RUN_DEPENDS= rubygem-passenger>=2.2.15:${PORTSDIR}/www/rubygem-passenger
+
+.include <bsd.port.mk>
diff --git a/www/rubygem-rails4/distinfo b/www/rubygem-rails4/distinfo
new file mode 100644
index 000000000000..a95e7cd432cb
--- /dev/null
+++ b/www/rubygem-rails4/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/rails-4.1.6.gem) = f351c95673cb833652deeaab5c67998ab0af9ff3c89c585abe23dafa0648efa0
+SIZE (rubygem/rails-4.1.6.gem) = 1438208
diff --git a/www/rubygem-rails4/pkg-descr b/www/rubygem-rails4/pkg-descr
new file mode 100644
index 000000000000..816c3dc06c91
--- /dev/null
+++ b/www/rubygem-rails4/pkg-descr
@@ -0,0 +1,12 @@
+Rails is a web-application framework for the MVC pattern that includes
+both a template engine, controller framework, and object-relational
+mapping package. Everything needed to develop web-apps that can run on
+CGI, FastCGI, and mod_ruby
+
+Being a full-stack framework means that all layers are built to work
+seamlessly together. That way you Don't Repeat Yourself (DRY) and you
+can use a single language from top to bottom. Everything from templates
+to control flow to business logic is written in Ruby - The language of
+love for industry heavy-weights.
+
+WWW: http://www.rubyonrails.org