aboutsummaryrefslogtreecommitdiff
path: root/www/sabredav/Makefile
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2014-08-08 14:58:11 +0000
committerKurt Jaeger <pi@FreeBSD.org>2014-08-08 14:58:11 +0000
commita78a8bf2c512a4f362a3830149d39bb4cbc99012 (patch)
tree0c5e5002aaf5d71471d4dbc65ffe6eb96f22888e /www/sabredav/Makefile
parentc395165f3bf62963bfe4e7020d17e625f36fccfa (diff)
downloadports-a78a8bf2c512a4f362a3830149d39bb4cbc99012.tar.gz
ports-a78a8bf2c512a4f362a3830149d39bb4cbc99012.zip
New port: www/sabredav
Popular WebDAV framework for PHP. Use it to create WebDAV, CalDAV and CardDAV servers. It supports a wide range of internet standards related to these protocols. The most relevant are: WebDAV CalDAV CardDAV vCard 2.1, 3.0, 4.0 and jCard iCalendar 2.0 and jCal current-user-principal Extended MKCOL WebDAV-sync CardDAV directories CalDAV delegation CalDAV sharing WWW: http://sabre.io/ Submitted by: meyser@xenet.de
Notes
Notes: svn path=/head/; revision=364365
Diffstat (limited to 'www/sabredav/Makefile')
-rw-r--r--www/sabredav/Makefile50
1 files changed, 50 insertions, 0 deletions
diff --git a/www/sabredav/Makefile b/www/sabredav/Makefile
new file mode 100644
index 000000000000..bd6095fe04bb
--- /dev/null
+++ b/www/sabredav/Makefile
@@ -0,0 +1,50 @@
+# $FreeBSD$
+
+PORTNAME= sabredav
+PORTVERSION= 2.0.3
+CATEGORIES= www
+MASTER_SITES= https://github.com/fruux/sabre-dav/releases/download/${PORTVERSION}/
+
+MAINTAINER= meyser@xenet.de
+COMMENT= WebDav, CalDav and Carddav Server/Framework written in PHP
+
+LICENSE= BSD3CLAUSE
+
+OPTIONS_DEFINE= MYSQL PGSQL SQLITE
+OPTIONS_DEFAULT= MYSQL
+
+MYSQL_DESC= Install mysql support
+PGSQL_DESC= Install postgresql support
+SQLITE_DESC= Install sqlite support
+
+OPTIONS_MULTI= DATABASE
+OPTIONS_MULTI_DATABASE= MYSQL PGSQL SQLITE
+
+USES= zip
+USE_PHP= dom simplexml mbstring ctype iconv
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MMYSQL}
+USE_PHP+= pdo_mysql
+.endif
+
+.if ${PORT_OPTIONS:MPGSQL}
+USE_PHP+= pdo_pgsql
+.endif
+
+.if ${PORT_OPTIONS:MSQLITE}
+USE_PHP+= pdo_sqlite
+.endif
+
+WRKSRC= ${WRKDIR}/SabreDAV
+
+NO_BUILD= yes
+
+USE_PHP= yes
+
+do-install:
+ ${MKDIR} ${STAGEDIR}/${WWWDIR}
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}/${WWWDIR} )
+
+.include <bsd.port.mk>