aboutsummaryrefslogtreecommitdiff
path: root/www/seahub
diff options
context:
space:
mode:
authorRichard Gallamore <ultima@FreeBSD.org>2021-02-26 06:22:00 +0000
committerRichard Gallamore <ultima@FreeBSD.org>2021-02-26 06:22:00 +0000
commite435d0ea202e58733704715a4a9af6127ce2f63e (patch)
tree9beeb366247d761b1d5e4bc050e4df6e85abe54c /www/seahub
parent29341a33838d1c9af71ddf6eb9fa8946b05d2aa6 (diff)
downloadports-e435d0ea202e58733704715a4a9af6127ce2f63e.tar.gz
ports-e435d0ea202e58733704715a4a9af6127ce2f63e.zip
Update ports to Django22
django-post_office jsonfield depend has been renamed upstream, the old django-jsonfield port does not support django past 1.11. PR: 245309 Approved by: sunpoet, kai, jhixson (timeout) Differential Revision: https://reviews.freebsd.org/D28513
Notes
Notes: svn path=/head/; revision=566581
Diffstat (limited to 'www/seahub')
-rw-r--r--www/seahub/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/www/seahub/Makefile b/www/seahub/Makefile
index b334a482976a..91aa348332af 100644
--- a/www/seahub/Makefile
+++ b/www/seahub/Makefile
@@ -4,7 +4,7 @@ PORTNAME= seahub
DISTVERSIONPREFIX= v
DISTVERSION= ${SEAHUB_VER}
DISTVERSIONSUFFIX= -server
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MAINTAINER= ultima@FreeBSD.org
@@ -13,11 +13,11 @@ COMMENT= Web frontend for Seafile
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django111>=0:www/py-django111@${PY_FLAVOR}
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django22>=0:www/py-django22@${PY_FLAVOR}
RUN_DEPENDS= bash:shells/bash \
${LOCALBASE}/www/haiwen/seafile-server/seafile/bin/seaf-server:net-mgmt/seafile-server \
- ${PYTHON_PKGNAMEPREFIX}django111>=0:www/py-django111@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}django22>=0:www/py-django22@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}future>=0:devel/py-future@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}django-statici18n>=0:www/py-django-statici18n@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}django-post_office>=0:www/py-django-post_office@${PY_FLAVOR} \
@@ -29,7 +29,7 @@ RUN_DEPENDS= bash:shells/bash \
${PYTHON_PKGNAMEPREFIX}qrcode>0:textproc/py-qrcode@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}django-formtools>=0:www/py-django-formtools@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}django-simple-captcha>=0:www/py-django-simple-captcha@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}djangorestframework311>=0:www/py-djangorestframework311@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}djangorestframework>=0:www/py-djangorestframework@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}dateutil>=0:devel/py-dateutil@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}requests>=0:www/py-requests@${PY_FLAVOR} \
${PY_PILLOW} \