aboutsummaryrefslogtreecommitdiff
path: root/www/seamonkey2
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-02-27 07:49:33 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-02-27 07:49:33 +0000
commite248e25ea13de8edd61023146ac7c42cb9e97694 (patch)
treebf3c9765cfb73083f505129e19e47c06052f2ecd /www/seamonkey2
parent1761168fee789e4fe9cb21bc626b4b3614d66623 (diff)
downloadports-e248e25ea13de8edd61023146ac7c42cb9e97694.tar.gz
ports-e248e25ea13de8edd61023146ac7c42cb9e97694.zip
Fix the install location for the header files. For those that installed
mozilla-devel along side mozilla, they will need to reinstall both to sort out the header problems. Sorry.
Notes
Notes: svn path=/head/; revision=102265
Diffstat (limited to 'www/seamonkey2')
-rw-r--r--www/seamonkey2/Makefile16
1 files changed, 8 insertions, 8 deletions
diff --git a/www/seamonkey2/Makefile b/www/seamonkey2/Makefile
index 3e6051853e51..bc9fbb87bfc5 100644
--- a/www/seamonkey2/Makefile
+++ b/www/seamonkey2/Makefile
@@ -7,7 +7,7 @@
PORTNAME?= mozilla
PORTVERSION= 1.7.a
-PORTREVISION?= 1
+PORTREVISION?= 2
PORTEPOCH?= 2
CATEGORIES?= www
MASTER_SITES= ${MASTER_SITE_MOZILLA}
@@ -270,10 +270,10 @@ pre-install:
${ECHO_CMD} libdata/pkgconfig/$${pcfile}${MOZ_SUFX}${PKGNAMESUFFIX}.pc >> ${PLIST} ; \
done
cd ${WRKSRC}/dist/include && ${FIND} -s * -type f -o -type l | \
- ${SED} -e 's:^:include/mozilla/:' >> ${PLIST} \
+ ${SED} -e 's:^:include/${MOZILLA}/:' >> ${PLIST} \
&& ${FIND} -d * -type d | \
- ${SED} -e 's:^:@dirrm include/mozilla/:' >> ${PLIST}
- ${ECHO_CMD} @dirrm include/mozilla >> ${PLIST}
+ ${SED} -e 's:^:@dirrm include/${MOZILLA}/:' >> ${PLIST}
+ ${ECHO_CMD} @dirrm include/${MOZILLA} >> ${PLIST}
do-install:
${MKDIR} ${PREFIX}/lib/${MOZILLA}
@@ -300,11 +300,11 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/build/unix/$${pcfile}.pc \
${PREFIX}/libdata/pkgconfig/$${pcfile}${MOZ_SUFX}${PKGNAMESUFFIX}.pc ; \
done
- -${RM} -fr ${PREFIX}/include/mozilla
- ${MKDIR} ${PREFIX}/include/mozilla
- ${CHMOD} 755 ${PREFIX}/include/mozilla
+ -${RM} -fr ${PREFIX}/include/${MOZILLA}
+ ${MKDIR} ${PREFIX}/include/${MOZILLA}
+ ${CHMOD} 755 ${PREFIX}/include/${MOZILLA}
cd ${WRKSRC}/dist/include && ${FIND} . | \
- ${CPIO} -pdm -L -R ${LIBOWN}:${LIBGRP} ${PREFIX}/include/mozilla
+ ${CPIO} -pdm -L -R ${LIBOWN}:${LIBGRP} ${PREFIX}/include/${MOZILLA}
post-install:
@${CHMOD} -R u-w ${PREFIX}/lib/${MOZILLA}/components