aboutsummaryrefslogtreecommitdiff
path: root/www/seamonkey2
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2007-01-18 22:37:11 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2007-01-18 22:37:11 +0000
commitfaa1047dd911a3de51604e2abc47ea61fab2345a (patch)
tree6c3a5ab8efb06f80a334dfa4ebfefe5497a12792 /www/seamonkey2
parentcf7f380693c143bba74cb65cb11bc5099b76e4ec (diff)
downloadports-faa1047dd911a3de51604e2abc47ea61fab2345a.tar.gz
ports-faa1047dd911a3de51604e2abc47ea61fab2345a.zip
Fix the gtk2 dnd implementation broken, see more details in the bugzilla. This
patch[1] was created by Matthias Clasen <mclasen@redhat.com>. This bug was started to reproduce with least 2.10.7 version of gtk2. PR: ports/107689 Reported by: a few users Bugzilla: https://bugzilla.mozilla.org/show_bug.cgi?id=355248 https://bugzilla.mozilla.org/show_bug.cgi?id=367203 [1] http://bugzilla.gnome.org/show_bug.cgi?id=394525
Notes
Notes: svn path=/head/; revision=182762
Diffstat (limited to 'www/seamonkey2')
-rw-r--r--www/seamonkey2/Makefile1
-rw-r--r--www/seamonkey2/files/patch-widget_src_gtk2_nsDragService.cpp18
2 files changed, 19 insertions, 0 deletions
diff --git a/www/seamonkey2/Makefile b/www/seamonkey2/Makefile
index e82fa707f775..ef959d531d47 100644
--- a/www/seamonkey2/Makefile
+++ b/www/seamonkey2/Makefile
@@ -8,6 +8,7 @@
PORTNAME= seamonkey
DISTVERSION= 1.0.7
+PORTREVISION= 1
CATEGORIES?= www ipv6
MASTER_SITES= ${MASTER_SITE_MOZILLA_EXTENDED}
MASTER_SITE_SUBDIR= seamonkey/releases/${DISTVERSION}
diff --git a/www/seamonkey2/files/patch-widget_src_gtk2_nsDragService.cpp b/www/seamonkey2/files/patch-widget_src_gtk2_nsDragService.cpp
new file mode 100644
index 000000000000..df9abaef67cc
--- /dev/null
+++ b/www/seamonkey2/files/patch-widget_src_gtk2_nsDragService.cpp
@@ -0,0 +1,18 @@
+--- widget/src/gtk2/nsDragService.cpp.nograb 2007-01-16 21:26:49.000000000 -0500
++++ widget/src/gtk2/nsDragService.cpp 2007-01-16 21:27:04.000000000 -0500
+@@ -799,7 +799,6 @@
+ void
+ nsDragService::GetTargetDragData(GdkAtom aFlavor)
+ {
+- gtk_grab_add(mHiddenWidget);
+ PR_LOG(sDragLm, PR_LOG_DEBUG, ("getting data flavor %d\n", aFlavor));
+ PR_LOG(sDragLm, PR_LOG_DEBUG, ("mLastWidget is %p and mLastContext is %p\n",
+ mTargetWidget, mTargetDragContext));
+@@ -817,7 +816,6 @@
+ gtk_main_iteration();
+ }
+ PR_LOG(sDragLm, PR_LOG_DEBUG, ("finished inner iteration\n"));
+- gtk_grab_remove(mHiddenWidget);
+ }
+
+ void