aboutsummaryrefslogtreecommitdiff
path: root/www/seamonkey
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-08-04 09:11:25 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-08-04 09:11:25 +0000
commitf92079c61ea2516fd5b1514bae10c743ba63b699 (patch)
tree1e9acf477fa72cf7c888cc484c96bd4f207a487a /www/seamonkey
parent397fa72062e7ed8fab7c8a395a1f9475d9723709 (diff)
downloadports-f92079c61ea2516fd5b1514bae10c743ba63b699.tar.gz
ports-f92079c61ea2516fd5b1514bae10c743ba63b699.zip
Update mozilla ports:
- firefox 31.0 - firefox-esr 24.7.0 - libxul 24.7.0 - seamonkey 2.26.1 - thunderbird 31.0 Among changes: - add workaround for crash with openldap on thunderbird and seamonkey [1] - add crashfix for architectures with strict alignmentment - backport crashfix with system sqlite/nss on firefox-esr and thunderbird - restore hooking jemalloc in sqlite on freebsd 10+ - fix thunderbird build with -jN [2] - respect MAKE_JOBS_NUMBER regardless of kern.smp.cpus [2] - define CPE_URI for nspr/nss and firefox/thunderbird/seamonkey - require recent gstreamer1-libav i386 crashfix - add DTRACE option for use with DTraceToolkit (js_flowtime.d, js_who.d, etc) PR: 165263 [1] PR: 184630 [2] Submitted by: Jan Beich
Notes
Notes: svn path=/head/; revision=363978
Diffstat (limited to 'www/seamonkey')
-rw-r--r--www/seamonkey/Makefile15
-rw-r--r--www/seamonkey/distinfo4
-rw-r--r--www/seamonkey/files/extra-patch-mailnews-extensions-enigmail-config-getOsTarget.pl53
-rw-r--r--www/seamonkey/files/patch-bug102649968
-rw-r--r--www/seamonkey/files/patch-bug102682820
-rw-r--r--www/seamonkey/files/patch-bug104138112
-rw-r--r--www/seamonkey/files/patch-bug104179548
-rw-r--r--www/seamonkey/files/patch-bug292127232
-rw-r--r--www/seamonkey/files/patch-bug70217951
-rw-r--r--www/seamonkey/files/patch-bug77971377
-rw-r--r--www/seamonkey/files/patch-mozilla-ipc-chromium-Makefile.in13
-rw-r--r--www/seamonkey/files/patch-mozilla-ipc-chromium-src-base-message_pump_libevent.cc11
12 files changed, 517 insertions, 87 deletions
diff --git a/www/seamonkey/Makefile b/www/seamonkey/Makefile
index 6d1848b80757..59290f8b7713 100644
--- a/www/seamonkey/Makefile
+++ b/www/seamonkey/Makefile
@@ -3,7 +3,7 @@
PORTNAME= seamonkey
DISTVERSION= 2.26.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES?= www mail news editors irc ipv6
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source \
https://ftp.mozilla.org/pub/mozilla.org/${PORTNAME}/candidates/${DISTVERSION}-candidates/build1/source/
@@ -30,7 +30,7 @@ BUILD_DEPENDS= nspr>=4.10.3:${PORTSDIR}/devel/nspr \
LIB_DEPENDS= libv4l2.so:${PORTSDIR}/multimedia/libv4l
-EM_VERSION= 1.6.1_pre20140112
+EM_VERSION= 1.7
L_VERSION= 3.1
SSP_UNSAFE= yes
@@ -104,11 +104,11 @@ CXXFLAGS+= -O1
.endif
.if ${PORT_OPTIONS:MALSA}
-BUILD_DEPENDS+= alsa-lib>=1.0.27.2_1:${PORTSDIR}/audio/alsa-lib
+RUN_DEPENDS+= alsa-lib>=1.0.27.2_1:${PORTSDIR}/audio/alsa-lib
.endif
.if ${PORT_OPTIONS:MGSTREAMER}
-BUILD_DEPENDS+= gstreamer1-libav>=1.2.4:${PORTSDIR}/multimedia/gstreamer1-libav
+RUN_DEPENDS+= gstreamer1-libav>=1.2.4_1:${PORTSDIR}/multimedia/gstreamer1-libav
.endif
.if ! ${PORT_OPTIONS:MMAILNEWS}
@@ -121,19 +121,17 @@ MOZ_OPTIONS+= --disable-ldap --enable-mailnews
MOZ_OPTIONS+= --enable-ldap --enable-mailnews
.endif
.if ${PORT_OPTIONS:MENIGMAIL}
-#MASTER_SITES+= https://www.enigmail.net/download/source/:enigmail
-MASTER_SITES+= https://dev.gentoo.org/~polynomial-c/mozilla/:enigmail
+MASTER_SITES+= https://www.enigmail.net/download/source/:enigmail
DISTFILES+= ${EM_DISTFILE}:enigmail
RUN_DEPENDS+= gpg:${PORTSDIR}/security/gnupg
EM_DISTNAME= enigmail-${EM_VERSION}
-EM_DISTFILE= ${EM_DISTNAME}.tar.xz
+EM_DISTFILE= ${EM_DISTNAME}.tar.gz
EM_XPI_FILE= ${WRKSRC}/mailnews/extensions/enigmail/build/${EM_DISTNAME}-${OPSYS:tl}-${ARCH:S/amd64/x86_64/:S/i386/x86/}-gcc3.xpi
EM_ORIG_ID= {847b3a00-7ab1-11d4-8f02-006008948af5}
EM_ID= ${PORTNAME}@mozilla-enigmail.org
EM_ID_RFILES= ${XPI_LIBDIR}/${EM_ID}/install.rdf \
${XPI_LIBDIR}/${EM_ID}/components/enigmail.js \
${XPI_LIBDIR}/${EM_ID}/modules/enigmailCommon.jsm
-EXTRA_PATCHES+= ${FILESDIR}/extra-patch-mailnews-extensions-enigmail-config-getOsTarget.pl
.endif
.endif
@@ -173,6 +171,7 @@ post-patch:
${WRKSRC}/mailnews/extensions/enigmail/util/fixlang.pl \
${WRKSRC}/mailnews/extensions/enigmail/util/make-lang-xpi.pl
@${REINPLACE_CMD} -e '/^xpi/s/$$/ all/' \
+ -e '/^all/s/ xpi//' \
-e '/^XPI_MODULE_VERS/s/= .*/= ${EM_VERSION}/' \
${WRKSRC}/mailnews/extensions/enigmail/Makefile
@${REINPLACE_CMD} -e '/em:version/s,>[^<]*<,>${EM_VERSION}<,' \
diff --git a/www/seamonkey/distinfo b/www/seamonkey/distinfo
index 99f153860ac0..1ecb6b2fc7c2 100644
--- a/www/seamonkey/distinfo
+++ b/www/seamonkey/distinfo
@@ -1,4 +1,4 @@
SHA256 (seamonkey-2.26.1.source.tar.bz2) = 741d383c87cc58e38b8d5eef34033a88a4352ff7d76064914bfc05fef1c5d2f3
SIZE (seamonkey-2.26.1.source.tar.bz2) = 165537001
-SHA256 (enigmail-1.6.1_pre20140112.tar.xz) = 2d89a9186c3ccfc9397c933c6f63c0518224fea0096d7a292dba3765de088149
-SIZE (enigmail-1.6.1_pre20140112.tar.xz) = 916028
+SHA256 (enigmail-1.7.tar.gz) = cddbf35783194a4e994f9584ad5bee74750e25f690e81727ba9eccc4f814f161
+SIZE (enigmail-1.7.tar.gz) = 1414100
diff --git a/www/seamonkey/files/extra-patch-mailnews-extensions-enigmail-config-getOsTarget.pl b/www/seamonkey/files/extra-patch-mailnews-extensions-enigmail-config-getOsTarget.pl
deleted file mode 100644
index 06cc849dd649..000000000000
--- a/www/seamonkey/files/extra-patch-mailnews-extensions-enigmail-config-getOsTarget.pl
+++ /dev/null
@@ -1,53 +0,0 @@
-commit 49a1daf
-Author: Patrick Brunschwig <patrick@enigmail.net>
-Date: Tue Jan 28 18:10:54 2014 +0100
-
- fixed detection of compiler type for better supporting cross-compilers
----
- config/getOsTarget.pl | 8 +++++---
- 1 file changed, 5 insertions(+), 3 deletions(-)
-
-diff --git config/getOsTarget.pl config/getOsTarget.pl
-index 91285cd..cf4a233 100755
---- mailnews/extensions/enigmail/config/getOsTarget.pl
-+++ mailnews/extensions/enigmail/config/getOsTarget.pl
-@@ -9,13 +9,15 @@
- # -c : CPU and compiler type
- # -o : OS type
-
-+use File::Basename;
-+
- if ($#ARGV != 3) {
- exit (1);
- }
-
- my $srcOs = $ARGV[1];
- my $srcCpu = $ARGV[2];
--my $srcComp = $ARGV[3];
-+my $srcComp = basename($ARGV[3]);
-
- my $targetOs = "";
- my $targetCpu = "";
-@@ -95,10 +97,10 @@ else {
- if ($targetOs eq "WINNT") {
- $targetComp = "msvc";
- }
--if ($srcComp =~ /^gcc/) {
-+elsif ($srcComp =~ /gcc/ || $srcComp =~ /clang/) {
- $targetComp = "gcc3";
- }
--elsif ($srcComp =~ /^cc/) {
-+elsif ($srcComp =~ /cc/) {
- if ($targetOs eq "SunOS") {
- $targetComp = "sunc";
- }
-@@ -107,6 +109,9 @@ elsif ($srcComp =~ /cc/) {
- elsif ($targetOs eq "AIX") {
- $targetComp = "ibmc";
- }
-+ else {
-+ $targetComp = "gcc3";
-+ }
- }
- else {
- $targetComp = $srcComp;
diff --git a/www/seamonkey/files/patch-bug1026499 b/www/seamonkey/files/patch-bug1026499
new file mode 100644
index 000000000000..729f91a5d8d4
--- /dev/null
+++ b/www/seamonkey/files/patch-bug1026499
@@ -0,0 +1,68 @@
+commit 8d0efe4
+Author: Martin Husemann <martin@NetBSD.org>
+Date: Wed Jun 18 18:12:22 2014 +0200
+
+ Bug 1026499 - Use MOZ_ALIGNED_DECL to declare union members in ipdl value declarations. r=bsmedberg
+---
+ ipc/ipdl/ipdl/cxx/ast.py | 7 ++++---
+ ipc/ipdl/ipdl/cxx/cgen.py | 5 ++++-
+ ipc/ipdl/ipdl/lower.py | 2 +-
+ 4 files changed, 10 insertions(+), 5 deletions(-)
+
+diff --git ipc/ipdl/ipdl/cxx/ast.py ipc/ipdl/ipdl/cxx/ast.py
+index 3180a65..c2d945b 100644
+--- mozilla/ipc/ipdl/ipdl/cxx/ast.py
++++ mozilla/ipc/ipdl/ipdl/cxx/ast.py
+@@ -336,12 +336,13 @@ Type.VOID = Type('void')
+ Type.VOIDPTR = Type('void', ptr=1)
+
+ class TypeArray(Node):
+- def __init__(self, basetype, nmemb):
+- '''the type |basetype DECLNAME[nmemb]|. |nmemb| is an Expr'''
++ def __init__(self, basetype, nmemb, alignType):
++ '''the type |basetype DECLNAME[nmemb]|. |nmemb| is an Expr, |alignType| is a type'''
+ self.basetype = basetype
+ self.nmemb = nmemb
++ self.alignType = alignType
+ def __deepcopy__(self, memo):
+- return TypeArray(deepcopy(self.basetype, memo), nmemb)
++ return TypeArray(deepcopy(self.basetype, memo), nmemb, alignType)
+
+ class TypeEnum(Node):
+ def __init__(self, name=None):
+diff --git ipc/ipdl/ipdl/cxx/cgen.py ipc/ipdl/ipdl/cxx/cgen.py
+index 48b0988..bc914cf 100644
+--- mozilla/ipc/ipdl/ipdl/cxx/cgen.py
++++ mozilla/ipc/ipdl/ipdl/cxx/cgen.py
+@@ -101,6 +101,7 @@ class CxxCodeGen(CodePrinter, Visitor):
+ def visitDecl(self, d):
+ # C-syntax arrays make code generation much more annoying
+ if isinstance(d.type, TypeArray):
++ self.write('MOZ_ALIGNED_DECL(')
+ d.type.basetype.accept(self)
+ else:
+ d.type.accept(self)
+@@ -111,7 +112,9 @@ class CxxCodeGen(CodePrinter, Visitor):
+ if isinstance(d.type, TypeArray):
+ self.write('[')
+ d.type.nmemb.accept(self)
+- self.write(']')
++ self.write('], MOZ_ALIGNOF(')
++ d.type.alignType.accept(self)
++ self.write('))')
+
+ def visitParam(self, p):
+ self.visitDecl(p)
+diff --git ipc/ipdl/ipdl/lower.py ipc/ipdl/ipdl/lower.py
+index e97a34c..9360f3c 100644
+--- mozilla/ipc/ipdl/ipdl/lower.py
++++ mozilla/ipc/ipdl/ipdl/lower.py
+@@ -768,7 +768,7 @@ IPDL union type."""
+ if self.recursive:
+ return self.ptrToType()
+ else:
+- return TypeArray(Type('char'), ExprSizeof(self.internalType()))
++ return TypeArray(Type('char'), ExprSizeof(self.internalType()), self.internalType())
+
+ def unionValue(self):
+ # NB: knows that Union's storage C union is named |mValue|
diff --git a/www/seamonkey/files/patch-bug1026828 b/www/seamonkey/files/patch-bug1026828
new file mode 100644
index 000000000000..b52dcd4e9788
--- /dev/null
+++ b/www/seamonkey/files/patch-bug1026828
@@ -0,0 +1,20 @@
+diff --git storage/src/moz.build storage/src/moz.build
+index 4cd2551..5c40536 100644
+--- mozilla/storage/src/moz.build
++++ mozilla/storage/src/moz.build
+@@ -50,11 +50,14 @@ FINAL_LIBRARY = 'storagecomps'
+ # (such as NSS) might trigger an initialization of sqlite and allocation
+ # of memory using the default allocator, prior to the storage service
+ # registering its allocator, causing memory management failures (bug 938730).
++# However, this is not an issue if both the jemalloc allocator and the default
++# allocator are the same thing.
+ #
+ # Note: On Windows our sqlite build assumes we use jemalloc. If you disable
+ # MOZ_STORAGE_MEMORY on Windows, you will also need to change the "ifdef
+ # MOZ_MEMORY" options in db/sqlite3/src/Makefile.in.
+-if CONFIG['MOZ_MEMORY'] and not CONFIG['MOZ_NATIVE_SQLITE']:
++if CONFIG['MOZ_MEMORY'] and (not CONFIG['MOZ_NATIVE_SQLITE']
++ or CONFIG['MOZ_NATIVE_JEMALLOC']):
+ if CONFIG['OS_TARGET'] != 'Android':
+ DEFINES['MOZ_STORAGE_MEMORY'] = True
+
diff --git a/www/seamonkey/files/patch-bug1041381 b/www/seamonkey/files/patch-bug1041381
new file mode 100644
index 000000000000..a6113b85f077
--- /dev/null
+++ b/www/seamonkey/files/patch-bug1041381
@@ -0,0 +1,12 @@
+diff --git config/rules.mk config/rules.mk
+index 1dee8c3..4d67eda 100644
+--- mozilla/config/rules.mk
++++ mozilla/config/rules.mk
+@@ -822,6 +822,7 @@ endif
+ ifdef DTRACE_PROBE_OBJ
+ EXTRA_DEPS += $(DTRACE_PROBE_OBJ)
+ OBJS += $(DTRACE_PROBE_OBJ)
++EXCLUDED_OBJS += $(DTRACE_PROBE_OBJ)
+ endif
+
+ $(filter %.$(LIB_SUFFIX),$(LIBRARY)): $(OBJS) $(EXTRA_DEPS) $(GLOBAL_DEPS)
diff --git a/www/seamonkey/files/patch-bug1041795 b/www/seamonkey/files/patch-bug1041795
new file mode 100644
index 000000000000..5164776bdde7
--- /dev/null
+++ b/www/seamonkey/files/patch-bug1041795
@@ -0,0 +1,48 @@
+diff --git config/rules.mk config/rules.mk
+index 4d67eda..783942f 100644
+--- mozilla/config/rules.mk
++++ mozilla/config/rules.mk
+@@ -858,7 +858,7 @@ ifdef DTRACE_PROBE_OBJ
+ ifndef DTRACE_LIB_DEPENDENT
+ NON_DTRACE_OBJS := $(filter-out $(DTRACE_PROBE_OBJ),$(OBJS))
+ $(DTRACE_PROBE_OBJ): $(NON_DTRACE_OBJS)
+- dtrace -G -C -s $(MOZILLA_DTRACE_SRC) -o $(DTRACE_PROBE_OBJ) $(NON_DTRACE_OBJS)
++ dtrace -x nolibs -G -C -s $(MOZILLA_DTRACE_SRC) -o $(DTRACE_PROBE_OBJ) $(NON_DTRACE_OBJS)
+ endif
+ endif
+ endif
+@@ -876,7 +876,7 @@ ifndef INCREMENTAL_LINKER
+ endif
+ ifdef DTRACE_LIB_DEPENDENT
+ ifndef XP_MACOSX
+- dtrace -G -C -s $(MOZILLA_DTRACE_SRC) -o $(DTRACE_PROBE_OBJ) $(shell $(EXPAND_LIBS) $(MOZILLA_PROBE_LIBS))
++ dtrace -x nolibs -G -C -s $(MOZILLA_DTRACE_SRC) -o $(DTRACE_PROBE_OBJ) $(shell $(EXPAND_LIBS) $(MOZILLA_PROBE_LIBS))
+ endif
+ $(EXPAND_MKSHLIB) $(SHLIB_LDSTARTFILE) $(OBJS) $(SUB_SHLOBJS) $(DTRACE_PROBE_OBJ) $(MOZILLA_PROBE_LIBS) $(RESFILE) $(LDFLAGS) $(WRAP_LDFLAGS) $(SHARED_LIBRARY_LIBS) $(EXTRA_DSO_LDOPTS) $(MOZ_GLUE_LDFLAGS) $(OS_LIBS) $(EXTRA_LIBS) $(DEF_FILE) $(SHLIB_LDENDFILE) $(if $(LIB_IS_C_ONLY),,$(STLPORT_LIBS))
+ @$(RM) $(DTRACE_PROBE_OBJ)
+diff --git js/src/Makefile.in js/src/Makefile.in
+index 28ca5e8..96793d7 100644
+--- mozilla/js/src/Makefile.in
++++ mozilla/js/src/Makefile.in
+@@ -342,7 +342,7 @@ endif
+
+ ifdef HAVE_DTRACE
+ $(CURDIR)/javascript-trace.h: $(srcdir)/devtools/javascript-trace.d
+- dtrace -h -s $(srcdir)/devtools/javascript-trace.d -o javascript-trace.h.in
++ dtrace -x nolibs -h -s $(srcdir)/devtools/javascript-trace.d -o javascript-trace.h.in
+ sed -e 's/if _DTRACE_VERSION/ifdef INCLUDE_MOZILLA_DTRACE/' \
+ -e '/const/!s/char \*/const char */g' \
+ javascript-trace.h.in > javascript-trace.h
+diff --git probes/Makefile.in probes/Makefile.in
+index 6d18f34..deec83f 100644
+--- mozilla/probes/Makefile.in
++++ mozilla/probes/Makefile.in
+@@ -7,7 +7,7 @@ export:: $(DIST)/include/mozilla-trace.h
+
+ # Replace _DTRACE_VERSION with INCLUDE_MOZILLA_DTRACE
+ $(DIST)/include/mozilla-trace.h: mozilla-trace.d Makefile
+- dtrace -h -s $(srcdir)/mozilla-trace.d -o mozilla-trace.h.tmp
++ dtrace -x nolibs -h -s $(srcdir)/mozilla-trace.d -o mozilla-trace.h.tmp
+ sed -e 's/if _DTRACE_VERSION/ifdef INCLUDE_MOZILLA_DTRACE/' \
+ mozilla-trace.h.tmp > $(DIST)/include/mozilla-trace.h
+ rm mozilla-trace.h.tmp
diff --git a/www/seamonkey/files/patch-bug292127 b/www/seamonkey/files/patch-bug292127
new file mode 100644
index 000000000000..c20ff1d564a3
--- /dev/null
+++ b/www/seamonkey/files/patch-bug292127
@@ -0,0 +1,232 @@
+--- ldap/sdks/c-sdk/ldap/include/ldap.h~
++++ ldap/sdks/c-sdk/ldap/include/ldap.h
+@@ -40,6 +40,229 @@
+ #ifndef _LDAP_H
+ #define _LDAP_H
+
++/* rename symbols to not clash with openldap (bug 292127) */
++#define ldap_abandon moz_ldap_abandon
++#define ldap_abandon_ext moz_ldap_abandon_ext
++#define ldap_abandoned moz_ldap_abandoned
++#define ldap_add moz_ldap_add
++#define ldap_add_ext moz_ldap_add_ext
++#define ldap_add_ext_s moz_ldap_add_ext_s
++#define ldap_add_result_entry moz_ldap_add_result_entry
++#define ldap_add_s moz_ldap_add_s
++#define ldap_ber_free moz_ldap_ber_free
++#define ldap_bind moz_ldap_bind
++#define ldap_bind_s moz_ldap_bind_s
++#define ldap_build_filter moz_ldap_build_filter
++#define ldap_cache_flush moz_ldap_cache_flush
++#define ldap_charray_add moz_ldap_charray_add
++#define ldap_charray_dup moz_ldap_charray_dup
++#define ldap_charray_free moz_ldap_charray_free
++#define ldap_charray_inlist moz_ldap_charray_inlist
++#define ldap_charray_merge moz_ldap_charray_merge
++#define ldap_charray_position moz_ldap_charray_position
++#define ldap_compare moz_ldap_compare
++#define ldap_compare_ext moz_ldap_compare_ext
++#define ldap_compare_ext_s moz_ldap_compare_ext_s
++#define ldap_compare_s moz_ldap_compare_s
++#define ldap_control_free moz_ldap_control_free
++#define ldap_controls_free moz_ldap_controls_free
++#define ldap_count_entries moz_ldap_count_entries
++#define ldap_count_messages moz_ldap_count_messages
++#define ldap_count_references moz_ldap_count_references
++#define ldap_count_values moz_ldap_count_values
++#define ldap_count_values_len moz_ldap_count_values_len
++#define ldap_create_authzid_control moz_ldap_create_authzid_control
++#define ldap_create_filter moz_ldap_create_filter
++#define ldap_create_geteffectiveRights_control moz_ldap_create_geteffectiveRights_control
++#define ldap_create_passwordpolicy_control moz_ldap_create_passwordpolicy_control
++#define ldap_create_passwordpolicy_control_ext moz_ldap_create_passwordpolicy_control_ext
++#define ldap_create_persistentsearch_control moz_ldap_create_persistentsearch_control
++#define ldap_create_proxiedauth_control moz_ldap_create_proxiedauth_control
++#define ldap_create_proxyauth_control moz_ldap_create_proxyauth_control
++#define ldap_create_sort_control moz_ldap_create_sort_control
++#define ldap_create_sort_keylist moz_ldap_create_sort_keylist
++#define ldap_create_userstatus_control moz_ldap_create_userstatus_control
++#define ldap_create_virtuallist_control moz_ldap_create_virtuallist_control
++#define ldap_delete moz_ldap_delete
++#define ldap_delete_ext moz_ldap_delete_ext
++#define ldap_delete_ext_s moz_ldap_delete_ext_s
++#define ldap_delete_result_entry moz_ldap_delete_result_entry
++#define ldap_delete_s moz_ldap_delete_s
++#define ldap_dn2ufn moz_ldap_dn2ufn
++#define ldap_entry2html moz_ldap_entry2html
++#define ldap_entry2html_search moz_ldap_entry2html_search
++#define ldap_entry2text moz_ldap_entry2text
++#define ldap_entry2text_search moz_ldap_entry2text_search
++#define ldap_err2string moz_ldap_err2string
++#define ldap_errlist moz_ldap_errlist
++#define ldap_explode moz_ldap_explode
++#define ldap_explode_dn moz_ldap_explode_dn
++#define ldap_explode_dns moz_ldap_explode_dns
++#define ldap_explode_rdn moz_ldap_explode_rdn
++#define ldap_extended_operation moz_ldap_extended_operation
++#define ldap_extended_operation_s moz_ldap_extended_operation_s
++#define ldap_find_control moz_ldap_find_control
++#define ldap_first_attribute moz_ldap_first_attribute
++#define ldap_first_disptmpl moz_ldap_first_disptmpl
++#define ldap_first_entry moz_ldap_first_entry
++#define ldap_first_message moz_ldap_first_message
++#define ldap_first_reference moz_ldap_first_reference
++#define ldap_first_searchobj moz_ldap_first_searchobj
++#define ldap_first_tmplcol moz_ldap_first_tmplcol
++#define ldap_first_tmplrow moz_ldap_first_tmplrow
++#define ldap_free_friendlymap moz_ldap_free_friendlymap
++#define ldap_free_searchprefs moz_ldap_free_searchprefs
++#define ldap_free_sort_keylist moz_ldap_free_sort_keylist
++#define ldap_free_templates moz_ldap_free_templates
++#define ldap_free_urldesc moz_ldap_free_urldesc
++#define ldap_friendly_name moz_ldap_friendly_name
++#define ldap_get_dn moz_ldap_get_dn
++#define ldap_get_entry_controls moz_ldap_get_entry_controls
++#define ldap_get_lang_values moz_ldap_get_lang_values
++#define ldap_get_lang_values_len moz_ldap_get_lang_values_len
++#define ldap_get_lderrno moz_ldap_get_lderrno
++#define ldap_get_option moz_ldap_get_option
++#define ldap_get_values moz_ldap_get_values
++#define ldap_get_values_len moz_ldap_get_values_len
++#define ldap_getfilter_free moz_ldap_getfilter_free
++#define ldap_getfirstfilter moz_ldap_getfirstfilter
++#define ldap_getnextfilter moz_ldap_getnextfilter
++#define ldap_init moz_ldap_init
++#define ldap_init_getfilter moz_ldap_init_getfilter
++#define ldap_init_getfilter_buf moz_ldap_init_getfilter_buf
++#define ldap_init_searchprefs moz_ldap_init_searchprefs
++#define ldap_init_searchprefs_buf moz_ldap_init_searchprefs_buf
++#define ldap_init_templates moz_ldap_init_templates
++#define ldap_init_templates_buf moz_ldap_init_templates_buf
++#define ldap_is_dns_dn moz_ldap_is_dns_dn
++#define ldap_is_ldap_url moz_ldap_is_ldap_url
++#define ldap_keysort_entries moz_ldap_keysort_entries
++#define ldap_ld_free moz_ldap_ld_free
++#define ldap_memcache_abandon moz_ldap_memcache_abandon
++#define ldap_memcache_append moz_ldap_memcache_append
++#define ldap_memcache_createkey moz_ldap_memcache_createkey
++#define ldap_memcache_destroy moz_ldap_memcache_destroy
++#define ldap_memcache_flush moz_ldap_memcache_flush
++#define ldap_memcache_flush_results moz_ldap_memcache_flush_results
++#define ldap_memcache_get moz_ldap_memcache_get
++#define ldap_memcache_init moz_ldap_memcache_init
++#define ldap_memcache_new moz_ldap_memcache_new
++#define ldap_memcache_result moz_ldap_memcache_result
++#define ldap_memcache_set moz_ldap_memcache_set
++#define ldap_memcache_update moz_ldap_memcache_update
++#define ldap_memfree moz_ldap_memfree
++#define ldap_modify moz_ldap_modify
++#define ldap_modify_ext moz_ldap_modify_ext
++#define ldap_modify_ext_s moz_ldap_modify_ext_s
++#define ldap_modify_s moz_ldap_modify_s
++#define ldap_modrdn moz_ldap_modrdn
++#define ldap_modrdn2 moz_ldap_modrdn2
++#define ldap_modrdn2_s moz_ldap_modrdn2_s
++#define ldap_modrdn_s moz_ldap_modrdn_s
++#define ldap_mods_free moz_ldap_mods_free
++#define ldap_msgdelete moz_ldap_msgdelete
++#define ldap_msgfree moz_ldap_msgfree
++#define ldap_msgid moz_ldap_msgid
++#define ldap_msgtype moz_ldap_msgtype
++#define ldap_multisort_entries moz_ldap_multisort_entries
++#define ldap_name2template moz_ldap_name2template
++#define ldap_next_attribute moz_ldap_next_attribute
++#define ldap_next_disptmpl moz_ldap_next_disptmpl
++#define ldap_next_entry moz_ldap_next_entry
++#define ldap_next_message moz_ldap_next_message
++#define ldap_next_reference moz_ldap_next_reference
++#define ldap_next_searchobj moz_ldap_next_searchobj
++#define ldap_next_tmplcol moz_ldap_next_tmplcol
++#define ldap_next_tmplrow moz_ldap_next_tmplrow
++#define ldap_oc2template moz_ldap_oc2template
++#define ldap_open moz_ldap_open
++#define ldap_parse_authzid_control moz_ldap_parse_authzid_control
++#define ldap_parse_entrychange_control moz_ldap_parse_entrychange_control
++#define ldap_parse_extended_result moz_ldap_parse_extended_result
++#define ldap_parse_passwd moz_ldap_parse_passwd
++#define ldap_parse_passwordpolicy_control moz_ldap_parse_passwordpolicy_control
++#define ldap_parse_passwordpolicy_control_ext moz_ldap_parse_passwordpolicy_control_ext
++#define ldap_parse_reference moz_ldap_parse_reference
++#define ldap_parse_result moz_ldap_parse_result
++#define ldap_parse_sasl_bind_result moz_ldap_parse_sasl_bind_result
++#define ldap_parse_sort_control moz_ldap_parse_sort_control
++#define ldap_parse_userstatus_control moz_ldap_parse_userstatus_control
++#define ldap_parse_virtuallist_control moz_ldap_parse_virtuallist_control
++#define ldap_parse_whoami moz_ldap_parse_whoami
++#define ldap_passwd moz_ldap_passwd
++#define ldap_passwd_s moz_ldap_passwd_s
++#define ldap_passwordpolicy_err2txt moz_ldap_passwordpolicy_err2txt
++#define ldap_perror moz_ldap_perror
++#define ldap_rename moz_ldap_rename
++#define ldap_rename_s moz_ldap_rename_s
++#define ldap_result moz_ldap_result
++#define ldap_result2error moz_ldap_result2error
++#define ldap_sasl_bind moz_ldap_sasl_bind
++#define ldap_sasl_bind_s moz_ldap_sasl_bind_s
++#define ldap_sasl_interactive_bind_ext_s moz_ldap_sasl_interactive_bind_ext_s
++#define ldap_sasl_interactive_bind_s moz_ldap_sasl_interactive_bind_s
++#define ldap_search moz_ldap_search
++#define ldap_search_ext moz_ldap_search_ext
++#define ldap_search_ext_s moz_ldap_search_ext_s
++#define ldap_search_s moz_ldap_search_s
++#define ldap_search_st moz_ldap_search_st
++#define ldap_set_filter_additions moz_ldap_set_filter_additions
++#define ldap_set_lderrno moz_ldap_set_lderrno
++#define ldap_set_option moz_ldap_set_option
++#define ldap_set_rebind_proc moz_ldap_set_rebind_proc
++#define ldap_setfilteraffixes moz_ldap_setfilteraffixes
++#define ldap_simple_bind moz_ldap_simple_bind
++#define ldap_simple_bind_s moz_ldap_simple_bind_s
++#define ldap_sort_entries moz_ldap_sort_entries
++#define ldap_sort_strcasecmp moz_ldap_sort_strcasecmp
++#define ldap_sort_values moz_ldap_sort_values
++#define ldap_start_tls_s moz_ldap_start_tls_s
++#define ldap_str2charray moz_ldap_str2charray
++#define ldap_tmplattrs moz_ldap_tmplattrs
++#define ldap_tmplerr2string moz_ldap_tmplerr2string
++#define ldap_tmplerrlist moz_ldap_tmplerrlist
++#define ldap_ufn_search_c moz_ldap_ufn_search_c
++#define ldap_ufn_search_ct moz_ldap_ufn_search_ct
++#define ldap_ufn_search_ctx moz_ldap_ufn_search_ctx
++#define ldap_ufn_search_s moz_ldap_ufn_search_s
++#define ldap_ufn_setfilter moz_ldap_ufn_setfilter
++#define ldap_ufn_setprefix moz_ldap_ufn_setprefix
++#define ldap_ufn_timeout moz_ldap_ufn_timeout
++#define ldap_unbind moz_ldap_unbind
++#define ldap_unbind_ext moz_ldap_unbind_ext
++#define ldap_unbind_s moz_ldap_unbind_s
++#define ldap_url_parse moz_ldap_url_parse
++#define ldap_url_parse_no_defaults moz_ldap_url_parse_no_defaults
++#define ldap_url_search moz_ldap_url_search
++#define ldap_url_search_s moz_ldap_url_search_s
++#define ldap_url_search_st moz_ldap_url_search_st
++#define ldap_utf8characters moz_ldap_utf8characters
++#define ldap_utf8copy moz_ldap_utf8copy
++#define ldap_utf8getcc moz_ldap_utf8getcc
++#define ldap_utf8isalnum moz_ldap_utf8isalnum
++#define ldap_utf8isalpha moz_ldap_utf8isalpha
++#define ldap_utf8isdigit moz_ldap_utf8isdigit
++#define ldap_utf8isspace moz_ldap_utf8isspace
++#define ldap_utf8isxdigit moz_ldap_utf8isxdigit
++#define ldap_utf8len moz_ldap_utf8len
++#define ldap_utf8next moz_ldap_utf8next
++#define ldap_utf8prev moz_ldap_utf8prev
++#define ldap_utf8strtok_r moz_ldap_utf8strtok_r
++#define ldap_vals2html moz_ldap_vals2html
++#define ldap_vals2text moz_ldap_vals2text
++#define ldap_value_free moz_ldap_value_free
++#define ldap_value_free_len moz_ldap_value_free_len
++#define ldap_version moz_ldap_version
++#define ldap_whoami moz_ldap_whoami
++#define ldap_whoami_s moz_ldap_whoami_s
++#define ldap_x_calloc moz_ldap_x_calloc
++#define ldap_x_free moz_ldap_x_free
++#define ldap_x_hostlist_first moz_ldap_x_hostlist_first
++#define ldap_x_hostlist_next moz_ldap_x_hostlist_next
++#define ldap_x_hostlist_statusfree moz_ldap_x_hostlist_statusfree
++#define ldap_x_malloc moz_ldap_x_malloc
++#define ldap_x_realloc moz_ldap_x_realloc
++
+ /* Standard LDAP API functions and declarations */
+ #include "ldap-standard.h"
+
diff --git a/www/seamonkey/files/patch-bug702179 b/www/seamonkey/files/patch-bug702179
new file mode 100644
index 000000000000..5f90f96d19ae
--- /dev/null
+++ b/www/seamonkey/files/patch-bug702179
@@ -0,0 +1,51 @@
+commit 6ddaacd
+Author: Ginn Chen <ginn.chen@oracle.com>
+Date: Wed Nov 30 07:23:46 2011 +0800
+
+ Bug 702179 dtrace probes are not installed on Solaris with static js lib r=glandium
+---
+ configure.in | 2 +-
+ js/src/Makefile.in | 2 --
+ 2 files changed, 1 insertion(+), 3 deletions(-)
+
+diff --git configure.in configure.in
+index 66549c1..75b848d 100644
+--- mozilla/configure.in
++++ mozilla/configure.in
+@@ -966,7 +966,7 @@ MOZ_BZ2_LIBS='$(call EXPAND_LIBNAME_PATH,bz2,$(DEPTH)/modules/libbz2/src)'
+ MOZ_PNG_CFLAGS="-I$_objdir/dist/include" # needed for freetype compilation
+ MOZ_PNG_LIBS='$(call EXPAND_LIBNAME_PATH,mozpng,$(DEPTH)/media/libpng)'
+
+-MOZ_JS_STATIC_LIBS='$(call EXPAND_LIBNAME_PATH,js_static,$(LIBXUL_DIST)/lib)'
++MOZ_JS_STATIC_LIBS='$(call EXPAND_LIBNAME_PATH,js_static,$(DEPTH)/js/src/js/src)'
+ MOZ_JS_SHARED_LIBS='$(call EXPAND_LIBNAME_PATH,mozjs,$(LIBXUL_DIST)/lib)'
+ MOZ_FIX_LINK_PATHS='-Wl,-rpath-link,$(LIBXUL_DIST)/bin -Wl,-rpath-link,$(prefix)/lib'
+ XPCOM_FROZEN_LDOPTS='$(call EXPAND_LIBNAME_PATH,xul mozalloc,$(LIBXUL_DIST)/bin)'
+diff --git js/src/Makefile.in js/src/Makefile.in
+index e28160a..28ca5e8 100644
+--- mozilla/js/src/Makefile.in
++++ mozilla/js/src/Makefile.in
+@@ -18,8 +18,6 @@ run_for_side_effects := $(shell echo 'MAKE: $(MAKE)')
+ STATIC_LIBRARY_NAME = js_static
+ LIBS = $(NSPR_LIBS)
+
+-DIST_INSTALL = 1
+-
+ ifdef JS_STANDALONE
+ SHARED_LIBRARY_LIBS += $(call EXPAND_LIBNAME_PATH,mfbt,$(DEPTH)/mfbt)
+ ifndef MOZ_NATIVE_ZLIB
+diff --git suite/build/Makefile.in suite/build/Makefile.in
+index 66549c1..75b848d 100644
+--- suite/build/Makefile.in
++++ suite/build/Makefile.in
+@@ -33,6 +33,10 @@ EXTRA_DSO_LDOPTS += \
+ $(TK_LIBS) \
+ $(NULL)
+
++ifndef ZLIB_IN_MOZGLUE
++EXTRA_DSO_LDOPTS += $(MOZ_ZLIB_LIBS)
++endif
++
+ include $(topsrcdir)/config/rules.mk
+
+ # Ensure that we don't embed a manifest referencing the CRT.
diff --git a/www/seamonkey/files/patch-bug779713 b/www/seamonkey/files/patch-bug779713
new file mode 100644
index 000000000000..cb721cba24a4
--- /dev/null
+++ b/www/seamonkey/files/patch-bug779713
@@ -0,0 +1,77 @@
+diff --git mfbt/Alignment.h mfbt/Alignment.h
+index e0843ca..353ec36 100644
+--- mozilla/mfbt/Alignment.h
++++ mozilla/mfbt/Alignment.h
+@@ -9,11 +9,20 @@
+ #ifndef mozilla_Alignment_h
+ #define mozilla_Alignment_h
+
++#include "mozilla/Attributes.h"
++
+ #include <stddef.h>
+ #include <stdint.h>
+
+ namespace mozilla {
+
++#if defined(MOZ_HAVE_CXX11_ALIGNAS)
++#define MOZ_ALIGNOF(T) alignof(T)
++#elif defined(__GNUC__)
++#define MOZ_ALIGNOF(T) __alignof__(T)
++#elif defined(_MSC_VER)
++#define MOZ_ALIGNOF(T) __alignof(T)
++#else
+ /*
+ * This class, and the corresponding macro MOZ_ALIGNOF, figures out how many
+ * bytes of alignment a given type needs.
+@@ -32,6 +41,7 @@ public:
+ };
+
+ #define MOZ_ALIGNOF(T) mozilla::AlignmentFinder<T>::alignment
++#endif
+
+ /*
+ * Declare the MOZ_ALIGNED_DECL macro for declaring aligned types.
+@@ -43,7 +53,10 @@ public:
+ * will declare a two-character array |arr| aligned to 8 bytes.
+ */
+
+-#if defined(__GNUC__)
++#if defined(MOZ_HAVE_CXX11_ALIGNAS)
++# define MOZ_ALIGNED_DECL(_type, _align) \
++ alignas(_align) _type
++#elif defined(__GNUC__)
+ # define MOZ_ALIGNED_DECL(_type, _align) \
+ _type __attribute__((aligned(_align)))
+ #elif defined(_MSC_VER)
+diff --git mfbt/Attributes.h mfbt/Attributes.h
+index d317766..ddb13da 100644
+--- mozilla/mfbt/Attributes.h
++++ mozilla/mfbt/Attributes.h
+@@ -54,6 +54,9 @@
+ # ifndef __has_extension
+ # define __has_extension __has_feature /* compatibility, for older versions of clang */
+ # endif
++# if __has_extension(cxx_alignas)
++# define MOZ_HAVE_CXX11_ALIGNAS
++# endif
+ # if __has_extension(cxx_constexpr)
+ # define MOZ_HAVE_CXX11_CONSTEXPR
+ # endif
+@@ -75,6 +78,9 @@
+ # endif
+ #elif defined(__GNUC__)
+ # if defined(__GXX_EXPERIMENTAL_CXX0X__) || __cplusplus >= 201103L
++# if MOZ_GCC_VERSION_AT_LEAST(4, 8, 0)
++# define MOZ_HAVE_CXX11_ALIGNAS
++# endif
+ # if MOZ_GCC_VERSION_AT_LEAST(4, 7, 0)
+ # define MOZ_HAVE_CXX11_OVERRIDE
+ # define MOZ_HAVE_CXX11_FINAL final
+@@ -96,6 +102,7 @@
+ # define MOZ_HAVE_NORETURN __attribute__((noreturn))
+ #elif defined(_MSC_VER)
+ # if _MSC_VER >= 1800
++# define MOZ_HAVE_CXX11_ALIGNAS
+ # define MOZ_HAVE_CXX11_DELETE
+ # endif
+ # if _MSC_VER >= 1700
diff --git a/www/seamonkey/files/patch-mozilla-ipc-chromium-Makefile.in b/www/seamonkey/files/patch-mozilla-ipc-chromium-Makefile.in
deleted file mode 100644
index 727a86a4c3bc..000000000000
--- a/www/seamonkey/files/patch-mozilla-ipc-chromium-Makefile.in
+++ /dev/null
@@ -1,13 +0,0 @@
---- mozilla/ipc/chromium/Makefile.in~
-+++ mozilla/ipc/chromium/Makefile.in
-@@ -55,9 +60,7 @@ vpath %.c \
- $(srcdir)/src/third_party/libevent \
- $(NULL)
- else # } else {
--# message_pump_libevent.cc includes third_party/libevent/event.h,
--# which we put in $(DIST), see export rule below
--LOCAL_INCLUDES += -I$(DIST)
-+LOCAL_INCLUDES += $(filter %/compat, $(MOZ_LIBEVENT_CFLAGS))
- endif # }
-
- vpath %.cc \
diff --git a/www/seamonkey/files/patch-mozilla-ipc-chromium-src-base-message_pump_libevent.cc b/www/seamonkey/files/patch-mozilla-ipc-chromium-src-base-message_pump_libevent.cc
deleted file mode 100644
index ba9c0d6d3416..000000000000
--- a/www/seamonkey/files/patch-mozilla-ipc-chromium-src-base-message_pump_libevent.cc
+++ /dev/null
@@ -1,11 +0,0 @@
---- mozilla/ipc/chromium/src/base/message_pump_libevent.cc~
-+++ mozilla/ipc/chromium/src/base/message_pump_libevent.cc
-@@ -16,7 +16,7 @@
- #include "base/scoped_ptr.h"
- #include "base/time.h"
- #include "nsDependentSubstring.h"
--#include "third_party/libevent/event.h"
-+#include "event.h"
-
- // Lifecycle of struct event
- // Libevent uses two main data structures: