aboutsummaryrefslogtreecommitdiff
path: root/www/sitecopy
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2010-07-30 22:14:49 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2010-07-30 22:14:49 +0000
commit113641e728e938d480f5c33ddd6a1ad6b06c2ab7 (patch)
tree13d8a1389a6f4c52c2e1d9583ff1313b5292a6bb /www/sitecopy
parent7bb5db52e1a44398d3bc9df3190bdfa7fc4375ec (diff)
downloadports-113641e728e938d480f5c33ddd6a1ad6b06c2ab7.tar.gz
ports-113641e728e938d480f5c33ddd6a1ad6b06c2ab7.zip
- Makes neon29 our default neon library. The neon 0.27.x to 0.29.x are API and
ABI backwards compatible. It is unnecessary to have more than one same libraries (ie: neon28 and neon29) as it creates issue in our ports tree such as CONFLICTS and made our Makefile complicate. - Remove www/neonpp and www/neon28. - Add USE_GNOME=ltverhack; it corrects the shared library version by change from libneon.so.29 to libneon.so.27. It won't get bump again with no reason unless ABI changes. - Bump the PORTREVISION on all ports and chase the shared library change. - Add info in the UPDATING for how to rebuild on all ports that depend on neon. PR: ports/148295 Approved by: lev (maintainer timeout, no respone for months), portmgr Tested by: pointyhat-exp by pav
Notes
Notes: svn path=/head/; revision=258515
Diffstat (limited to 'www/sitecopy')
-rw-r--r--www/sitecopy/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/www/sitecopy/Makefile b/www/sitecopy/Makefile
index 7570a20043cb..08cc3899ef80 100644
--- a/www/sitecopy/Makefile
+++ b/www/sitecopy/Makefile
@@ -7,7 +7,7 @@
PORTNAME= sitecopy
PORTVERSION= 0.16.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= http://www.manyfish.co.uk/${PORTNAME}/ \
${MASTER_SITE_GENTOO}
@@ -16,7 +16,7 @@ MASTER_SITE_SUBDIR= distfiles
MAINTAINER= olgeni@FreeBSD.org
COMMENT= Maintains remote websites, uses FTP or WebDAV to sync up with local copy
-LIB_DEPENDS= neon.28:${PORTSDIR}/www/neon28
+LIB_DEPENDS= neon.27:${PORTSDIR}/www/neon29
GNU_CONFIGURE= yes
CONFIGURE_ENV= CC="${CC} -I${LOCALBASE}/include" \
@@ -36,5 +36,7 @@ MAN1= sitecopy.1
post-patch:
@${REINPLACE_CMD} -e 's|;;|;|g' \
${WRKSRC}/src/sitestore.c
+ @${REINPLACE_CMD} -e 's|25 26 27 28|25 26 27 28 29|g' \
+ ${WRKSRC}/configure
.include <bsd.port.mk>