aboutsummaryrefslogtreecommitdiff
path: root/www/smb2www
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-05-11 05:54:12 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-05-11 05:54:12 +0000
commitd18ac9fb20e3ad37c0041bfb519b6128608814c6 (patch)
tree8a8f5a4ec41b272fff8afaa99939e53204e2f943 /www/smb2www
parentb63d6e74fbda119954fefdac08a0ec61d08e106e (diff)
downloadports-d18ac9fb20e3ad37c0041bfb519b6128608814c6.tar.gz
ports-d18ac9fb20e3ad37c0041bfb519b6128608814c6.zip
- Adopt
- Remove apache from RUN_DEPENDS - USE_COMPAT is deprecated - Remove IS_INTERACTIVE and patch - Use WWWDIR in pkg-plist - Bump PORTREVISION
Notes
Notes: svn path=/head/; revision=233671
Diffstat (limited to 'www/smb2www')
-rw-r--r--www/smb2www/Makefile14
-rw-r--r--www/smb2www/files/patch-Install.pl133
-rw-r--r--www/smb2www/pkg-plist70
3 files changed, 132 insertions, 85 deletions
diff --git a/www/smb2www/Makefile b/www/smb2www/Makefile
index fbc68968e77b..8dbdf13f33de 100644
--- a/www/smb2www/Makefile
+++ b/www/smb2www/Makefile
@@ -7,24 +7,22 @@
PORTNAME= smb2www
PORTVERSION= 0.0.980804
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SAMBA}
MASTER_SITE_SUBDIR= smb2www
DISTNAME= ${PORTNAME}-${PORTVERSION:S/0.0.//g}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= pgollucci@FreeBSD.org
COMMENT= Windows Network client that is accessible through a web browser
-RUN_DEPENDS= httpd:${PORTSDIR}/${APACHE_PORT} \
- smbclient:${PORTSDIR}/net/samba3 \
- ${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64
+RUN_DEPENDS= smbclient:${PORTSDIR}/net/samba3 \
+ ${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64
-IS_INTERACTIVE= yes
-NO_BUILD= yes
+USE_APACHE= 1.3
USE_PERL5= yes
+NO_BUILD= yes
WRKSRC= ${WRKDIR}
-APACHE_COMPAT= yes
do-install:
@cd ${WRKSRC}; ${PERL} ${WRKSRC}/Install.pl
diff --git a/www/smb2www/files/patch-Install.pl b/www/smb2www/files/patch-Install.pl
index 4b8c5f13d317..56c7a05d7028 100644
--- a/www/smb2www/files/patch-Install.pl
+++ b/www/smb2www/files/patch-Install.pl
@@ -1,61 +1,110 @@
---- Install.pl.orig Sun Aug 2 21:31:40 1998
-+++ Install.pl Sun Mar 25 17:53:37 2001
-@@ -19,24 +19,24 @@
- if ($is_root == 1) {
- while (! getpwnam($uname)) {
- print "$uname is not a valid username.\n" if (! $uname eq "");
+--- ./Install.pl.orig 2009-05-11 05:39:12.000000000 +0000
++++ ./Install.pl 2009-05-11 05:46:51.000000000 +0000
+@@ -7,38 +7,11 @@
+ chop $version;
+ close VERSION;
+
+-print <<"EOF";
+-
+-Welcome to the installation of SMB2WWW, release $version.
+-Press <Return> to continue, or press <Ctrl-C> to stop.
+-EOF
+
+-$foo=<STDIN>;
+-
+-
+-if ($is_root == 1) {
+- while (! getpwnam($uname)) {
+- print "$uname is not a valid username.\n" if (! $uname eq "");
- print "What username shall I use to install smb2www [www-data] ? ";
-+ print "What username shall I use to install smb2www [nobody] ? ";
- $uname=<STDIN>;
- chop $uname;
+- $uname=<STDIN>;
+- chop $uname;
- $uname = "www-data" if ($uname eq "");
-+ $uname = "nobody" if ($uname eq "");
- }
-
- while (! getgrnam($gname)) {
- print "$gname is not a valid groupname.\n" if (! $gname eq "");
+- }
+-
+- while (! getgrnam($gname)) {
+- print "$gname is not a valid groupname.\n" if (! $gname eq "");
- print "What groupname shall I use to install smb2www [www-data] ? ";
-+ print "What groupname shall I use to install smb2www [nobody] ? ";
- $gname= <STDIN>;
- chop $gname;
+- $gname= <STDIN>;
+- chop $gname;
- $gname = "www-data" if ($gname eq "");
-+ $gname = "nobody" if ($gname eq "");
- }
- }
+- }
+-}
++$uname = 'nobody';
++$gname = 'nobody';
-print "Where shall I put smb2www [/usr/local/smb2www] ? ";
-+print "Where shall I put smb2www [/usr/local/www/smb2www] ? ";
- $dir=<STDIN>; chop $dir;
+-$dir=<STDIN>; chop $dir;
-if ( $dir eq "") { $dir = "/usr/local/smb2www" };
-+if ( $dir eq "") { $dir = "/usr/local/www/smb2www" };
- print "\n";
- die "Directory already exists ! Move first before continuing !" if ( -d $dir);
+-print "\n";
+-die "Directory already exists ! Move first before continuing !" if ( -d $dir);
++$dir = '/usr/local/www/smb2www';
mkdir "$dir",0755 or die "Unable to create directory ! Check your permissions.";
-@@ -59,9 +59,9 @@
- $smbc = "";
- while (not -x "$smbc/smbclient" ) {
+ print "\nDirectory $dir created successfully.\nNow creating subdirectories.\n";
+@@ -57,54 +30,24 @@
+ print "done.\n\n";
+ }
+
+-$smbc = "";
+-while (not -x "$smbc/smbclient" ) {
- print "In which directory is smbclient located [/usr/local/samba/bin] ? ";
-+ print "In which directory is smbclient located [/usr/local/bin] ? ";
- $smbc=<STDIN>; chop $smbc;
+- $smbc=<STDIN>; chop $smbc;
- if ( $smbc eq "") { $smbc = "/usr/local/samba/bin" };
-+ if ( $smbc eq "") { $smbc = "/usr/local/bin" };
- print "\n";
+- print "\n";
+-}
++$smbc = "/usr/local/bin";
+
+ symlink "$smbc/smbclient","$dir/bin/smbclient" or die "unable to symlink smbclient to $dir/bin !\n";
+
+-$perl = "";
+-while (not -x "$perl" ){
+- print "What is your perl 5 binary [/usr/bin/perl] ? ";
+- $perl=<STDIN>; chop $perl;
+- if ( $perl eq "") { $perl = "/usr/bin/perl" };
+- print "\n";
+-}
++$perl = "/usr/bin/perl";
+
+-print "Which server shall I use as master browser ? ";
+-$mbrowse=<STDIN>; chop $mbrowse;
+-print "\n";
++$mbrowse='localhost';
+
+ srand ( time ^ ($$ + ($$ << 15)) );
+ while (length $key < 25) {
+ $key = $key.chr(rand(64)+64);
}
+-print "Which language would you like to use with SMB2WWW ?\n (english dutch finnish) [english] ";
+-$language = <STDIN>; chop $language;
+-if ( $language eq "" ) { $language = "english" };
+-print "\n";
+-
+-
+-
+-print "Which path shall I use for SMB2WWW pictures on your webserver\n[/smbimg] ? ";
+-$imgpath=<STDIN>; chop $imgpath;
+-if ( $imgpath eq "" ) { $imgpath = "/smbimg" };
+-print "\n";
++$language = 'english';
-@@ -100,9 +100,9 @@
- if ( $cgiroot eq "" ) { $cgiroot = "/samba" };
- print "\n";
+-print "Which path shall I use as SMB2WWW root on your webserver [/samba] ? ";
+-$cgiroot=<STDIN>; chop $cgiroot;
+-if ( $cgiroot eq "" ) { $cgiroot = "/samba" };
+-print "\n";
++$imgpath='/sbming';
++$cgiroot='/samba';
-print "Where is your mime.types file [/etc] ? ";
-+print "Where is your mime.types file [/usr/local/etc/apache] ? ";
- $mime=<STDIN>; chop $mime;
+-$mime=<STDIN>; chop $mime;
-if ( $mime eq "" ) { $mime = "/etc" };
-+if ( $mime eq "" ) { $mime = "/usr/local/etc/apache" };
- $mime= $mime."/mime.types";
- print "\n";
+-$mime= $mime."/mime.types";
+-print "\n";
++$mime='/usr/local/etc/apache';
+
+ print "Now modifying scripts and configuration files...\n\n";
-@@ -124,7 +124,7 @@
+@@ -124,7 +67,7 @@
cfgdir = $dir/etc
imgroot = $imgpath
cgiroot = $cgiroot
@@ -64,7 +113,7 @@
background = cloud.gif
icon_other = world.gif
icon_all = network.gif
-@@ -209,6 +209,6 @@
+@@ -209,6 +152,6 @@
print "\nAdd this to your apache config:\n";
print "-------------------------------\n\n";
print "Alias $imgpath $dir/images\n";
diff --git a/www/smb2www/pkg-plist b/www/smb2www/pkg-plist
index b776e850c6cf..70a43f8ba0c9 100644
--- a/www/smb2www/pkg-plist
+++ b/www/smb2www/pkg-plist
@@ -1,35 +1,35 @@
-www/smb2www/bin/smbclient
-www/smb2www/images/archive.gif
-www/smb2www/images/share.gif
-www/smb2www/images/search.gif
-www/smb2www/images/printer.gif
-www/smb2www/images/network.gif
-www/smb2www/images/message.gif
-www/smb2www/images/help.gif
-www/smb2www/images/group.gif
-www/smb2www/images/folder.gif
-www/smb2www/images/file.gif
-www/smb2www/images/computer.gif
-www/smb2www/images/cloud.gif
-www/smb2www/images/world.gif
-www/smb2www/cgi-bin/smbfile.pl
-www/smb2www/cgi-bin/smbtar.pl
-www/smb2www/cgi-bin/smbhelp.pl
-www/smb2www/cgi-bin/smbshr.pl
-www/smb2www/cgi-bin/smbdir.pl
-www/smb2www/cgi-bin/smbgrp.pl
-www/smb2www/cgi-bin/smb2www.pl
-www/smb2www/cgi-bin/smbmsg.pl
-www/smb2www/cgi-bin/smb2www.pm
-www/smb2www/etc/smb2www.conf
-www/smb2www/etc/finnish_help.lang
-www/smb2www/etc/finnish.lang
-www/smb2www/etc/english_help.lang
-www/smb2www/etc/english.lang
-www/smb2www/etc/dutch_help.lang
-www/smb2www/etc/dutch.lang
-@dirrm www/smb2www/images
-@dirrm www/smb2www/cgi-bin
-@dirrm www/smb2www/bin
-@dirrm www/smb2www/etc
-@dirrm www/smb2www
+%%WWWDIR%%/bin/smbclient
+%%WWWDIR%%/images/archive.gif
+%%WWWDIR%%/images/share.gif
+%%WWWDIR%%/images/search.gif
+%%WWWDIR%%/images/printer.gif
+%%WWWDIR%%/images/network.gif
+%%WWWDIR%%/images/message.gif
+%%WWWDIR%%/images/help.gif
+%%WWWDIR%%/images/group.gif
+%%WWWDIR%%/images/folder.gif
+%%WWWDIR%%/images/file.gif
+%%WWWDIR%%/images/computer.gif
+%%WWWDIR%%/images/cloud.gif
+%%WWWDIR%%/images/world.gif
+%%WWWDIR%%/cgi-bin/smbfile.pl
+%%WWWDIR%%/cgi-bin/smbtar.pl
+%%WWWDIR%%/cgi-bin/smbhelp.pl
+%%WWWDIR%%/cgi-bin/smbshr.pl
+%%WWWDIR%%/cgi-bin/smbdir.pl
+%%WWWDIR%%/cgi-bin/smbgrp.pl
+%%WWWDIR%%/cgi-bin/smb2www.pl
+%%WWWDIR%%/cgi-bin/smbmsg.pl
+%%WWWDIR%%/cgi-bin/smb2www.pm
+%%WWWDIR%%/etc/smb2www.conf
+%%WWWDIR%%/etc/finnish_help.lang
+%%WWWDIR%%/etc/finnish.lang
+%%WWWDIR%%/etc/english_help.lang
+%%WWWDIR%%/etc/english.lang
+%%WWWDIR%%/etc/dutch_help.lang
+%%WWWDIR%%/etc/dutch.lang
+@dirrm %%WWWDIR%%/images
+@dirrm %%WWWDIR%%/cgi-bin
+@dirrm %%WWWDIR%%/bin
+@dirrm %%WWWDIR%%/etc
+@dirrm %%WWWDIR%%