aboutsummaryrefslogtreecommitdiff
path: root/www/squid30
diff options
context:
space:
mode:
authorAdrian Chadd <adrian@FreeBSD.org>2001-03-27 12:28:47 +0000
committerAdrian Chadd <adrian@FreeBSD.org>2001-03-27 12:28:47 +0000
commit88dd211266913d0df8c20d25df96c11041e4f94c (patch)
treeedff426bdf7c55288de3d1aa4ac38e64c1c2c382 /www/squid30
parentaba319a01e6dcfb3fd15e9d20f6f1b1eb40b519e (diff)
downloadports-88dd211266913d0df8c20d25df96c11041e4f94c.tar.gz
ports-88dd211266913d0df8c20d25df96c11041e4f94c.zip
PR: 26059
Update the squid-2.4 port to actually _be_ squid-2.4 . Phew. This port builds, installs, packages, pkg_delete's cleanly. I'm going to run it through some more linting and tidying up before I'm completely done with it. Differences from squid22/squid23 : * install-pinger isn't built. I'll tackle this later, possibly by creating a squid user/group. I don't like having suid binaries installed, even more so when 99% of the users of this port won't even enable ICMP pinging. * I've enabled the lru and heap replacement policies. LRU is used by default, the beauty here is that the user can choose one or the other without needing a recompile. * I've enabled ufs (sync), diskd (async) and null (no caching, only proxying). This again lets users choose what they want without needing a recompile. The default is still a 100mb cache in /usr/local/squid/cache/ running ufs. I would change it to diskd but if the user hasn't tweaked their sysV shm/msg parameters sufficiently they'll just be puzzled when squid gives mysterious sysV errors (and if they load it up enough to have UFS become an issue, they'd be better off reading the squid FAQ anyhow..)
Notes
Notes: svn path=/head/; revision=40434
Diffstat (limited to 'www/squid30')
-rw-r--r--www/squid30/Makefile28
-rw-r--r--www/squid30/distinfo9
-rw-r--r--www/squid30/pkg-descr4
-rw-r--r--www/squid30/pkg-install4
-rw-r--r--www/squid30/pkg-plist82
5 files changed, 64 insertions, 63 deletions
diff --git a/www/squid30/Makefile b/www/squid30/Makefile
index 0421718cc61a..911bca9dc3d8 100644
--- a/www/squid30/Makefile
+++ b/www/squid30/Makefile
@@ -6,33 +6,30 @@
#
PORTNAME= squid
-PORTVERSION= 2.3
+PORTVERSION= 2.4
CATEGORIES= www
MASTER_SITES= \
ftp://ftp.squid-cache.org/pub/squid-2/STABLE/ \
ftp://www.unimelb.edu.au/pub/cwis/servers/unix/squid/squid-2/STABLE/ \
ftp://sunsite.auc.dk/pub/infosystems/squid/squid-2/STABLE/ \
ftp://ftp.net.lut.ac.uk/squid/squid-2/STABLE/
-DISTNAME= squid-2.3.STABLE4
+DISTNAME= squid-2.4.STABLE1
EXTRACT_SUFX= -src.tar.gz
-PATCH_SITES= http://www.squid-cache.org/Versions/v2/2.3/bugs/
-PATCHFILES= squid-2.3.stable4-ftp_icon_not_found.patch \
- squid-2.3.stable4-internal_dns_rcode_table_formatting.patch \
- squid-2.3.stable4-ipfw_configure.patch \
- squid-2.3.stable4-invalid_ip_acl_entry.patch \
- squid-2.3.stable4-accel_only_access.patch \
- squid-2.3.stable4-html_quoting.patch \
- squid-2.3.stable4-carp-assertion.patch
+PATCH_SITES= http://www.squid-cache.org/Versions/v2/2.4/bugs/
+PATCHFILES=
MAINTAINER= adrian@freebsd.org
-DIST_SUBDIR= squid2.3
+DIST_SUBDIR= squid2.4
PATCH_DIST_STRIP= -p0
GNU_CONFIGURE= yes
# Follow the apache port's lead...
CONFIGURE_ARGS= --bindir=${PREFIX}/sbin --sysconfdir=${PREFIX}/etc/squid \
- --localstatedir=${PREFIX}/squid
+ --localstatedir=${PREFIX}/squid \
+ --enable-storeio="ufs diskd null" \
+ --enable-removal-policies="lru heap" \
+
STRIP= # won't install scripts correctly otherwise.
MAKEFILE= makefile
@@ -49,8 +46,6 @@ MAKEFILE= makefile
#CONFIGURE_ARGS+= --enable-xmalloc-statistics
# - Enable CARP support
#CONFIGURE_ARGS+= --enable-carp
-# - Use ASYNC disk I/O (Requires real threads, apparently runs on 3.0 libc_r)
-#CONFIGURE_ARGS+= --enable-async-io
# - Enable ICMP pinging for heirarchy stats and selection
#CONFIGURE_ARGS+= --enable-icmp
# - Enable delay pools to limit bandwidth usage
@@ -101,7 +96,10 @@ post-extract:
@${PERL} -pi -e 's|-lpthread|-pthread|g' ${WRKSRC}/configure
post-install:
- cd ${WRKSRC}/src; make install-pinger
+# I don't think many people use the pinger nowadays, and if you
+# do you'll want squid in its own group so as to restrict access
+# to it.
+# cd ${WRKSRC}/src; make install-pinger
.for file in client squid
if [ -f ${PREFIX}/sbin/${file} ] ; then \
strip ${PREFIX}/sbin/${file} ; \
diff --git a/www/squid30/distinfo b/www/squid30/distinfo
index 8a7788b702d2..2251e5889514 100644
--- a/www/squid30/distinfo
+++ b/www/squid30/distinfo
@@ -1,8 +1 @@
-MD5 (squid2.3/squid-2.3.STABLE4-src.tar.gz) = c38c083f44c222a8d026fa129c30b98f
-MD5 (squid2.3/squid-2.3.stable4-ftp_icon_not_found.patch) = f1383b24672f9a8317c2c16302a94eaa
-MD5 (squid2.3/squid-2.3.stable4-internal_dns_rcode_table_formatting.patch) = bec46f5a1fcbd9aa1deb9d518c5c11a5
-MD5 (squid2.3/squid-2.3.stable4-ipfw_configure.patch) = 4453c53a712280a26fdca42c950bc94f
-MD5 (squid2.3/squid-2.3.stable4-invalid_ip_acl_entry.patch) = 436eb77056bed5d45547c739d1123bd3
-MD5 (squid2.3/squid-2.3.stable4-accel_only_access.patch) = db8e4eb9c1712a4adde7e9aaed0b5249
-MD5 (squid2.3/squid-2.3.stable4-html_quoting.patch) = 68228709d011c93c2cccd9ac723fb462
-MD5 (squid2.3/squid-2.3.stable4-carp-assertion.patch) = c3d48a2b4fc26c0d90eb4c30ae34d3d6
+MD5 (squid2.4/squid-2.4.STABLE1-src.tar.gz) = 6a3977716571a8459cf66b96306f7c05
diff --git a/www/squid30/pkg-descr b/www/squid30/pkg-descr
index 646e01da5b32..a030d6c271b8 100644
--- a/www/squid30/pkg-descr
+++ b/www/squid30/pkg-descr
@@ -11,7 +11,7 @@ continued development of the cache where Harvest finished.
FreeBSD PORTER'S NOTES. To this moment, Squid is not well documented.
But you aren't lost in space: there is a mailing list,
-<squid-users@nlanr.net>, where you will find some support and help.
+<squid-users@squid-cache.org>, where you will find some support and help.
We also _strongly_ suggest you to examine Web pages noted above.
-WWW: http://squid.nlanr.net/Squid/
+WWW: http://www.squid-cache.org/
diff --git a/www/squid30/pkg-install b/www/squid30/pkg-install
index 2b6052e5aa11..82f6605be3a2 100644
--- a/www/squid30/pkg-install
+++ b/www/squid30/pkg-install
@@ -14,6 +14,10 @@ case $2 in
echo " configuring your WWW Navigator (Netscape, Mosaic,...)"
echo " to use it as a proxy server."
echo ""
+ echo " o Note that before you can run ${PKGNAME} you will"
+ echo " need to initialise the cache directory."
+ echo " You can do this by typing \"squid -z\"."
+ echo ""
echo "==> Press Enter to edit the ${PKGNAME} config file."
echo " (The defaults are reasonable; and the file is well commented)"
tput md
diff --git a/www/squid30/pkg-plist b/www/squid30/pkg-plist
index ba5a312069c2..38572224f947 100644
--- a/www/squid30/pkg-plist
+++ b/www/squid30/pkg-plist
@@ -1,4 +1,36 @@
etc/rc.d/squid.sh
+etc/squid/mib.txt
+etc/squid/squid.conf.default
+etc/squid/squid.conf
+etc/squid/mime.conf.default
+etc/squid/mime.conf
+etc/squid/icons/anthony-binhex.gif
+etc/squid/icons/anthony-bomb.gif
+etc/squid/icons/anthony-box.gif
+etc/squid/icons/anthony-box2.gif
+etc/squid/icons/anthony-c.gif
+etc/squid/icons/anthony-compressed.gif
+etc/squid/icons/anthony-dir.gif
+etc/squid/icons/anthony-dirup.gif
+etc/squid/icons/anthony-dvi.gif
+etc/squid/icons/anthony-f.gif
+etc/squid/icons/anthony-image.gif
+etc/squid/icons/anthony-image2.gif
+etc/squid/icons/anthony-layout.gif
+etc/squid/icons/anthony-link.gif
+etc/squid/icons/anthony-movie.gif
+etc/squid/icons/anthony-pdf.gif
+etc/squid/icons/anthony-portal.gif
+etc/squid/icons/anthony-ps.gif
+etc/squid/icons/anthony-quill.gif
+etc/squid/icons/anthony-script.gif
+etc/squid/icons/anthony-sound.gif
+etc/squid/icons/anthony-tar.gif
+etc/squid/icons/anthony-tex.gif
+etc/squid/icons/anthony-text.gif
+etc/squid/icons/anthony-unknown.gif
+etc/squid/icons/anthony-xbm.gif
+etc/squid/icons/anthony-xpm.gif
etc/squid/errors/ERR_ACCESS_DENIED
etc/squid/errors/ERR_CACHE_ACCESS_DENIED
etc/squid/errors/ERR_CACHE_MGR_ACCESS_DENIED
@@ -28,46 +60,20 @@ etc/squid/errors/ERR_UNSUP_REQ
etc/squid/errors/ERR_URN_RESOLVE
etc/squid/errors/ERR_WRITE_ERROR
etc/squid/errors/ERR_ZERO_SIZE_OBJECT
-etc/squid/icons/anthony-binhex.gif
-etc/squid/icons/anthony-bomb.gif
-etc/squid/icons/anthony-box.gif
-etc/squid/icons/anthony-box2.gif
-etc/squid/icons/anthony-c.gif
-etc/squid/icons/anthony-compressed.gif
-etc/squid/icons/anthony-dir.gif
-etc/squid/icons/anthony-dirup.gif
-etc/squid/icons/anthony-dvi.gif
-etc/squid/icons/anthony-f.gif
-etc/squid/icons/anthony-image.gif
-etc/squid/icons/anthony-image2.gif
-etc/squid/icons/anthony-layout.gif
-etc/squid/icons/anthony-link.gif
-etc/squid/icons/anthony-movie.gif
-etc/squid/icons/anthony-pdf.gif
-etc/squid/icons/anthony-portal.gif
-etc/squid/icons/anthony-ps.gif
-etc/squid/icons/anthony-quill.gif
-etc/squid/icons/anthony-script.gif
-etc/squid/icons/anthony-sound.gif
-etc/squid/icons/anthony-tar.gif
-etc/squid/icons/anthony-tex.gif
-etc/squid/icons/anthony-text.gif
-etc/squid/icons/anthony-unknown.gif
-etc/squid/icons/anthony-xbm.gif
-etc/squid/icons/anthony-xpm.gif
-etc/squid/mib.txt
-etc/squid/mime.conf.default
-etc/squid/squid.conf.default
-libexec/cachemgr.cgi
-libexec/dnsserver
-libexec/pinger
+libexec/diskd
libexec/unlinkd
-sbin/RunAccel
+libexec/cachemgr.cgi
sbin/RunCache
-sbin/client
+sbin/RunAccel
sbin/squid
+sbin/client
@exec mkdir -p %D/squid/cache
+@exec chown nobody:nogroup %D/squid/cache
@exec mkdir -p %D/squid/logs
-@unexec rmdir %D/squid/cache 2>/dev/null || true
-@unexec rmdir %D/squid/logs 2>/dev/null || true
-@unexec rmdir %D/squid 2>/dev/null || true
+@exec chown nobody:nogroup %D/squid/logs
+@dirrm etc/squid/icons
+@dirrm etc/squid/errors
+@dirrm etc/squid
+@dirrm squid/logs
+@dirrm squid/cache
+@dirrm squid