aboutsummaryrefslogtreecommitdiff
path: root/www/squid31/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-04-26 08:11:29 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-04-26 08:11:29 +0000
commit4d7c38b4978e3cdd86d2660e5bdc7a2232a2d5e6 (patch)
treea49c450240f4bda5749a5d4d048c736db4c2e459 /www/squid31/Makefile
parent5cbfa18239958337bc3bf357f4394ce555492b86 (diff)
downloadports-4d7c38b4978e3cdd86d2660e5bdc7a2232a2d5e6.tar.gz
ports-4d7c38b4978e3cdd86d2660e5bdc7a2232a2d5e6.zip
Add a patch for Squid bug #1814, see <http://www.squid-cache.org/bugs/show_bug.cgi?id=1814>.
The patchset is a slightly modified version of the Squid patchset 11375. Notes: Since this patch conflicts with the ICAP patchset and only affects non-default configurations that have been compiled using the WITH_SQUID_SSL configuration option, apply the patch only when this option is enabled. Set IGNORE when both WITH_SQUID_SSL and WITH_SQUID_ICAP are defined. PR: 112054 Submitted by: Thomas-Martin Seck <tmseck@netcologne.de> (maintainer)
Notes
Notes: svn path=/head/; revision=190906
Diffstat (limited to 'www/squid31/Makefile')
-rw-r--r--www/squid31/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/www/squid31/Makefile b/www/squid31/Makefile
index 8c91129c4831..d82c16d861c8 100644
--- a/www/squid31/Makefile
+++ b/www/squid31/Makefile
@@ -76,6 +76,7 @@
PORTNAME= squid
PORTVERSION= 2.6.12
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= ftp://ftp.squid-cache.org/pub/%SUBDIR%/ \
ftp://ftp.vistech.net/pub/squid/%SUBDIR%/ \
@@ -279,6 +280,10 @@ CONFIGURE_ARGS+= --enable-ssl \
--with-openssl="${OPENSSLBASE}"
CFLAGS+= -I${OPENSSLINC}
LDFLAGS+= -L${OPENSSLLIB}
+.if defined(WITH_SQUID_ICAP)
+IGNORE= is currently broken with both ICAP and SSL support enabled because of conflicting patches. This will be resolved for Squid 2.6.13
+.endif
+EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-changeset_11375
.endif
.if defined(WITH_SQUID_PINGER)
CONFIGURE_ARGS+= --enable-icmp