aboutsummaryrefslogtreecommitdiff
path: root/www/squid
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2005-03-13 19:32:53 +0000
committerMichael Johnson <ahze@FreeBSD.org>2005-03-13 19:32:53 +0000
commit386223668be5cecb2495861dc13459751e6bd923 (patch)
tree0aef2b86db727a4ee086af2283781a8b6f94cace /www/squid
parent9a9ad66f3c7a0aa0257044be1d49f28ea7c14125 (diff)
downloadports-386223668be5cecb2495861dc13459751e6bd923.tar.gz
ports-386223668be5cecb2495861dc13459751e6bd923.zip
- Integrate the following vendor patches as published on
<http://www.squid-cache.org/Versions/v2/2.5/bugs/>: + Handle odd data formats (squid bug #321) + reload_into_ims fails to revalidate negatively cached entries (squid bug #1159) + Clarify delay_access function (squid bug #1245) + Check several squid.conf directives for int overflows (squid bug #1247) + Use memset(3) instead of bzero(3) (squid bug #1256) + Fix compile warnings due to pid_t not being an int (squid bug #1257) + Fix incorrect use of ctype functions (squid bug #1259) + Defer digest fetch if the peer is not allowed to be used (squid bug #1262) + Extend relaxed_header_parser to work around "excess data from" errors from many major web servers (squid bug #1265) - Enable IPFilter based transparent proxying on all FreeBSD versions where IPFilter headers are part of the base system (i.e. RELENG_4 < 4.7-RELEASE, RELENG_5 and 6-CURRENT). Create a new OPTION WITH_SQUID_IPFILTER for this purpose. Thanks to sem@ for keeping track of this issue! PR: ports/78780 Submitted by: Thomas-Martin Seck <tmseck@netcologne.de> (maintainer)
Notes
Notes: svn path=/head/; revision=131118
Diffstat (limited to 'www/squid')
-rw-r--r--www/squid/Makefile38
-rw-r--r--www/squid/distinfo20
2 files changed, 47 insertions, 11 deletions
diff --git a/www/squid/Makefile b/www/squid/Makefile
index 909682ce949b..cd51cffa3bc8 100644
--- a/www/squid/Makefile
+++ b/www/squid/Makefile
@@ -63,18 +63,10 @@
# --with-coss-membuf-size
# COSS membuf size (default: 1048576 bytes)
#
-# This option does not work on FreeBSD at the moment:
-#
-# --enable-ipf-transparent
-# Enable Transparent Proxy support for IP-Filter systems (incl 3.0)
-# (IPFilter headers are not currently installed to the base system,
-# PRs ports/60700 and misc/44148 describe the problem; see
-# http://www.squid-cache.org/Doc/FAQ/FAQ-17.html for information
-# about how to do transparent proxying with ipfw)
PORTNAME= squid
PORTVERSION= 2.5.9
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= \
ftp://ftp.squid-cache.org/pub/%SUBDIR%/ \
@@ -90,7 +82,17 @@ PATCH_SITES= http://www.squid-cache.org/Versions/v2/2.5/bugs/
PATCHFILES= squid-2.5.STABLE9-setcookie.patch \
squid-2.5.STABLE9-ftp_EPLF.patch \
squid-2.5.STABLE9-ftp_base_href.patch \
- squid-2.5.STABLE9-acl_error.patch
+ squid-2.5.STABLE9-acl_error.patch \
+ squid-2.5.STABLE9-date.patch \
+ squid-2.5.STABLE9-reload_into_ims.patch \
+ squid-2.5.STABLE9-delay_access_doc.patch \
+ squid-2.5.STABLE9-config_overflow.patch \
+ squid-2.5.STABLE9-bzero.patch \
+ squid-2.5.STABLE9-pid_t.patch \
+ squid-2.5.STABLE9-ctype.patch \
+ squid-2.5.STABLE9-defer_digest_fetch.patch \
+ squid-2.5.STABLE9-dup_content_length.patch \
+ squid-2.5.STABLE9-excess_data.patch
PATCH_DIST_STRIP= -p1
MAINTAINER= tmseck@netcologne.de
@@ -128,7 +130,8 @@ OPTIONS= SQUID_LDAP_AUTH "Install LDAP authentication helpers" off \
SQUID_IDENT "Enable ident (RFC 931) lookups" on \
SQUID_USERAGENT_LOG "Enable User-Agent-header logging" off \
SQUID_ARP_ACL "Enable ACLs based on ethernet address" off \
- SQUID_PF "Enable transp. proxy support using PF" off \
+ SQUID_PF "Enable transparent proxying with PF" off \
+ SQUID_IPFILTER "Enable transp. proxying with IPFilter" off \
SQUID_FOLLOW_XFF "Follow X-Forwarded-For headers" off \
SQUID_AUFS "Enable the aufs storage scheme" off \
SQUID_COSS "Enable the COSS storage scheme" off \
@@ -286,6 +289,19 @@ CFLAGS+= -I${pf_includedir}
EXTRA_PATCHES+= ${WRKDIR}/pf_from_ports.patch
.endif
.endif
+# IPFilter-headers are not installed on FreeBSD 4 since 4.7-RELEASE,
+# they were not installed on FreeBSD 5 from 2002-03-26 (OSVERSION > 500032) to
+# 2003-06-27 (OSVERSION < 501101).
+#
+# Please see PR misc/44148 and the CVS log of src/include/Makefile for further
+# information.
+.if defined(WITH_SQUID_IPFILTER)
+.if (${OSVERSION} >= 470000 && ${OSVERSION} < 500000) || (${OSVERSION} > 500032 && ${OSVERSION} < 501101)
+IGNORE= "IPFilter headers are not part of the base system"
+.else
+CONFIGURE_ARGS+= --enable-ipf-transparent
+.endif
+.endif
.if defined(WITH_SQUID_FOLLOW_XFF)
EXTRA_PATCHES+= ${PATCHDIR}/follow_xff-2.5.patch \
${PATCHDIR}/follow_xff-configure.patch
diff --git a/www/squid/distinfo b/www/squid/distinfo
index 073e62d6ee9f..fa3d9b22489f 100644
--- a/www/squid/distinfo
+++ b/www/squid/distinfo
@@ -8,3 +8,23 @@ MD5 (squid2.5/squid-2.5.STABLE9-ftp_base_href.patch) = ddc034a2c2a002bfcf6bf97eb
SIZE (squid2.5/squid-2.5.STABLE9-ftp_base_href.patch) = 709
MD5 (squid2.5/squid-2.5.STABLE9-acl_error.patch) = f70922d873ce73c7fdad8bf7156afeb4
SIZE (squid2.5/squid-2.5.STABLE9-acl_error.patch) = 8499
+MD5 (squid2.5/squid-2.5.STABLE9-date.patch) = 7ce5a1f82bf646f5c6fdd60be658ea3f
+SIZE (squid2.5/squid-2.5.STABLE9-date.patch) = 5647
+MD5 (squid2.5/squid-2.5.STABLE9-reload_into_ims.patch) = 433dde5bbbd67eee5ca60cd2e0827263
+SIZE (squid2.5/squid-2.5.STABLE9-reload_into_ims.patch) = 852
+MD5 (squid2.5/squid-2.5.STABLE9-delay_access_doc.patch) = 6550fb36d16ea17067dbab43964a224a
+SIZE (squid2.5/squid-2.5.STABLE9-delay_access_doc.patch) = 1258
+MD5 (squid2.5/squid-2.5.STABLE9-config_overflow.patch) = 8770c7900b1135a3ded7560ed4491887
+SIZE (squid2.5/squid-2.5.STABLE9-config_overflow.patch) = 591
+MD5 (squid2.5/squid-2.5.STABLE9-bzero.patch) = 90c46b9ba7ff62034c0ca63a70eb2c09
+SIZE (squid2.5/squid-2.5.STABLE9-bzero.patch) = 11326
+MD5 (squid2.5/squid-2.5.STABLE9-pid_t.patch) = fb4696da25f478ce7acb652fd09c974f
+SIZE (squid2.5/squid-2.5.STABLE9-pid_t.patch) = 4739
+MD5 (squid2.5/squid-2.5.STABLE9-ctype.patch) = 039b4cf0e8c5b910be54da68952400e1
+SIZE (squid2.5/squid-2.5.STABLE9-ctype.patch) = 4698
+MD5 (squid2.5/squid-2.5.STABLE9-defer_digest_fetch.patch) = 437d440cc4cfeb37b636c998e124a5fe
+SIZE (squid2.5/squid-2.5.STABLE9-defer_digest_fetch.patch) = 1026
+MD5 (squid2.5/squid-2.5.STABLE9-dup_content_length.patch) = 50da2e64f2b3a80b1a8ffdd94e2b4ef4
+SIZE (squid2.5/squid-2.5.STABLE9-dup_content_length.patch) = 1685
+MD5 (squid2.5/squid-2.5.STABLE9-excess_data.patch) = c9ab2d162574e44da51f4e14c653652e
+SIZE (squid2.5/squid-2.5.STABLE9-excess_data.patch) = 1553