aboutsummaryrefslogtreecommitdiff
path: root/www/squid
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-01-22 08:49:50 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-01-22 08:49:50 +0000
commit5859c78c454bcb7fb359bc764cb2255655b9682b (patch)
tree88a6a38c0fe05f9cfed0b3bfd4d1f8191798901c /www/squid
parentdf3598a8e4257fef623f6e4c39466cf7d9895173 (diff)
downloadports-5859c78c454bcb7fb359bc764cb2255655b9682b.tar.gz
ports-5859c78c454bcb7fb359bc764cb2255655b9682b.zip
- Add a patch for Squid bug #1857 (segfault on certain FTP URLs).
- Bump Portrevision PR: ports/107961 Submitted by: Thomas-Martin Sec <tmseck@netcologne.de>
Notes
Notes: svn path=/head/; revision=182965
Diffstat (limited to 'www/squid')
-rw-r--r--www/squid/Makefile4
-rw-r--r--www/squid/files/patch-src-ftp.c24
2 files changed, 26 insertions, 2 deletions
diff --git a/www/squid/Makefile b/www/squid/Makefile
index d44a068593fa..c4a531b9472e 100644
--- a/www/squid/Makefile
+++ b/www/squid/Makefile
@@ -73,7 +73,7 @@
PORTNAME= squid
PORTVERSION= 2.5.14
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= www
MASTER_SITES= http://www.squid-cache.org/%SUBDIR%/ \
http://www2.us.squid-cache.org/%SUBDIR%/ \
@@ -252,7 +252,7 @@ CONFIGURE_ARGS+= --enable-carp
CONFIGURE_ARGS+= --enable-ssl \
--with-openssl="${OPENSSLBASE}"
CFLAGS+= -I${OPENSSLINC}
-LDFLAGS+= -L${LOCALBASE}/lib
+LDFLAGS+= -L${OPENSSLLIB}
.endif
.if defined(WITH_SQUID_PINGER)
CONFIGURE_ARGS+= --enable-icmp
diff --git a/www/squid/files/patch-src-ftp.c b/www/squid/files/patch-src-ftp.c
new file mode 100644
index 000000000000..44f28b75646f
--- /dev/null
+++ b/www/squid/files/patch-src-ftp.c
@@ -0,0 +1,24 @@
+Patch for Squid bug #1857, obtained from Squid bugzilla 2007-01-15.
+
+--- src/ftp.c.orig Sun Feb 26 00:34:13 2006
++++ src/ftp.c Mon Jan 15 19:46:29 2007
+@@ -441,7 +441,7 @@
+ ftpState->flags.dir_slash ? rfc1738_escape_part(ftpState->old_filepath) : ".");
+ } else if (ftpState->typecode == 'D') {
+ const char *path = ftpState->flags.dir_slash ? ftpState->filepath : ".";
+- storeAppendPrintf(e, "<A HREF=\"%s/\">[As extended directory]</A>\n", html_quote(path));
++ storeAppendPrintf(e, "<A HREF=\"%s/\">[As extended directory]</A>\n", rfc1738_escape_part(path));
+ }
+ storeAppendPrintf(e, "<HR noshade size=\"1px\">\n");
+ storeAppendPrintf(e, "<ADDRESS>\n");
+@@ -689,8 +689,8 @@
+ snprintf(html, 8192, "%s\n", line);
+ return html;
+ }
+- if (ftpState->flags.dir_slash)
+- snprintf(prefix, sizeof(prefix), "%s/", rfc1738_escape_part(ftpState->dirpath));
++ if (ftpState->flags.dir_slash && ftpState->dirpath && ftpState->typecode != 'D' )
++ snprintf(prefix, 2048, "%s/", rfc1738_escape_part(ftpState->dirpath));
+ else
+ prefix[0] = '\0';
+ /* Handle builtin <dirup> */