aboutsummaryrefslogtreecommitdiff
path: root/www/squidclamav
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2014-05-14 16:30:21 +0000
committerRenato Botelho <garga@FreeBSD.org>2014-05-14 16:30:21 +0000
commitaa78c6a61dd3fc4cf8d5976736eaa6304560d84a (patch)
tree342ab80e4a9d84a777539a1296111e5b22b9f388 /www/squidclamav
parent26512ab68a63565317c3a71273f56e79e9a16810 (diff)
downloadports-aa78c6a61dd3fc4cf8d5976736eaa6304560d84a.tar.gz
ports-aa78c6a61dd3fc4cf8d5976736eaa6304560d84a.zip
. Support stage
. Use new LIB_DEPENDS syntax . Fix shebang on necessary files . INSTALL_TARGET = install-strip . Add USES=libtool and drop .la files Approved by: portmgr (blanket)
Notes
Notes: svn path=/head/; revision=354072
Diffstat (limited to 'www/squidclamav')
-rw-r--r--www/squidclamav/Makefile8
-rw-r--r--www/squidclamav/files/patch-etc-Makefile.in18
-rw-r--r--www/squidclamav/pkg-plist2
3 files changed, 17 insertions, 11 deletions
diff --git a/www/squidclamav/Makefile b/www/squidclamav/Makefile
index edfc53400817..dec2f5f69c32 100644
--- a/www/squidclamav/Makefile
+++ b/www/squidclamav/Makefile
@@ -12,18 +12,18 @@ COMMENT= Clamav c-icap service and redirector for Squid
LICENSE= GPLv3
-LIB_DEPENDS+= icapapi:${PORTSDIR}/www/c-icap
+LIB_DEPENDS+= libicapapi.so:${PORTSDIR}/www/c-icap
GNU_CONFIGURE= yes
CFLAGS+= -DHAVE_STRNSTR
-
-MAN1= squidclamav.1
+USES= shebangfix libtool
+SHEBANG_FILES= cgi-bin/clwarn.cgi*
+INSTALL_TARGET= install-strip
CONFIGURE_ARGS+= --enable-shared --enable-static \
--sysconfdir="${PREFIX}/etc/c-icap" \
--with-c-icap=${LOCALBASE}
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's|CFGDIR=.*|CFGDIR="${PREFIX}/etc/c-icap"|g' \
${WRKSRC}/configure.in ${WRKSRC}/configure
diff --git a/www/squidclamav/files/patch-etc-Makefile.in b/www/squidclamav/files/patch-etc-Makefile.in
index 9843f4876126..7fe3004e1da2 100644
--- a/www/squidclamav/files/patch-etc-Makefile.in
+++ b/www/squidclamav/files/patch-etc-Makefile.in
@@ -1,10 +1,16 @@
---- etc/Makefile.in.orig 2012-08-15 03:15:12.431509933 +0200
-+++ etc/Makefile.in 2012-08-15 03:15:29.685506098 +0200
-@@ -338,6 +338,7 @@
+--- etc/Makefile.in.orig 2014-05-14 16:04:39.000000000 -0300
++++ etc/Makefile.in 2014-05-14 16:04:57.000000000 -0300
+@@ -338,12 +338,7 @@
install-data-local:
$(mkinstalldirs) $(DESTDIR)$(CFGINST)
+- @if test -f "$(DESTDIR)$(CFGINST)/squidclamav.conf" ; then \
+- echo "$@ will not overwrite existing $(DESTDIR)$(CFGINST)/squidclamav.conf" ; \
+- else \
+- echo "$(INSTALL_DATA) $(srcdir)/squidclamav.conf $(DESTDIR)$(CFGINST)"; \
+- $(INSTALL_DATA) $(srcdir)/squidclamav.conf $(DESTDIR)$(CFGINST)/squidclamav.conf; \
+- fi
+ $(INSTALL_DATA) $(srcdir)/squidclamav.conf $(DESTDIR)$(CFGINST)/squidclamav.conf.default
- @if test -f "$(DESTDIR)$(CFGINST)/squidclamav.conf" ; then \
- echo "$@ will not overwrite existing $(DESTDIR)$(CFGINST)/squidclamav.conf" ; \
- else \
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
+ .NOEXPORT:
diff --git a/www/squidclamav/pkg-plist b/www/squidclamav/pkg-plist
index 062f22a9073e..262eddeb7585 100644
--- a/www/squidclamav/pkg-plist
+++ b/www/squidclamav/pkg-plist
@@ -3,7 +3,6 @@ etc/c-icap/squidclamav.conf.default
@exec [ -f %B/squidclamav.conf ] || cp %B/%f %B/squidclamav.conf
%%DATADIR%%/README
lib/c_icap/squidclamav.a
-lib/c_icap/squidclamav.la
lib/c_icap/squidclamav.so
libexec/squidclamav/clwarn.cgi
libexec/squidclamav/clwarn.cgi.de_DE
@@ -11,5 +10,6 @@ libexec/squidclamav/clwarn.cgi.en_EN
libexec/squidclamav/clwarn.cgi.fr_FR
libexec/squidclamav/clwarn.cgi.pt_BR
libexec/squidclamav/clwarn.cgi.ru_RU
+man/man1/squidclamav.1.gz
@dirrm libexec/squidclamav
@dirrm %%DATADIR%%