aboutsummaryrefslogtreecommitdiff
path: root/www/srt
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-05-16 22:12:41 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-05-16 22:12:41 +0000
commitaf445a38fd160d89a54b928c20940d33e371cec1 (patch)
tree89315dbdde5129c59ddec487eb1ea1ca8e1667b8 /www/srt
parent65f32255d227cc81c80ae8214dd4067b24d11d64 (diff)
downloadports-af445a38fd160d89a54b928c20940d33e371cec1.tar.gz
ports-af445a38fd160d89a54b928c20940d33e371cec1.zip
New port: www/srt: Secure Reliable Transport (SRT) Protocol
Diffstat (limited to 'www/srt')
-rw-r--r--www/srt/Makefile21
-rw-r--r--www/srt/distinfo3
-rw-r--r--www/srt/pkg-descr9
-rw-r--r--www/srt/pkg-plist16
4 files changed, 49 insertions, 0 deletions
diff --git a/www/srt/Makefile b/www/srt/Makefile
new file mode 100644
index 000000000000..6703beea6325
--- /dev/null
+++ b/www/srt/Makefile
@@ -0,0 +1,21 @@
+PORTNAME= srt
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.4.3
+CATEGORIES= www
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Secure Reliable Transport (SRT) Protocol
+
+LICENSE= LGPL21
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= bash:shells/bash
+
+USES= cmake shebangfix ssl
+
+USE_GITHUB= yes
+GH_ACCOUNT= Haivision
+
+SHEBANG_FILES= scripts/srt-ffplay
+
+.include <bsd.port.mk>
diff --git a/www/srt/distinfo b/www/srt/distinfo
new file mode 100644
index 000000000000..981f76f4f75e
--- /dev/null
+++ b/www/srt/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1621202062
+SHA256 (Haivision-srt-v1.4.3_GH0.tar.gz) = c06e05664c71d635c37207a2b5a444f2c4a95950a3548402b3e0c524f735b33d
+SIZE (Haivision-srt-v1.4.3_GH0.tar.gz) = 1602671
diff --git a/www/srt/pkg-descr b/www/srt/pkg-descr
new file mode 100644
index 000000000000..02ae28b754dc
--- /dev/null
+++ b/www/srt/pkg-descr
@@ -0,0 +1,9 @@
+SRT is an open source video transport protocol and technology stack that
+optimizes streaming performance across unpredictable networks with secure
+streams and easy firewall traversal, bringing the best quality live video over
+the worst networks. The SRT Open Source project, driven by the SRT Alliance, is
+a collaborative community of industry leaders and developers striving to achieve
+lower latency internet video transport by continuously improving open-source
+SRT.
+
+WWW: https://www.srtalliance.org/
diff --git a/www/srt/pkg-plist b/www/srt/pkg-plist
new file mode 100644
index 000000000000..af848374ae99
--- /dev/null
+++ b/www/srt/pkg-plist
@@ -0,0 +1,16 @@
+bin/srt-ffplay
+bin/srt-file-transmit
+bin/srt-live-transmit
+bin/srt-tunnel
+include/srt/access_control.h
+include/srt/logging_api.h
+include/srt/platform_sys.h
+include/srt/srt.h
+include/srt/udt.h
+include/srt/version.h
+lib/libsrt.a
+lib/libsrt.so
+lib/libsrt.so.1.4
+lib/libsrt.so.1.4.3
+libdata/pkgconfig/haisrt.pc
+libdata/pkgconfig/srt.pc