aboutsummaryrefslogtreecommitdiff
path: root/www/swish++/Makefile
diff options
context:
space:
mode:
authorPatrick Li <pat@FreeBSD.org>2002-07-22 01:36:13 +0000
committerPatrick Li <pat@FreeBSD.org>2002-07-22 01:36:13 +0000
commite19c294b9bc7325130fa15fdf9f2ef1387d0a9a8 (patch)
tree70ca104b4f953c634002c72a41f6e3a0f9bf8bf5 /www/swish++/Makefile
parent4910fc395a27687611e04c790cc7414cedcf3ba3 (diff)
downloadports-e19c294b9bc7325130fa15fdf9f2ef1387d0a9a8.tar.gz
ports-e19c294b9bc7325130fa15fdf9f2ef1387d0a9a8.zip
Update to 5.9.3
PR: ports/40827 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=63354
Diffstat (limited to 'www/swish++/Makefile')
-rw-r--r--www/swish++/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/www/swish++/Makefile b/www/swish++/Makefile
index 15390e4eb6df..20a74a73691f 100644
--- a/www/swish++/Makefile
+++ b/www/swish++/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= swish++
-PORTVERSION= 5.9.2
+PORTVERSION= 5.9.3
CATEGORIES= www textproc
MASTER_SITES= http://homepage.mac.com/pauljlucas/software/
@@ -16,6 +16,7 @@ MAINTAINER= obraun@informatik.unibw-muenchen.de
RUN_DEPENDS= wget:${PORTSDIR}/ftp/wget
USE_PERL5= yes
+USE_REINPLACE= yes
USE_GMAKE= yes
MAKEFILE= GNUmakefile
MAKE_ENV= PTHREAD_LIB=${PTHREAD_LIBS} \
@@ -27,11 +28,9 @@ MAN4= swish++.conf.4 swish++.index.4
MAN8= searchd.8 searchmonitor.8
post-patch:
- @(cd ${WRKSRC} ; \
- ${SED} '/^#error/d' config.h > config.h.tmp ; \
- ${MV} -f config.h.tmp config.h)
+ @${REINPLACE_CMD} -e '/^#error/d' ${WRKSRC}/config.h
.for file in searchd searchmonitor
- @${PERL} -pi -e "s,%%PREFIX%%,${PREFIX},g" ${WRKSRC}/${file}.in
+ @${REINPLACE_CMD} -e "s,%%PREFIX%%,${PREFIX},g" ${WRKSRC}/${file}.in
.endfor
post-install: