aboutsummaryrefslogtreecommitdiff
path: root/www/tdiary/Makefile
diff options
context:
space:
mode:
authorTAKATSU Tomonari <tota@FreeBSD.org>2012-02-04 01:59:32 +0000
committerTAKATSU Tomonari <tota@FreeBSD.org>2012-02-04 01:59:32 +0000
commit1af95e356e8edb792b0e95a02eea1c70eb7e12f6 (patch)
treee42c64128b911227db41855fb76011037a39f160 /www/tdiary/Makefile
parent0a6923b299898039352511b87998da04fa72847f (diff)
downloadports-1af95e356e8edb792b0e95a02eea1c70eb7e12f6.tar.gz
ports-1af95e356e8edb792b0e95a02eea1c70eb7e12f6.zip
- Update to 3.1.2
Notes
Notes: svn path=/head/; revision=290370
Diffstat (limited to 'www/tdiary/Makefile')
-rw-r--r--www/tdiary/Makefile18
1 files changed, 8 insertions, 10 deletions
diff --git a/www/tdiary/Makefile b/www/tdiary/Makefile
index 38e2bc9b619f..07f3bb53f742 100644
--- a/www/tdiary/Makefile
+++ b/www/tdiary/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= tdiary
-PORTVERSION= 3.1.1
-PORTREVISION= 1
+PORTVERSION= 3.1.2
CATEGORIES?= www ruby
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/ \
http://www.tdiary.org/download/
@@ -17,11 +16,11 @@ MAINTAINER= tota@FreeBSD.org
COMMENT= A Web-based diary system (like weblog) written in Ruby
LICENSE= GPLv2
-LICENSE_FILE= ${WRKDIR}/doc/COPYING
+LICENSE_FILE= ${WRKDIR}/doc/LICENSE
RUN_DEPENDS= hikidoc:${PORTSDIR}/textproc/ruby-hikidoc \
rubygem-imagesize>=0.1.1:${PORTSDIR}/graphics/rubygem-imagesize \
- rubygem-json_pure>=1.6.1:${PORTSDIR}/devel/rubygem-json_pure
+ rd2:${PORTSDIR}/textproc/ruby-rdtool
NO_BUILD= yes
USE_RUBY= yes
@@ -38,10 +37,10 @@ RUBY_SHEBANG_FILES= index.fcgi \
misc/plugin/xmlrpc/xmlrpc.rb \
misc/standalone_cgi/bin/server
-PORTDOCS= ChangeLog COPYING HOWTO-make-io.rd HOWTO-make-plugin.html \
+PORTDOCS= ChangeLog HOWTO-make-io.rd HOWTO-make-plugin.html \
HOWTO-make-theme.html HOWTO-use-plugin.html \
HOWTO-write-tDiary.en.html HOWTO-write-tDiary.html INSTALL.html \
- README.en.html README.html README.md UPGRADE doc.css
+ LICENSE README.en.html README.html README.md UPGRADE doc.css
SUB_FILES= pkg-message tdiaryinst.rb
SUB_LIST+= TDIARY_LANG=${TDIARY_LANG} \
@@ -88,16 +87,15 @@ post-extract:
@${RM} ${WRKSRC}/config.ru
@${RM} -r ${WRKSRC}/public
@${RM} -r ${WRKSRC}/spec
+ @${RM} -r ${WRKSRC}/test
@${RM} -r ${WRKSRC}/vendor/hikidoc-0.0.6
@${RM} -r ${WRKSRC}/vendor/imagesize-0.1.1/*
- @${RM} -r ${WRKSRC}/vendor/json_pure-1.6.1
+ @${RM} -r ${WRKSRC}/vendor/rdtool-0.6.29
@${MV} ${WRKSRC}/ChangeLog ${WRKSRC}/doc
+ @${MV} ${WRKSRC}/LICENSE ${WRKSRC}/doc
@${MV} ${WRKSRC}/README.md ${WRKSRC}/doc
@cd ${WRKSRC} && ${MV} doc ${WRKDIR}
-post-patch:
- ${RUBY} -i -pe "sub %r|((\s*)require 'json')|, %Q|\\\2require 'rubygems'\n\\\1|" ${WRKSRC}/tdiary.rb
-
pre-install:
@${SED} -e 's,#!/usr/bin/env ruby,#!${RUBY},' \
${WRKDIR}/tdiaryinst.rb > ${WRKDIR}/${TDIARY_SCRIPT}