aboutsummaryrefslogtreecommitdiff
path: root/www/tdiary/Makefile
diff options
context:
space:
mode:
authorTAKATSU Tomonari <tota@FreeBSD.org>2011-04-30 06:12:07 +0000
committerTAKATSU Tomonari <tota@FreeBSD.org>2011-04-30 06:12:07 +0000
commit82dd195157477038b682318e7472448a5f6423a5 (patch)
tree3ef04ed6d8001f3d4d4041899f9f303eae8902ec /www/tdiary/Makefile
parentb264b00bbffb09af3944761e3ab2153451eb286e (diff)
downloadports-82dd195157477038b682318e7472448a5f6423a5.tar.gz
ports-82dd195157477038b682318e7472448a5f6423a5.zip
- Update to 3.0.2
Notes
Notes: svn path=/head/; revision=273363
Diffstat (limited to 'www/tdiary/Makefile')
-rw-r--r--www/tdiary/Makefile36
1 files changed, 26 insertions, 10 deletions
diff --git a/www/tdiary/Makefile b/www/tdiary/Makefile
index 54f2e1e1d458..f801c9b71cfc 100644
--- a/www/tdiary/Makefile
+++ b/www/tdiary/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= tdiary
-PORTVERSION= 3.0.1
+PORTVERSION= 3.0.2
CATEGORIES?= www ruby
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/ \
http://www.tdiary.org/download/
@@ -20,24 +20,22 @@ LICENSE_FILE= ${WRKDIR}/doc/COPYING
NO_BUILD= yes
USE_RUBY= yes
-RUBY_REQUIRE= Ruby >= 182
+RUBY_REQUIRE= Ruby >= 185
RUBY_SHEBANG_FILES= index.fcgi \
index.rb \
update.rb \
misc/convert2.rb \
+ misc/migrate.rb \
misc/plugin/amazon/amazonimg.rb \
- misc/plugin/pingback/pb.rb \
misc/plugin/squeeze.rb \
- misc/plugin/trackback/tb.rb \
misc/plugin/xmlrpc/xmlrpc.rb \
- misc/style/etdiary/etdiary_test.rb \
- tdiary/wiki_style_test.rb
+ misc/standalone_cgi/bin/server
PORTDOCS= ChangeLog COPYING HOWTO-make-io.rd HOWTO-make-plugin.html \
HOWTO-make-theme.html HOWTO-use-plugin.html \
HOWTO-write-tDiary.en.html HOWTO-write-tDiary.html INSTALL.html \
- README.en.html README.html UPGRADE doc.css
+ README.en.html README.html README.md UPGRADE doc.css
SUB_FILES= pkg-message tdiaryinst.rb
SUB_LIST+= TDIARY_LANG=${TDIARY_LANG} \
@@ -53,6 +51,8 @@ TDIARY_SCRIPT= ${UNIQUENAME}-inst.rb
TDIARY_LANG= en
.endif
+REINPLACE_ARGS= -i ''
+
.include <bsd.port.pre.mk>
.if ${RUBY_VER} == 1.9
@@ -63,7 +63,7 @@ IGNORE= requires Ruby 1.9.1 or later
.if ${RUBY_VER} == 1.8
.if !defined(RUBY_PROVIDED)
-IGNORE= requires Ruby 1.8.2 or later
+IGNORE= requires Ruby 1.8.5 or later
.endif
.if !defined(WITHOUT_TDIARY_NORA)
RUN_DEPENDS+= ${RUBY_SITEARCHLIBDIR}/web/escape_ext.so:${PORTSDIR}/www/ruby-nora
@@ -71,12 +71,24 @@ RUN_DEPENDS+= ${RUBY_SITEARCHLIBDIR}/web/escape_ext.so:${PORTSDIR}/www/ruby-nora
.endif
post-extract:
- @cd ${WRKSRC} && ${RM} -f README && ${MV} ChangeLog doc
- @cd ${WRKSRC} && ${MV} doc ${WRKDIR}
+ ${RM} ${WRKSRC}/.gitignore
+ ${RM} ${WRKSRC}/.rspec
+ ${RM} ${WRKSRC}/Capfile
+ ${RM} ${WRKSRC}/Gemfile
+ ${RM} ${WRKSRC}/Gemfile.lock
+ ${RM} ${WRKSRC}/Rakefile
+ ${RM} ${WRKSRC}/config.ru
+ ${RM} -r ${WRKSRC}/public
+ ${RM} -r ${WRKSRC}/spec
+ ${MV} ${WRKSRC}/ChangeLog ${WRKSRC}/doc
+ ${MV} ${WRKSRC}/README.md ${WRKSRC}/doc
+ cd ${WRKSRC} && ${MV} doc ${WRKDIR}
pre-install:
@${SED} -e 's,#!/usr/bin/env ruby,#!${RUBY},' \
${WRKDIR}/tdiaryinst.rb > ${WRKDIR}/${TDIARY_SCRIPT}
+ @${REINPLACE_CMD} '/#!\/usr\/bin\/env ruby/d' ${WRKSRC}/misc/convert2.rb
+ @${REINPLACE_CMD} '/#!\/usr\/bin\/env ruby/d' ${WRKSRC}/misc/migrate.rb
do-install:
@${INSTALL_SCRIPT} ${WRKDIR}/${TDIARY_SCRIPT} ${PREFIX}/bin
@@ -93,4 +105,8 @@ post-install:
.endif
@${CAT} ${PKGMESSAGE}
+x-generate-plist:
+ ${FIND} ${WWWDIR} -type f | ${SORT} | ${SED} -e 's,${WWWDIR},%%WWWDIR%%,g' > pkg-plist.new
+ ${FIND} ${WWWDIR} -type d -depth | ${SORT} -r | ${SED} -e 's,${WWWDIR},@dirrm %%WWWDIR%%,g' >> pkg-plist.new
+
.include <bsd.port.post.mk>