aboutsummaryrefslogtreecommitdiff
path: root/www/thundersnarf/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-03-22 11:53:34 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-03-22 11:53:34 +0000
commit606c17b9c8ceebf3bba34704094912556f260836 (patch)
tree5f0dbe9212a3377e7182c77ac610d48050fcb2b0 /www/thundersnarf/Makefile
parent919430dbf0343ab4fb4c8362bb4b711509b3981b (diff)
downloadports-606c17b9c8ceebf3bba34704094912556f260836.tar.gz
ports-606c17b9c8ceebf3bba34704094912556f260836.zip
Convert a bunch of www ports to new options framework
Notes
Notes: svn path=/head/; revision=314915
Diffstat (limited to 'www/thundersnarf/Makefile')
-rw-r--r--www/thundersnarf/Makefile22
1 files changed, 12 insertions, 10 deletions
diff --git a/www/thundersnarf/Makefile b/www/thundersnarf/Makefile
index 4eaf2d80d001..6df9b00ca7dc 100644
--- a/www/thundersnarf/Makefile
+++ b/www/thundersnarf/Makefile
@@ -11,32 +11,34 @@ MASTER_SITES= http://www.tracanelli.com.br/l/dev/thunder/ \
MAINTAINER= eksffa@freebsdbrasil.com.br
COMMENT= Web reporting and trending analysis for Thunder Cache Pro
-OPTIONS= APACHE "Install apache for reporting viewing" on \
- PHP "Install PHP for reporting generating" on \
- PGSQL "Install PostgreSQL (report data storing)" on
+OPTIONS_DEFINE= APACHE PHP PGSQL DOCS
+OPTIONS_DEFAULT= APACHE PHP PGSQL
+APACHE_DESC= Install apache for reporting viewing
+PHP_DESC= Install PHP for reporting generating
+PGSQL_DESC= Install PostgreSQL (report data storing)
USE_BZIP2= yes
NO_BUILD= yes
WRKSRC= ${WRKDIR}/${PORTNAME:R}
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined (WITH_APACHE)
+.if ${PORT_OPTIONS:MAPACHE}
USE_APACHE_RUN= 22+
.endif
-.if defined (WITH_PGSQL)
+.if ${PORT_OPTIONS:MPGSQL}
USE_PGSQL= yes
WANT_PGSQL_VER= 84+
RUN_DEPENDS+= postgresql-server>=0:${PORTSDIR}/databases/postgresql${PGSQL_VER}-server
.endif
-.if defined(WITH_PHP) && defined(WITH_PGSQL)
+.if ${PORT_OPTIONS:MPHP} && ${PORT_OPTIONS:MPGSQL}
RUN_DEPENDS+= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/pdo_pgsql.so:${PORTSDIR}/databases/php5-pdo_pgsql
.endif
-.if defined(WITH_PHP)
+.if ${PORT_OPTIONS:MPHP}
USE_PHP+= curl pcre bcmath pdo mcrypt mhash session pgsql spl dom xmlrpc ctype openssl simplexml soap json
.endif
@@ -53,7 +55,7 @@ do-install:
@${CHMOD} -R g+rwx ${WWWDIR}/protected/runtime \
${WWWDIR}/assets
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
@${CP} -Rv ${WRKSRC}/README ${DOCSDIR}/README.pt_BR
.endif
@@ -61,4 +63,4 @@ do-install:
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>