aboutsummaryrefslogtreecommitdiff
path: root/www/trac-gitplugin
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-11-04 10:18:03 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-11-04 10:18:03 +0000
commit5ee1648e91451b1bba6d7a2510df3d0b6195b9cb (patch)
treeb08dd7aaf6387ff0c8a6371738cd35b17b869ee0 /www/trac-gitplugin
parent8a7c08c9e8a2abc9e13854e5674ef4301e70696b (diff)
downloadports-5ee1648e91451b1bba6d7a2510df3d0b6195b9cb.tar.gz
ports-5ee1648e91451b1bba6d7a2510df3d0b6195b9cb.zip
GitTrac is a plugin for Trac which enables Git to be used instead of Subversion
as the VersioningSystemBackend for Trac. WWW: http://trac-hacks.org/wiki/GitPlugin PR: ports/140235 Submitted by: Douglas Thrift
Notes
Notes: svn path=/head/; revision=243750
Diffstat (limited to 'www/trac-gitplugin')
-rw-r--r--www/trac-gitplugin/Makefile34
-rw-r--r--www/trac-gitplugin/distinfo3
-rw-r--r--www/trac-gitplugin/pkg-descr4
3 files changed, 41 insertions, 0 deletions
diff --git a/www/trac-gitplugin/Makefile b/www/trac-gitplugin/Makefile
new file mode 100644
index 000000000000..f4088eb01f15
--- /dev/null
+++ b/www/trac-gitplugin/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: trac-gitplugin
+# Date created: 2 November 2009
+# Whom: Douglas Thrift
+#
+# $FreeBSD$
+#
+
+PORTNAME= gitplugin
+PORTVERSION= 0.11.0.2.7034
+CATEGORIES= www devel python
+MASTER_SITES= http://code.douglasthrift.net/files/${PORTNAME}/
+PKGNAMEPREFIX= trac-
+DISTNAME= ${PORTNAME}-r${PORTVERSION:E}
+
+MAINTAINER= douglas@douglasthrift.net
+COMMENT= Git plugin for Trac
+
+RUN_DEPENDS= git:${PORTSDIR}/devel/git \
+ tracd:${PORTSDIR}/www/trac
+BUILD_DEPENDS= easy_install:${PORTSDIR}/devel/py-setuptools
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= easy_install
+USE_ZIP= yes
+PYDISTUTILS_PKGNAME= TracGit
+PYDISTUTILS_PKGVERSION= ${PORTVERSION:R}
+WRKSRC= ${WRKDIR}/${PORTNAME}/${PORTVERSION:C/(.[0-9]+){3}$//}
+
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
+
+pre-configure:
+ ${CHMOD} -R a+r ${WRKSRC}
+
+.include <bsd.port.mk>
diff --git a/www/trac-gitplugin/distinfo b/www/trac-gitplugin/distinfo
new file mode 100644
index 000000000000..fe31fbc4a1cc
--- /dev/null
+++ b/www/trac-gitplugin/distinfo
@@ -0,0 +1,3 @@
+MD5 (gitplugin-r7034.zip) = aa97d9343a43be86f1701375f9a90c1d
+SHA256 (gitplugin-r7034.zip) = 1ece50a8a0870e860af24d6d91da7d6140f0a716ba79856514a6fd8532d152ab
+SIZE (gitplugin-r7034.zip) = 32645
diff --git a/www/trac-gitplugin/pkg-descr b/www/trac-gitplugin/pkg-descr
new file mode 100644
index 000000000000..77c818d18576
--- /dev/null
+++ b/www/trac-gitplugin/pkg-descr
@@ -0,0 +1,4 @@
+GitTrac is a plugin for Trac which enables Git to be used instead of Subversion
+as the VersioningSystemBackend for Trac.
+
+WWW: http://trac-hacks.org/wiki/GitPlugin