aboutsummaryrefslogtreecommitdiff
path: root/www/trac-graphviz/Makefile
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2012-10-30 19:47:33 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2012-10-30 19:47:33 +0000
commitae46a8ae0e400f46934751c4554a02d92f99e427 (patch)
treec95f4adff3e6f5bdd7e51e6dd2dfb82ec48351a9 /www/trac-graphviz/Makefile
parent58d04a3575f7d5abcf527887233f79cc00fdfaf9 (diff)
downloadports-ae46a8ae0e400f46934751c4554a02d92f99e427.tar.gz
ports-ae46a8ae0e400f46934751c4554a02d92f99e427.zip
- do not directly depend on setuptools, use USE_DISTUTILS instead
- bump PORTREVISION because of dependency change - trim Makefile header - limit python version to 2.x only - whitespace fix in pkg-descr PR: 173172 Submitted by: rm (myself) Approved by: brooks (maintainer, by mail) Feature safe: yes
Notes
Notes: svn path=/head/; revision=306705
Diffstat (limited to 'www/trac-graphviz/Makefile')
-rw-r--r--www/trac-graphviz/Makefile25
1 files changed, 6 insertions, 19 deletions
diff --git a/www/trac-graphviz/Makefile b/www/trac-graphviz/Makefile
index 712f3b2da107..b063d4a8f3ea 100644
--- a/www/trac-graphviz/Makefile
+++ b/www/trac-graphviz/Makefile
@@ -1,13 +1,9 @@
-# New ports collection makefile for: trac-graphviz
-# Date created: January 14, 2009
-# Whom: Brooks Davis <brooks@freebsd.org>
-#
+# Created by: Brooks Davis <brooks@freebsd.org>
# $FreeBSD$
-#
PORTNAME= ${PYDISTUTILS_PKGNAME:S;^Trac;;S;Plugin$;;:L}
PORTVERSION= 0.7.4
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= www devel graphics python
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= brooks
@@ -20,18 +16,12 @@ COMMENT= Graphviz plugin for Trac's wiki
RUN_DEPENDS+= ${LOCALBASE}/lib/X11/fonts/URW/fonts.dir:${PORTSDIR}/x11-fonts/urwfonts \
dot:${PORTSDIR}/graphics/graphviz \
tracd:${PORTSDIR}/www/trac
-BUILD_DEPENDS+= easy_install:${PORTSDIR}/devel/py-setuptools
-USE_PYTHON= 2.5+
-NO_BUILD= yes
-USE_PYDISTUTILS=yes
+USE_PYTHON= -2.7
+USE_PYDISTUTILS= easy_install
PYDISTUTILS_PKGNAME= graphviz
-WRKSRC= ${WRKDIR}/${PORTNAME}plugin
-PYDISTUTILS_NOEGGINFO= yes
-PLIST_SUB= PORTVERSION=${PORTVERSION} \
- PYTHON_VER=${PYTHON_VER}
-
-PLIST_FILES= %%PYTHON_SITELIBDIR%%/${PYDISTUTILS_PKGNAME}-${PORTVERSION}-py${PYTHON_VER}.egg
+WRKSRC= ${WRKDIR}/${PORTNAME}plugin
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
post-patch:
${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|' \
@@ -39,7 +29,4 @@ post-patch:
-e 's|%%OSMAJOR%%|${OSREL:C/\..*$//}|' \
${WRKSRC}/graphviz/graphviz.py
-do-build:
- @${DO_NADA}
-
.include <bsd.port.mk>