aboutsummaryrefslogtreecommitdiff
path: root/www/trafficserver
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2015-07-20 03:51:06 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2015-07-20 03:51:06 +0000
commit715c085e5af0aa74ccc4f4f17361db9b1084ea18 (patch)
tree91c392c1b7af0eafe0a47f770847fbad459aa3eb /www/trafficserver
parentf7ec944c6379976e19b90672b7251a5149c89a26 (diff)
downloadports-715c085e5af0aa74ccc4f4f17361db9b1084ea18.tar.gz
ports-715c085e5af0aa74ccc4f4f17361db9b1084ea18.zip
Add spdy support.
PR: 201563 Submitted by: me@celogeek.com Approved by: maintainer
Notes
Notes: svn path=/head/; revision=392545
Diffstat (limited to 'www/trafficserver')
-rw-r--r--www/trafficserver/Makefile5
-rw-r--r--www/trafficserver/files/patch-tools_Makefile.in4
2 files changed, 6 insertions, 3 deletions
diff --git a/www/trafficserver/Makefile b/www/trafficserver/Makefile
index bde5a23fbd41..adf7dca62713 100644
--- a/www/trafficserver/Makefile
+++ b/www/trafficserver/Makefile
@@ -47,7 +47,7 @@ CONFIGURE_ARGS= --with-libxml2=${LOCALBASE} \
--with-user=${USERS} \
--with-group=${GROUPS}
-OPTIONS_DEFINE= DOCS INTERIM WCCP
+OPTIONS_DEFINE= DOCS INTERIM WCCP SPDY
OPTIONS_RADIO= MEMMAN
OPTIONS_RADIO_MEMMAN= ALLOCATORS FREELISTS RECLAIM
OPTIONS_DEFAULT= FREELISTS
@@ -57,9 +57,12 @@ INTERIM_DESC= Enable interim cache (SSD)
ALLOCATORS_DESC= Manage memory with allocators
FREELISTS_DESC= Manage memory with freelists
RECLAIM_DESC= Reclaim unused memory in freelists
+SPDY_DESC= Enable SPDY
WCCP_CONFIGURE_ENABLE= wccp
INTERIM_CONFIGURE_ENABLE= interim-cache
+SPDY_CONFIGURE_ENABLE= spdy
+SPDY_LIB_DEPENDS= libspdylay.so:${PORTSDIR}/www/spdylay
.include <bsd.port.options.mk>
diff --git a/www/trafficserver/files/patch-tools_Makefile.in b/www/trafficserver/files/patch-tools_Makefile.in
index c83c9c0ceb4f..482621cec7c1 100644
--- a/www/trafficserver/files/patch-tools_Makefile.in
+++ b/www/trafficserver/files/patch-tools_Makefile.in
@@ -1,5 +1,5 @@
---- tools/Makefile.in.orig 2015-07-07 14:35:35.993832221 +0800
-+++ tools/Makefile.in 2015-07-07 14:35:49.432831048 +0800
+--- tools/Makefile.in.orig 2015-06-30 04:11:56 UTC
++++ tools/Makefile.in
@@ -614,7 +614,7 @@ valuesh = @valuesh@
waith = @waith@
zlibh = @zlibh@