aboutsummaryrefslogtreecommitdiff
path: root/www/tt-rss
diff options
context:
space:
mode:
authorFelix Palmen <zirias@FreeBSD.org>2023-07-12 12:13:03 +0000
committerFelix Palmen <zirias@FreeBSD.org>2023-07-12 18:56:04 +0000
commit7d1faa7179813ffa542b550a1fdb3bdc80a7986c (patch)
treebca2e70f4a6137f858d0ca5792e376602af7bab7 /www/tt-rss
parent16bde072b16daca1c886116e602c94b5fa99c20f (diff)
downloadports-7d1faa7179813ffa542b550a1fdb3bdc80a7986c.tar.gz
ports-7d1faa7179813ffa542b550a1fdb3bdc80a7986c.zip
bsd.sites.mk: Update all ports using USE_GITLAB
Replace GL_COMMIT by GL_TAGNAME in all ports. The new GL_TAGNAME is backwards-compatible (accepting any commit hash as before), but also understands an actual tag name. Moving to tag names where appropriate is left to individual ports' maintainers. Approved by: portmgr (tcberner, mentor) Differential Revision: https://reviews.freebsd.org/D37077
Diffstat (limited to 'www/tt-rss')
-rw-r--r--www/tt-rss/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/www/tt-rss/Makefile b/www/tt-rss/Makefile
index ec348958373c..a8b36e800265 100644
--- a/www/tt-rss/Makefile
+++ b/www/tt-rss/Makefile
@@ -15,7 +15,7 @@ USES= gettext-tools php:cli,web shebangfix
USE_GITLAB= yes
GL_SITE= https://gitlab.tt-rss.org
-GL_COMMIT= 11946f0148d0b8a76ecc120fd9c1dc0b7fa04664
+GL_TAGNAME= 11946f0148d0b8a76ecc120fd9c1dc0b7fa04664
USE_PHP= ctype dom exif fileinfo filter iconv intl mbstring openssl \
pcntl pdo phar posix session simplexml tokenizer xml xmlwriter \
@@ -61,7 +61,7 @@ do-install:
"! -name LICENSE ! -name .empty ! -name Jenkinsfile")
${RM} -r ${STAGEDIR}${WWWDIR}/debian
${INSTALL_DATA} ${WRKDIR}/httpd-tt-rss.conf ${STAGEDIR}${DATADIR}
- ${ECHO} "${OPSYS}:${PORTVERSION}:${GL_COMMIT:C/^(.{11}).*$/\1/W}}" > \
+ ${ECHO} "${OPSYS}:${PORTVERSION}:${GL_TAGNAME:C/^(.{11}).*$/\1/W}}" > \
"${STAGEDIR}${WWWDIR}/version_static.txt"
${RM} ${STAGEDIR}${WWWDIR}/config.php-dist
${INSTALL_DATA} ${WRKDIR}/config.php \