aboutsummaryrefslogtreecommitdiff
path: root/www/varnish4
diff options
context:
space:
mode:
authorMark Felder <feld@FreeBSD.org>2015-03-03 12:57:57 +0000
committerMark Felder <feld@FreeBSD.org>2015-03-03 12:57:57 +0000
commitd56b5f11c5ea2c157ca3eac19021904f57845146 (patch)
tree07d482c9b15b46e88f6575d8cfe32070ed659d8e /www/varnish4
parent3a336940294ca670bab5c024c8c48847696d358e (diff)
downloadports-d56b5f11c5ea2c157ca3eac19021904f57845146.tar.gz
ports-d56b5f11c5ea2c157ca3eac19021904f57845146.zip
Update "BSD" license for buganini's ports
Notes
Notes: svn path=/head/; revision=380358
Diffstat (limited to 'www/varnish4')
-rw-r--r--www/varnish4/Makefile51
-rw-r--r--www/varnish4/distinfo2
-rw-r--r--www/varnish4/files/bug-1201.patch15
-rw-r--r--www/varnish4/files/no-inet6.patch8
-rw-r--r--www/varnish4/files/pkg-message.in12
-rw-r--r--www/varnish4/files/varnishd.in83
-rw-r--r--www/varnish4/files/varnishlog.in49
-rw-r--r--www/varnish4/files/varnishncsa.in49
-rw-r--r--www/varnish4/pkg-descr12
-rw-r--r--www/varnish4/pkg-plist91
10 files changed, 372 insertions, 0 deletions
diff --git a/www/varnish4/Makefile b/www/varnish4/Makefile
new file mode 100644
index 000000000000..0ceff4a7c285
--- /dev/null
+++ b/www/varnish4/Makefile
@@ -0,0 +1,51 @@
+# $FreeBSD$
+
+PORTNAME= varnish
+PORTVERSION= 4.0.3
+CATEGORIES= www
+MASTER_SITES= http://repo.varnish-cache.org/source/
+PKGNAMESUFFIX= 4
+
+MAINTAINER= feld@FreeBSD.org
+COMMENT= The Varnish high-performance HTTP accelerator
+
+LICENSE= BSD2CLAUSE
+
+LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre
+
+CONFLICTS= varnish-2.* varnish-3.*
+
+USES= autoreconf gmake libtool readline pkgconfig python:build
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --localstatedir=${PREFIX} --enable-tests
+CONFIGURE_ENV= RST2MAN=true
+USE_LDCONFIG= yes
+INSTALL_TARGET= install-strip
+
+USE_RC_SUBR= varnishd varnishlog varnishncsa
+SUB_FILES= pkg-message
+.if defined(NO_INET6) || defined(WITHOUT_INET6)
+BAD_TESTS+= r00832
+EXTRA_PATCHES+= ${FILESDIR}/no-inet6.patch
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|\$$(libdir)/pkgconfig|\$$(prefix)/libdata/pkgconfig|' \
+ ${WRKSRC}/Makefile.am
+.if defined(BAD_TESTS)
+ ${RM} -f ${BAD_TESTS:C|.+|${WRKSRC}/bin/varnishtest/tests/\0.vtc|}
+.endif
+
+regression-test check test: build
+ ${MAKE_CMD} TESTS_PARALLELISM=1 -C ${WRKSRC} check
+
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "i386"
+EXTRA_PATCHES+= ${FILESDIR}/bug-1201.patch
+.endif
+.if ${ARCH} == "arm"
+BROKEN= Does not configure on arm
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/varnish4/distinfo b/www/varnish4/distinfo
new file mode 100644
index 000000000000..76b41d4493ab
--- /dev/null
+++ b/www/varnish4/distinfo
@@ -0,0 +1,2 @@
+SHA256 (varnish-4.0.3.tar.gz) = 94b9a174097f47db2286acd2c35f235e49a2b7a9ddfdbd6eb7aa4da9ae8f8206
+SIZE (varnish-4.0.3.tar.gz) = 1866760
diff --git a/www/varnish4/files/bug-1201.patch b/www/varnish4/files/bug-1201.patch
new file mode 100644
index 000000000000..e0872f346bc9
--- /dev/null
+++ b/www/varnish4/files/bug-1201.patch
@@ -0,0 +1,15 @@
+Use larger stack-size for the r01109 test. See:
+
+ https://www.varnish-cache.org/trac/ticket/1201
+
+for details.
+
+--- bin/varnishtest/tests/r01109.vtc 2012-08-20 05:20:39.000000000 -0400
++++ bin/varnishtest/tests/r01109.vtc 2012-10-10 09:06:29.000000000 -0400
+@@ -22,5 +22,5 @@
+ } -start
+
+-varnish v1 -arg "-pfetch_chunksize=4k" -arg "-pgzip_level=0" -vcl+backend {
++varnish v1 -arg "-pfetch_chunksize=4k" -arg "-pgzip_level=0" -arg "-pthread_pool_stack=131072" -vcl+backend {
+ sub vcl_fetch {
+ if (req.url ~ "/test") {
diff --git a/www/varnish4/files/no-inet6.patch b/www/varnish4/files/no-inet6.patch
new file mode 100644
index 000000000000..56d16e63b100
--- /dev/null
+++ b/www/varnish4/files/no-inet6.patch
@@ -0,0 +1,8 @@
+--- bin/varnishtest/tests/c00005.vtc 2012-08-20 05:20:39.000000000 -0400
++++ bin/varnishtest/tests/c00005.vtc 2012-09-26 12:09:59.000000000 -0400
+@@ -32,5 +32,4 @@
+ ! "localhost";
+ "0.0.0.0" / 0;
+- "::" / 0;
+ }
+
diff --git a/www/varnish4/files/pkg-message.in b/www/varnish4/files/pkg-message.in
new file mode 100644
index 000000000000..71157cc58486
--- /dev/null
+++ b/www/varnish4/files/pkg-message.in
@@ -0,0 +1,12 @@
+QUICK-START GUIDE
+
+It's two in the morning and someone posted a link to your website on
+slashdot. Don't panic, it takes only a minute to set up Varnish in
+front of your web server:
+
+1) Install Varnish
+2) Reconfigure your web server to listen on localhost:8080
+3) echo 'varnishd_enable="YES"' >>/etc/rc.conf
+4) %%PREFIX%%/etc/rc.d/varnishd start
+
+Refer to the documentation for more advanced configuration.
diff --git a/www/varnish4/files/varnishd.in b/www/varnish4/files/varnishd.in
new file mode 100644
index 000000000000..61512f1ce8e3
--- /dev/null
+++ b/www/varnish4/files/varnishd.in
@@ -0,0 +1,83 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+# PROVIDE: varnishd
+# REQUIRE: DAEMON
+# KEYWORD: shutdown
+
+#
+# Add the following line to /etc/rc.conf to enable varnishd:
+#
+# varnishd_enable="YES"
+#
+# Configuration variables and their default values:
+#
+# varnishd_pidfile - full path to the PID file.
+# default: "/var/run/varnishd.pid"
+#
+# varnishd_listen - address and port at which varnishd will listen for
+# client requests.
+# default: ":80"
+#
+# varnishd_admin - address and port at which varnishd will listen for
+# administrative commands.
+# default: "localhost:81"
+#
+# varnishd_backend - address of the backend server.
+# default: "localhost:8080"
+#
+# varnishd_config - name of the varnishd config file.
+# default: unset.
+#
+# varnishd_hash - hash algorithm
+# default: "classic,16383"
+#
+# varnishd_storage - storage method and parameters.
+# default: "file,/tmp,50%"
+#
+# varnishd_user - unprivileged user for the child process.
+# default: "www"
+#
+# varnishd_group - unprivileged group for the child process.
+# default: "www"
+#
+# varnishd_flags - complete command line arguments.
+# default if varnishd_config is unset: "-P ${varnishd_pidfile} -a ${varnishd_listen} -T ${varnishd_admin} -b ${varnishd_backend} -s ${varnishd_storage} -h ${varnishd_hash} -u ${varnishd_user} -g ${varnishd_group}"
+# default if varnishd_config is set: "-P ${varnishd_pidfile} -a ${varnishd_listen} -T ${varnishd_admin} -f ${varnishd_config} -s ${varnishd_storage} -h ${varnishd_hash} -u ${varnishd_user} -g ${varnishd_group}"
+#
+# See varnishd(1) for a detailed overview of command-line options.
+#
+
+. /etc/rc.subr
+
+name="varnishd"
+rcvar=varnishd_enable
+
+command="%%PREFIX%%/sbin/${name}"
+
+# read configuration and set defaults
+load_rc_config ${name}
+: ${varnishd_enable:="NO"}
+: ${varnishd_pidfile:="/var/run/${name}.pid"}
+: ${varnishd_listen:=":80"}
+: ${varnishd_admin:="localhost:81"}
+: ${varnishd_backend:="localhost:8080"}
+: ${varnishd_storage:="file,/tmp,50%"}
+: ${varnishd_hash:="classic,16383"}
+: ${varnishd_user:="www"}
+: ${varnishd_group:="www"}
+if [ -n "${varnishd_config}" ] ; then
+ : ${varnishd_flags:="-P ${varnishd_pidfile} -a ${varnishd_listen} -T ${varnishd_admin} -f ${varnishd_config} -s ${varnishd_storage} -h ${varnishd_hash} -u ${varnishd_user} -g ${varnishd_group}"}
+else
+ : ${varnishd_flags:="-P ${varnishd_pidfile} -a ${varnishd_listen} -T ${varnishd_admin} -b ${varnishd_backend} -s ${varnishd_storage} -h ${varnishd_hash} -u ${varnishd_user} -g ${varnishd_group}"}
+fi
+
+# If we leave these set, rc.subr will su to them before starting
+# varnishd, which is not what we want.
+unset varnishd_user
+unset varnishd_group
+
+pidfile="${varnishd_pidfile}"
+run_rc_command "$1"
diff --git a/www/varnish4/files/varnishlog.in b/www/varnish4/files/varnishlog.in
new file mode 100644
index 000000000000..c7b298059097
--- /dev/null
+++ b/www/varnish4/files/varnishlog.in
@@ -0,0 +1,49 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+# PROVIDE: varnishlog
+# REQUIRE: DAEMON
+# KEYWORD: shutdown
+
+#
+# Add the following line to /etc/rc.conf to enable varnishlog:
+#
+# varnishlog_enable="YES"
+#
+# Configuration variables and their default values:
+#
+# varnishlog_pidfile - full path to the PID file.
+# default: "/var/run/varnishlog.pid"
+#
+# varnishlog_file - full path to the log file.
+# default: "/var/log/varnish.log"
+#
+# varnishlog_flags - command line arguments.
+# default: "-D -P ${varnishlog_pidfile} -a -w ${varnishlog_file}"
+#
+# Add the following line to /etc/newsyslog.conf to rotate the log file
+# once a day:
+#
+# /var/log/varnish.log 640 7 * @T00 JB /var/run/varnishlog.pid
+#
+# See varnishlog(1) for a detailed overview of command-line options.
+#
+
+. /etc/rc.subr
+
+name="varnishlog"
+rcvar=varnishlog_enable
+
+command="%%PREFIX%%/bin/${name}"
+
+# read configuration and set defaults
+load_rc_config ${name}
+: ${varnishlog_enable:="NO"}
+: ${varnishlog_pidfile:="/var/run/${name}.pid"}
+: ${varnishlog_file:="/var/log/varnish.log"}
+: ${varnishlog_flags:="-P ${varnishlog_pidfile} -D -a -w ${varnishlog_file}"}
+
+pidfile=${varnishlog_pidfile}
+run_rc_command "$1"
diff --git a/www/varnish4/files/varnishncsa.in b/www/varnish4/files/varnishncsa.in
new file mode 100644
index 000000000000..73950ccc5f16
--- /dev/null
+++ b/www/varnish4/files/varnishncsa.in
@@ -0,0 +1,49 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+# PROVIDE: varnishncsa
+# REQUIRE: DAEMON
+# KEYWORD: shutdown
+
+#
+# Add the following line to /etc/rc.conf to enable varnishncsa:
+#
+# varnishncsa_enable="YES"
+#
+# Configuration variables and their default values:
+#
+# varnishncsa_pidfile - full path to the PID file.
+# default: "/var/run/varnishncsa.pid"
+#
+# varnishncsa_file - full path to the log file.
+# default: "/var/log/varnishncsa.log"
+#
+# varnishncsa_flags - command line arguments.
+# default: "-D -P ${varnishncsa_pidfile} -a -c -w ${varnishncsa_file}"
+#
+# Add the following line to /etc/newsyslog.conf to rotate the log file
+# once a day:
+#
+# /var/log/varnishncsa.log 640 7 * @T00 JB /var/run/varnishncsa.pid
+#
+# See varnishncsa(1) for a detailed overview of command-line options.
+#
+
+. /etc/rc.subr
+
+name="varnishncsa"
+rcvar=varnishncsa_enable
+
+command="%%PREFIX%%/bin/${name}"
+
+# read configuration and set defaults
+load_rc_config ${name}
+: ${varnishncsa_enable:="NO"}
+: ${varnishncsa_pidfile:="/var/run/${name}.pid"}
+: ${varnishncsa_file:="/var/log/${name}.log"}
+: ${varnishncsa_flags:="-P ${varnishncsa_pidfile} -D -a -c -w ${varnishncsa_file}"}
+
+pidfile=${varnishncsa_pidfile}
+run_rc_command "$1"
diff --git a/www/varnish4/pkg-descr b/www/varnish4/pkg-descr
new file mode 100644
index 000000000000..d6e8c679fbb4
--- /dev/null
+++ b/www/varnish4/pkg-descr
@@ -0,0 +1,12 @@
+This is the Varnish high-performance HTTP accelerator.
+
+Documentation and additional information about Varnish is available on
+<URL:http://varnish.projects.linpro.no/>.
+
+Technical questions about Varnish and this release should be addressed
+to <varnish-dev@projects.linpro.no>.
+
+Questions about commercial support and services related to Varnish
+should be addressed to <varnish@linpro.no>.
+
+WWW: http://www.varnish-cache.org/
diff --git a/www/varnish4/pkg-plist b/www/varnish4/pkg-plist
new file mode 100644
index 000000000000..932808b57ef7
--- /dev/null
+++ b/www/varnish4/pkg-plist
@@ -0,0 +1,91 @@
+bin/varnishadm
+bin/varnishhist
+bin/varnishlog
+bin/varnishncsa
+bin/varnishstat
+bin/varnishtest
+bin/varnishtop
+include/varnish/cache/cache.h
+include/varnish/cache/cache_backend.h
+include/varnish/common/common.h
+include/varnish/common/params.h
+include/varnish/miniobj.h
+include/varnish/tbl/acct_fields_bereq.h
+include/varnish/tbl/acct_fields_req.h
+include/varnish/tbl/backend_poll.h
+include/varnish/tbl/ban_vars.h
+include/varnish/tbl/bo_flags.h
+include/varnish/tbl/body_status.h
+include/varnish/tbl/debug_bits.h
+include/varnish/tbl/feature_bits.h
+include/varnish/tbl/http_headers.h
+include/varnish/tbl/http_response.h
+include/varnish/tbl/locks.h
+include/varnish/tbl/req_body.h
+include/varnish/tbl/sess_close.h
+include/varnish/tbl/steps.h
+include/varnish/tbl/symbol_kind.h
+include/varnish/tbl/vcc_types.h
+include/varnish/tbl/vcl_returns.h
+include/varnish/tbl/vrt_stv_var.h
+include/varnish/tbl/vsc_all.h
+include/varnish/tbl/vsc_f_main.h
+include/varnish/tbl/vsc_fields.h
+include/varnish/tbl/vsc_levels.h
+include/varnish/tbl/vsc_types.h
+include/varnish/tbl/vsl_tags.h
+include/varnish/tbl/vsl_tags_http.h
+include/varnish/vapi/vapi_options.h
+include/varnish/vapi/voptget.h
+include/varnish/vapi/vsc.h
+include/varnish/vapi/vsc_int.h
+include/varnish/vapi/vsl.h
+include/varnish/vapi/vsl_int.h
+include/varnish/vapi/vsm.h
+include/varnish/vapi/vsm_int.h
+include/varnish/vas.h
+include/varnish/vav.h
+include/varnish/vbm.h
+include/varnish/vcl.h
+include/varnish/vcli.h
+include/varnish/vcs.h
+include/varnish/vdef.h
+include/varnish/vmod_abi.h
+include/varnish/vqueue.h
+include/varnish/vre.h
+include/varnish/vrt.h
+include/varnish/vrt_obj.h
+include/varnish/vsa.h
+include/varnish/vsb.h
+include/varnish/vsha256.h
+lib/libvarnishapi.so
+lib/libvarnishapi.so.1
+lib/libvarnishapi.so.1.0.0
+lib/varnish/libvarnish.so
+lib/varnish/libvarnishcompat.so
+lib/varnish/libvcc.so
+lib/varnish/libvgz.so
+lib/varnish/vmods/libvmod_directors.so
+lib/varnish/vmods/libvmod_std.so
+libdata/pkgconfig/varnishapi.pc
+man/man1/varnishadm.1.gz
+man/man1/varnishd.1.gz
+man/man1/varnishhist.1.gz
+man/man1/varnishlog.1.gz
+man/man1/varnishncsa.1.gz
+man/man1/varnishstat.1.gz
+man/man1/varnishtest.1.gz
+man/man1/varnishtop.1.gz
+man/man3/vmod_directors.3.gz
+man/man3/vmod_std.3.gz
+man/man7/varnish-cli.7.gz
+man/man7/varnish-counters.7.gz
+man/man7/vcl.7.gz
+man/man7/vsl-query.7.gz
+man/man7/vsl.7.gz
+sbin/varnishd
+share/aclocal/varnish.m4
+%%PORTDOCS%%%%DOCSDIR%%/builtin.vcl
+%%PORTDOCS%%%%DOCSDIR%%/example.vcl
+%%DATADIR%%/vmodtool.py
+@dir varnish