aboutsummaryrefslogtreecommitdiff
path: root/www/w3-4/Makefile
diff options
context:
space:
mode:
authorMasafumi Max NAKANE <max@FreeBSD.org>1997-01-04 00:36:59 +0000
committerMasafumi Max NAKANE <max@FreeBSD.org>1997-01-04 00:36:59 +0000
commit7b0003204da92fc93ef955d4dbde920879ccb016 (patch)
treeabf828e886f1e2881ec468eb1eab9c6fb0a19ee1 /www/w3-4/Makefile
parentaa357f715076fd6b24a9d656d64c303aa4fbe404 (diff)
downloadports-7b0003204da92fc93ef955d4dbde920879ccb016.tar.gz
ports-7b0003204da92fc93ef955d4dbde920879ccb016.zip
Rename files/.{emacs,mosaic-hotlist-default} to
dot.{emacs,mosaic-hotlist-default}. Install sample files into share/examples/w3 instead of to share/doc/w3. Use PKG_PREFIX in the installation/deinstallation scripts. Some Makefile cleanup. Submitted by: (Kiriyama Kazuhiko) <kiri@kiri.toba-cmt.ac.jp>
Notes
Notes: svn path=/head/; revision=5201
Diffstat (limited to 'www/w3-4/Makefile')
-rw-r--r--www/w3-4/Makefile18
1 files changed, 10 insertions, 8 deletions
diff --git a/www/w3-4/Makefile b/www/w3-4/Makefile
index a303be9cc242..974cea267372 100644
--- a/www/w3-4/Makefile
+++ b/www/w3-4/Makefile
@@ -1,9 +1,9 @@
# New ports collection makefile for: w3 on Emacs
# Version required: 2.2.26
-# Date created: 30 November 1996
+# Date created: 31 December 1996
# Whom: MITA Yoshio <mita@ee.t.u-tokyo.ac.jp>
#
-# $Id$
+# $Id: Makefile,v 1.1.1.1 1996/12/18 05:26:32 asami Exp $
#
DISTNAME= w3-2.2.26
@@ -19,18 +19,20 @@ RUN_DEPENDS= emacs:${PORTSDIR}/editors/emacs
WRKSRC= ${WRKDIR}/w3
DOCDIR= ${PREFIX}/share/doc/w3
+SAMPLEDIR= ${PREFIX}/share/examples/w3
post-install:
.if !defined(NOPORTDOCS)
- @if [ ! -d ${DOCDIR} ]; then mkdir -p ${DOCDIR}; fi
-.for f in .emacs .mosaic-hotlist-default
- @${CP} ${FILESDIR}/${f} ${DOCDIR}
+ @${MKDIR} ${DOCDIR}
+ @${MKDIR} ${SAMPLEDIR}
+.for f in dot.emacs dot.mosaic-hotlist-default
+ @${INSTALL_DATA} ${FILESDIR}/${f} ${SAMPLEDIR}
.endfor
- @${INSTALL_SCRIPT} ${FILESDIR}/user-install ${DOCDIR}
+ @${INSTALL_SCRIPT} ${FILESDIR}/user-install ${SAMPLEDIR}
.for f in W3.ad clean-cache Makefile w3.txi
- @${CP} ${WRKSRC}/${f} ${DOCDIR}
+ @${INSTALL_DATA} ${WRKSRC}/${f} ${DOCDIR}
.endfor
.endif
- @/bin/sh ${PKGDIR}/INSTALL ${PKGNAME} POST-INSTALL
+ @${SETENV} PKG_PREFIX=${PREFIX} /bin/sh ${PKGDIR}/INSTALL ${PKGNAME} POST-INSTALL
.include <bsd.port.mk>