aboutsummaryrefslogtreecommitdiff
path: root/www/w3
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>1996-12-18 05:26:32 +0000
committerSatoshi Asami <asami@FreeBSD.org>1996-12-18 05:26:32 +0000
commit52f538cad04b948ebf775fe312fdcb22e4f9e18f (patch)
tree965c9d5ba0371b4ff2e7cab42ace5115da7d6c32 /www/w3
parentc8edeba2cd3dbf670b91b0c675186d72dc0d2d28 (diff)
downloadports-52f538cad04b948ebf775fe312fdcb22e4f9e18f.tar.gz
ports-52f538cad04b948ebf775fe312fdcb22e4f9e18f.zip
Web browser based on emacs/mule.
Submitted by: Kiriyama Kazuhiko <kiri@kiri.toba-cmt.ac.jp>
Notes
Notes: svn path=/head/; revision=5016
Diffstat (limited to 'www/w3')
-rw-r--r--www/w3/Makefile36
-rw-r--r--www/w3/distinfo1
-rw-r--r--www/w3/files/patch-aa40
-rw-r--r--www/w3/pkg-comment1
-rw-r--r--www/w3/pkg-descr27
-rw-r--r--www/w3/pkg-plist70
6 files changed, 175 insertions, 0 deletions
diff --git a/www/w3/Makefile b/www/w3/Makefile
new file mode 100644
index 000000000000..a303be9cc242
--- /dev/null
+++ b/www/w3/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: w3 on Emacs
+# Version required: 2.2.26
+# Date created: 30 November 1996
+# Whom: MITA Yoshio <mita@ee.t.u-tokyo.ac.jp>
+#
+# $Id$
+#
+
+DISTNAME= w3-2.2.26
+CATEGORIES= www
+MASTER_SITES= ftp://ftp.iij.ad.jp/pub/network/WWW/w3/ \
+ ftp://ftp.cs.indiana.edu/pub/elisp/w3/
+
+MAINTAINER= kiri@kiri.toba-cmt.ac.jp
+
+BUILD_DEPENDS= emacs:${PORTSDIR}/editors/emacs
+RUN_DEPENDS= emacs:${PORTSDIR}/editors/emacs
+
+WRKSRC= ${WRKDIR}/w3
+
+DOCDIR= ${PREFIX}/share/doc/w3
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @if [ ! -d ${DOCDIR} ]; then mkdir -p ${DOCDIR}; fi
+.for f in .emacs .mosaic-hotlist-default
+ @${CP} ${FILESDIR}/${f} ${DOCDIR}
+.endfor
+ @${INSTALL_SCRIPT} ${FILESDIR}/user-install ${DOCDIR}
+.for f in W3.ad clean-cache Makefile w3.txi
+ @${CP} ${WRKSRC}/${f} ${DOCDIR}
+.endfor
+.endif
+ @/bin/sh ${PKGDIR}/INSTALL ${PKGNAME} POST-INSTALL
+
+.include <bsd.port.mk>
diff --git a/www/w3/distinfo b/www/w3/distinfo
new file mode 100644
index 000000000000..90db576bc408
--- /dev/null
+++ b/www/w3/distinfo
@@ -0,0 +1 @@
+MD5 (w3-2.2.26.tar.gz) = b53c81896353eec79911455d67d24339
diff --git a/www/w3/files/patch-aa b/www/w3/files/patch-aa
new file mode 100644
index 000000000000..0429fd811d79
--- /dev/null
+++ b/www/w3/files/patch-aa
@@ -0,0 +1,40 @@
+--- Makefile.org Sun Oct 29 01:21:56 1995
++++ Makefile Sun Dec 1 14:01:52 1996
+@@ -8,12 +8,13 @@
+ # Various other stuff used
+ RM = rm -f
+ CP = cp
++INSTALL_DATA = /usr/bin/install -c -o bin -g bin -m 444
+
+ # where the Info file should go
+-INFODIR = ../info
++INFODIR = ${PREFIX}/info
+
+ # where the w3 lisp files should go
+-LISPDIR = $$HOME/lisp
++LISPDIR = ${PREFIX}/share/emacs/site-lisp/w3
+
+ # Change this to be where your .emacs file is stored
+ DOTEMACS = $$HOME/.emacs
+@@ -57,16 +58,16 @@
+ w3: docomp.el $(OBJECTS)
+ @echo Build of w3 complete...
+
+-all: w3.info w3 emacs
++all: w3.info w3
+
+ install: all
+ @echo Installing in $(LISPDIR)
+ if [ ! -d $(LISPDIR) ] ; then $(MKDIR) $(LISPDIR) ; fi
+- (cd $(LISPDIR) ; $(RM) -f $(SOURCES) $(OBJECTS) w3-sysdp.el*)
+- $(CP) $(SOURCES) $(OBJECTS) $(LISPDIR)
++ (cd $(LISPDIR) ; $(RM) $(SOURCES) $(OBJECTS) w3-sysdp.el*)
++ ${INSTALL_DATA} $(SOURCES) $(OBJECTS) $(LISPDIR)
+ if [ ! -d $(INFODIR) ] ; then $(MKDIR) $(INFODIR) ; fi
+- (cd $(INFODIR) ; $(RM) -f w3.info*)
+- $(CP) w3.info* $(INFODIR)
++ (cd $(INFODIR) ; $(RM) w3.info*)
++ ${INSTALL_DATA} w3.info* $(INFODIR)
+
+ emacs:
+ @echo Adding w3 setup to $(DOTEMACS)
diff --git a/www/w3/pkg-comment b/www/w3/pkg-comment
new file mode 100644
index 000000000000..f40be1afb337
--- /dev/null
+++ b/www/w3/pkg-comment
@@ -0,0 +1 @@
+WWW browser based on emacs/mule
diff --git a/www/w3/pkg-descr b/www/w3/pkg-descr
new file mode 100644
index 000000000000..98848a562c48
--- /dev/null
+++ b/www/w3/pkg-descr
@@ -0,0 +1,27 @@
+w3-2.2.26 package is WWW browser package for emacs.
+
+Info path and elisp load path would be set as follows :
+
+ Info path - /usr/local/info
+ load path - /usr/local/share/emacs/site-lisp/mew
+
+You may be happy by adding following lines to your .emacs file:
+
+ (setq url-keep-history t)
+ (setq url-be-asynchronous t)
+ (setq w3-default-homepage
+ "file://localhost/usr/share/doc/handbook/handbook.html")
+
+and copying .mosaic-hotlist-default file from /usr/local/share/doc/w3
+directory to your home directory.
+
+Setting above user environment would be only executed by
+/usr/local/share/doc/mew/user-install on your home directory.
+
+If you want to get an typesetting manual, copy Makefile and w3.texi from
+/usr/local/share/doc/w3 and 'make w3.dvi'.
+
+If you have installed correctly, type "M-x w3". Enjoy!
+
+- Kiriyama Kazuhiko
+kiri@kiri.toba-cmt.ac.jp
diff --git a/www/w3/pkg-plist b/www/w3/pkg-plist
new file mode 100644
index 000000000000..a456f9923b40
--- /dev/null
+++ b/www/w3/pkg-plist
@@ -0,0 +1,70 @@
+info/w3.info
+info/w3.info-1
+info/w3.info-2
+info/w3.info-3
+info/w3.info-4
+share/doc/w3/.emacs
+share/doc/w3/.mosaic-hotlist-default
+share/doc/w3/Makefile
+share/doc/w3/W3.ad
+share/doc/w3/clean-cache
+share/doc/w3/user-install
+share/doc/w3/w3.txi
+share/emacs/site-lisp/w3/base64.el
+share/emacs/site-lisp/w3/base64.elc
+share/emacs/site-lisp/w3/font.el
+share/emacs/site-lisp/w3/font.elc
+share/emacs/site-lisp/w3/md5.el
+share/emacs/site-lisp/w3/md5.elc
+share/emacs/site-lisp/w3/mm.el
+share/emacs/site-lisp/w3/mm.elc
+share/emacs/site-lisp/w3/ssl.el
+share/emacs/site-lisp/w3/ssl.elc
+share/emacs/site-lisp/w3/url-hash.el
+share/emacs/site-lisp/w3/url-hash.elc
+share/emacs/site-lisp/w3/url.el
+share/emacs/site-lisp/w3/url.elc
+share/emacs/site-lisp/w3/urlauth.el
+share/emacs/site-lisp/w3/urlauth.elc
+share/emacs/site-lisp/w3/w3-about.el
+share/emacs/site-lisp/w3/w3-about.elc
+share/emacs/site-lisp/w3/w3-beta.el
+share/emacs/site-lisp/w3/w3-beta.elc
+share/emacs/site-lisp/w3/w3-draw.el
+share/emacs/site-lisp/w3/w3-draw.elc
+share/emacs/site-lisp/w3/w3-e19.el
+share/emacs/site-lisp/w3/w3-e19.elc
+share/emacs/site-lisp/w3/w3-emacs.el
+share/emacs/site-lisp/w3/w3-emacs.elc
+share/emacs/site-lisp/w3/w3-epoch.el
+share/emacs/site-lisp/w3/w3-epoch.elc
+share/emacs/site-lisp/w3/w3-hot.el
+share/emacs/site-lisp/w3/w3-hot.elc
+share/emacs/site-lisp/w3/w3-mac.el
+share/emacs/site-lisp/w3/w3-mac.elc
+share/emacs/site-lisp/w3/w3-mule.el
+share/emacs/site-lisp/w3/w3-mule.elc
+share/emacs/site-lisp/w3/w3-next.el
+share/emacs/site-lisp/w3/w3-next.elc
+share/emacs/site-lisp/w3/w3-parse.el
+share/emacs/site-lisp/w3/w3-parse.elc
+share/emacs/site-lisp/w3/w3-print.el
+share/emacs/site-lisp/w3/w3-print.elc
+share/emacs/site-lisp/w3/w3-srch.el
+share/emacs/site-lisp/w3/w3-srch.elc
+share/emacs/site-lisp/w3/w3-style.el
+share/emacs/site-lisp/w3/w3-style.elc
+share/emacs/site-lisp/w3/w3-sysdp.el
+share/emacs/site-lisp/w3/w3-sysdp.elc
+share/emacs/site-lisp/w3/w3-vars.el
+share/emacs/site-lisp/w3/w3-vars.elc
+share/emacs/site-lisp/w3/w3-wemac.el
+share/emacs/site-lisp/w3/w3-wemac.elc
+share/emacs/site-lisp/w3/w3-xemac.el
+share/emacs/site-lisp/w3/w3-xemac.elc
+share/emacs/site-lisp/w3/w3.el
+share/emacs/site-lisp/w3/w3.elc
+share/emacs/site-lisp/w3/xbm-button.el
+share/emacs/site-lisp/w3/xbm-button.elc
+share/emacs/site-lisp/w3/xpm-button.el
+share/emacs/site-lisp/w3/xpm-button.elc