aboutsummaryrefslogtreecommitdiff
path: root/www/w3m
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-03-22 11:53:34 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-03-22 11:53:34 +0000
commit606c17b9c8ceebf3bba34704094912556f260836 (patch)
tree5f0dbe9212a3377e7182c77ac610d48050fcb2b0 /www/w3m
parent919430dbf0343ab4fb4c8362bb4b711509b3981b (diff)
downloadports-606c17b9c8ceebf3bba34704094912556f260836.tar.gz
ports-606c17b9c8ceebf3bba34704094912556f260836.zip
Convert a bunch of www ports to new options framework
Notes
Notes: svn path=/head/; revision=314915
Diffstat (limited to 'www/w3m')
-rw-r--r--www/w3m/Makefile27
1 files changed, 14 insertions, 13 deletions
diff --git a/www/w3m/Makefile b/www/w3m/Makefile
index 0fde646e99e6..808821cbb217 100644
--- a/www/w3m/Makefile
+++ b/www/w3m/Makefile
@@ -27,25 +27,26 @@ DOCS= FAQ.html HISTORY MANUAL.html README \
keymap.lynx menu.default menu.submenu
.if !defined(MASTERDIR)
-OPTIONS= M17N "Multilingualization support" off \
- JAPANESE "Japanese messages and migemo support" off \
- INLINE_IMAGE "Inline image support" off \
- KEY_LYNX "Keymap like lynx browser" off
+OPTIONS_DEFINE= M17N JAPANESE INLINE_IMAGE KEY_LYNX DOCS
+M17N_DESC= Multilingualization support
+JAPANESE_DESC= Japanese messages and migemo support
+INLINE_IMAGE_DESC= Inline image support
+KEY_LYNX_DESC= Keymap like lynx browser
.include <bsd.port.options.mk>
.endif
-.if defined(WITH_M17N)
+.if ${PORT_OPTIONS:MM17N}
CONFIGURE_ARGS+= --enable-m17n
PLIST_SUB+= M17N=""
.else
-.if !defined(WITH_JAPANESE)
+.if ! ${PORT_OPTIONS:MJAPANESE}
CONFIGURE_ARGS+= --disable-m17n
PLIST_SUB+= M17N="@comment "
.endif
.endif
-.if defined(WITH_JAPANESE)
+.if ${PORT_OPTIONS:MJAPANESE}
USE_GETTEXT= yes
CONFIGURE_ARGS+= --enable-m17n --enable-japanese=E --with-migemo=yes gt_cv_func_gnugettext1_libintl=yes
DOCS_JP= ${DOCS} README.SSL README.cookie README.keymap README.mailcap \
@@ -57,7 +58,7 @@ CONFIGURE_ARGS+= --disable-nls
PLIST_SUB+= JAPANESE="@comment "
.endif
-.if defined(WITH_INLINE_IMAGE)
+.if ${PORT_OPTIONS:MINLINE_IMAGE}
USE_GNOME= gtk20
CONFIGURE_ARGS+= --with-imagelib=gtk2 --enable-image=fb,x11
@@ -74,7 +75,7 @@ PLIST_SUB+= INLINE_IMAGE="@comment "
PKGMESSAGE= ${NONEXISTENT}
.endif
-.if defined(WITH_KEY_LYNX)
+.if ${PORT_OPTIONS:MKEY_LYNX}
CONFIGURE_ARGS+= --enable-keymap=lynx
.endif
@@ -89,8 +90,8 @@ post-patch:
-exec ${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|g' {} +
post-install:
-.if !defined(NOPORTDOCS)
-.if defined(WITH_JAPANESE)
+.if ${PORT_OPTIONS:MDOCS}
+.if ${PORT_OPTIONS:MJAPANESE}
@${MKDIR} ${PREFIX}/share/doc/ja/w3m
@cd ${WRKSRC}/doc-jp; \
for i in ${DOCS_JP} ; do \
@@ -102,12 +103,12 @@ post-install:
for i in ${DOCS} ; do \
${INSTALL_DATA} $$i ${PREFIX}/share/doc/w3m/ ; \
done
-.if defined(WITH_M17N) || defined(WITH_JAPANESE)
+.if ${PORT_OPTIONS:MM17N} || ${PORT_OPTIONS:MJAPANESE}
@${INSTALL_DATA} ${WRKSRC}/doc/README.m17n ${PREFIX}/share/doc/w3m
.endif
.endif
@${INSTALL_MAN} ${WRKSRC}/scripts/w3mman/w3mman.1 ${PREFIX}/man/ja/man1
-.if defined(WITH_INLINE_IMAGE)
+.if ${PORT_OPTIONS:MINLINE_IMAGE}
@${CAT} ${PKGMESSAGE}
.endif