aboutsummaryrefslogtreecommitdiff
path: root/www/webcalendar-devel
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2008-01-10 00:06:11 +0000
committerBeech Rintoul <beech@FreeBSD.org>2008-01-10 00:06:11 +0000
commit4355c2c0256069c6ed059f8d210eb190fc6ccb97 (patch)
tree8eb25521e4bc24075d6a4fda11bf1ae739acf095 /www/webcalendar-devel
parent2bbf54afc4b34d47df5506922ed62cd19997ea6c (diff)
downloadports-4355c2c0256069c6ed059f8d210eb190fc6ccb97.tar.gz
ports-4355c2c0256069c6ed059f8d210eb190fc6ccb97.zip
- New port webcalendar-devel-1.1.6
- This is a port of the WebCalendar application. WebCalendar is an Open Source web-based calendar/scheduling system written in PHP. WebCalendar has been under development since 2000 and continues to evolve. PR: ports/119474 Submitted by: Greg Larkin <glarkin@sourcehosting.net> (maintainer) Approved by: linimon (mentor)
Notes
Notes: svn path=/head/; revision=205345
Diffstat (limited to 'www/webcalendar-devel')
-rw-r--r--www/webcalendar-devel/Makefile120
-rw-r--r--www/webcalendar-devel/distinfo3
-rw-r--r--www/webcalendar-devel/files/pkg-message.in14
-rw-r--r--www/webcalendar-devel/pkg-descr8
4 files changed, 145 insertions, 0 deletions
diff --git a/www/webcalendar-devel/Makefile b/www/webcalendar-devel/Makefile
new file mode 100644
index 000000000000..5a7e8d1557be
--- /dev/null
+++ b/www/webcalendar-devel/Makefile
@@ -0,0 +1,120 @@
+# New ports collection makefile for: WebCalendar
+# Date created: 08 Jan 2008
+# Whom: glarkin
+#
+# $FreeBSD$
+#
+
+PORTNAME= WebCalendar
+PORTVERSION= 1.1.6
+CATEGORIES= www
+MASTER_SITES= SF
+MASTER_SITE_SUBDIR= webcalendar
+PKGNAMESUFFIX= -devel
+DISTNAME= ${PORTNAME:S/-devel//g}-${PORTVERSION}
+
+MAINTAINER= glarkin@sourcehosting.net
+COMMENT= A web-based calendar application
+
+USE_PHP= pcre session
+WANT_PHP_WEB= yes
+NO_BUILD= yes
+CONFLICTS= WebCalendar-[0-9]*
+
+WRKSRC= ${WRKDIR}/${DISTNAME}
+
+WCURL?= ${MASTER_SITE_SUBDIR}
+WCDIR?= www/${WCURL}
+PLIST= ${WRKDIR}/pkg-plist
+
+SUB_FILES= pkg-message
+SUB_LIST= WCURL=${WCURL} WCDIR=${WCDIR}
+
+DOCSDIR?= ${PREFIX}/share/doc/${MASTER_SITE_SUBDIR}
+PORTDOCS= WebCalendar-SysAdmin.html \
+ newwin.gif
+
+OPTIONS= MYSQL "Use MySQL database backend (default)" On \
+ PGSQL "Use PostgreSQL database backend" Off \
+ MSSQL "Use MSSQL database backend" Off \
+ DBASE "Use DBase database backend" Off \
+ ODBC "Use ODBC database backend" Off \
+ ORACLE "Use Oracle database backend" Off \
+ LDAP "Use LDAP user authentication" Off \
+ GRADIENTBG "Add gradient background image support" Off \
+ REMINDERS "Add email reminder support" On
+
+.include <bsd.port.pre.mk>
+
+DB_DEFINED= no
+
+.if !defined(WITHOUT_MYSQL)
+USE_PHP+= mysql
+DB_DEFINED= yes
+.endif
+
+.if defined(WITH_PGSQL)
+USE_PHP+= pgsql
+DB_DEFINED= yes
+.endif
+
+.if defined(WITH_MSSQL)
+USE_PHP+= mssql
+DB_DEFINED= yes
+.endif
+
+.if defined(WITH_DBASE)
+USE_PHP+= dbase
+DB_DEFINED= yes
+.endif
+
+.if defined(WITH_ODBC)
+USE_PHP+= odbc
+DB_DEFINED= yes
+.endif
+
+.if defined(WITH_ORACLE)
+USE_PHP+= oracle
+DB_DEFINED= yes
+.endif
+
+.if ${DB_DEFINED} == "no"
+IGNORE= please choose database backend by running 'make config'
+.endif
+
+.if defined(WITH_LDAP)
+USE_PHP+= ldap
+.endif
+
+.if defined(WITH_GRADIENTBG)
+USE_PHP+= gd
+.endif
+
+.if defined(WITH_REMINDERS)
+WANT_PHP_CLI= yes
+.endif
+
+pre-install:
+ cd ${WRKSRC} && ${FIND} -s * -type f | \
+ ${SED} -e 's|^|${WCDIR}/|' > ${PLIST} \
+ && ${FIND} -d * -type d | \
+ ${SED} -e 's|^|@dirrm ${WCDIR}/|' >> ${PLIST} \
+ && ${ECHO_CMD} @dirrm ${WCDIR} >> ${PLIST}
+ @${ECHO_CMD} @dirrmtry www/data-dist >> ${PLIST}
+ @${ECHO_CMD} @dirrmtry www/data >> ${PLIST}
+
+do-install:
+ @cd ${WRKSRC} && ${COPYTREE_SHARE} . ${PREFIX}/${WCDIR}
+ @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${PREFIX}/${WCDIR}
+ @${FIND} ${PREFIX}/${WCDIR} -type f -print0 | ${XARGS} -0 ${CHMOD} 644
+ @${ECHO_CMD} '@exec ${CHOWN} -R ${WWWOWN}:${WWWGRP} \
+ ${WCDIR:S|^${PREFIX}/|%D/|}' >> ${TMPPLIST}
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @cd ${WRKSRC}/docs && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+.endif
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/www/webcalendar-devel/distinfo b/www/webcalendar-devel/distinfo
new file mode 100644
index 000000000000..47d467a67ec0
--- /dev/null
+++ b/www/webcalendar-devel/distinfo
@@ -0,0 +1,3 @@
+MD5 (WebCalendar-1.1.6.tar.gz) = 1a9e80abd7373008e0b998525dd03404
+SHA256 (WebCalendar-1.1.6.tar.gz) = ea8ede2a7ce74a3f5c72a7039ec5db6f6ee8db80e8a461f79cd493f16ac87d42
+SIZE (WebCalendar-1.1.6.tar.gz) = 1300618
diff --git a/www/webcalendar-devel/files/pkg-message.in b/www/webcalendar-devel/files/pkg-message.in
new file mode 100644
index 000000000000..cf55974b4b30
--- /dev/null
+++ b/www/webcalendar-devel/files/pkg-message.in
@@ -0,0 +1,14 @@
+*************************************************
+Post-installation instructions:
+
+First, add the following line to your httpd.conf:
+
+Alias /%%WCURL%%/ "%%PREFIX%%/%%WCDIR%%/"
+
+Make sure to restart your web server after changing
+httpd.conf.
+
+Next, to configure WebCalendar, please visit
+http://localhost/%%WCURL%%/ and you will
+be guided through the installation process.
+*************************************************
diff --git a/www/webcalendar-devel/pkg-descr b/www/webcalendar-devel/pkg-descr
new file mode 100644
index 000000000000..7bee540983fb
--- /dev/null
+++ b/www/webcalendar-devel/pkg-descr
@@ -0,0 +1,8 @@
+This is a port of the WebCalendar application. WebCalendar is an
+Open Source web-based calendar/scheduling system written in PHP.
+WebCalendar has been under development since 2000 and continues
+to evolve.
+
+WWW: http://www.k5n.us/webcalendar.php
+- Greg Larkin
+glarkin@sourcehosting.net