aboutsummaryrefslogtreecommitdiff
path: root/www/webcalendar
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2006-11-07 17:37:01 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2006-11-07 17:37:01 +0000
commit2a26c0c7b5abad8865399e71792a4be1b57e51f7 (patch)
treef7e48259c5c875e6d16e8891f5970f4d34a99846 /www/webcalendar
parent1f917e575ed049ff7c899af7fc9478b6341062b9 (diff)
downloadports-2a26c0c7b5abad8865399e71792a4be1b57e51f7.tar.gz
ports-2a26c0c7b5abad8865399e71792a4be1b57e51f7.zip
- Install in the correct directory (/usr/local/www/data -> /usr/local/www).
PR: ports/105053 Submitted by: Greg Larkin <glarkin@sourcehosting.net> (maintainer)
Notes
Notes: svn path=/head/; revision=176730
Diffstat (limited to 'www/webcalendar')
-rw-r--r--www/webcalendar/Makefile30
-rw-r--r--www/webcalendar/files/pkg-message.in18
-rw-r--r--www/webcalendar/pkg-message13
3 files changed, 36 insertions, 25 deletions
diff --git a/www/webcalendar/Makefile b/www/webcalendar/Makefile
index 91207f783393..c55e176a29ef 100644
--- a/www/webcalendar/Makefile
+++ b/www/webcalendar/Makefile
@@ -6,7 +6,8 @@
#
PORTNAME= WebCalendar
-DISTVERSION= 1.0.4
+PORTVERSION= 1.0.4
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= webcalendar
@@ -19,11 +20,15 @@ USE_PHP= pcre session
WANT_PHP_WEB= yes
NO_BUILD= yes
-WRKSRC= ${WRKDIR}/WebCalendar-${DISTVERSION}
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-WEBWCDIR?= www/data/WebCalendar
+WCURL?= ${PORTNAME:L}
+WCDIR?= www/${WCURL}
PLIST= ${WRKDIR}/pkg-plist
+SUB_FILES= pkg-message
+SUB_LIST= WCURL=${WCURL} WCDIR=${WCDIR}
+
DOCSDIR?= ${PREFIX}/share/doc/${PORTNAME}
DOCS= docs/README \
docs/WebCalendar-Database.html \
@@ -87,26 +92,27 @@ USE_PHP+= ldap
pre-install:
cd ${WRKSRC} && ${FIND} -s * -type f | \
- ${SED} -e 's|^|${WEBWCDIR}/|' > ${PLIST} \
+ ${SED} -e 's|^|${WCDIR}/|' > ${PLIST} \
&& ${FIND} -d * -type d | \
- ${SED} -e 's|^|@dirrm ${WEBWCDIR}/|' >> ${PLIST} \
- && ${ECHO_CMD} @dirrm ${WEBWCDIR} >> ${PLIST}
+ ${SED} -e 's|^|@dirrm ${WCDIR}/|' >> ${PLIST} \
+ && ${ECHO_CMD} @dirrm ${WCDIR} >> ${PLIST}
@${CAT} pkg-plist >> ${PLIST}
@${ECHO_CMD} @dirrmtry www/data-dist >> ${PLIST}
@${ECHO_CMD} @dirrmtry www/data >> ${PLIST}
do-install:
- @${MKDIR} ${PREFIX}/${WEBWCDIR}
- ${CP} -R ${WRKSRC}/* ${PREFIX}/${WEBWCDIR}
- ${CHOWN} -R www:www ${PREFIX}/${WEBWCDIR}
- ${FIND} ${PREFIX}/${WEBWCDIR} -type f | ${XARGS} ${CHMOD} 644
+ @${MKDIR} ${PREFIX}/${WCDIR}
+ ${CP} -R ${WRKSRC}/* ${PREFIX}/${WCDIR}
+ ${CHOWN} -R www:www ${PREFIX}/${WCDIR}
+ ${FIND} ${PREFIX}/${WCDIR} -type f | ${XARGS} ${CHMOD} 644
post-install:
+.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
.for i in ${DOCS}
${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
.endfor
- @${CAT} ${PKGMESSAGE} | ${SED} -e 's|%%PREFIX%%|${PREFIX}|g' \
- -e 's|%%WEBWCDIR%%|${WEBWCDIR}|g' -e 's|%%DOCSDIR%%|${DOCSDIR}|g'
+.endif
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
diff --git a/www/webcalendar/files/pkg-message.in b/www/webcalendar/files/pkg-message.in
new file mode 100644
index 000000000000..b3183580760c
--- /dev/null
+++ b/www/webcalendar/files/pkg-message.in
@@ -0,0 +1,18 @@
+*************************************************
+Post-installation instructions:
+
+First, Add the following line to your httpd.conf:
+
+Alias /%%WCURL%%/ "%%PREFIX%%/%%WCDIR%%"
+
+Next, to configure WebCalendar, please read
+%%DOCSDIR%%/WebCalendar-SysAdmin.html
+for information about creating the database, installing
+the database tables and other post-installation tasks,
+such as setting up email reminders.
+
+Finally copy
+%%PREFIX%%/%%WCDIR%%/includes/settings.php.orig to
+%%PREFIX%%/%%WCDIR%%/includes/settings.php and edit it
+for your installation.
+*************************************************
diff --git a/www/webcalendar/pkg-message b/www/webcalendar/pkg-message
deleted file mode 100644
index 709418e4f0b4..000000000000
--- a/www/webcalendar/pkg-message
+++ /dev/null
@@ -1,13 +0,0 @@
-
-Post-installation instructions:
-
-To configure WebCalendar, please read
-%%DOCSDIR%%/WebCalendar-SysAdmin.html
-for information about creating the database, installing
-the database tables and other post-installation tasks,
-such as setting up email reminders.
-
-Then copy
-%%PREFIX%%/%%WEBWCDIR%%/includes/settings.php.orig to
-%%PREFIX%%/%%WEBWCDIR%%/includes/settings.php and edit it
-for your installation.