aboutsummaryrefslogtreecommitdiff
path: root/www/webhook/Makefile
diff options
context:
space:
mode:
authorHiroki Tagato <tagattie@FreeBSD.org>2020-05-20 09:52:56 +0000
committerHiroki Tagato <tagattie@FreeBSD.org>2020-05-20 09:52:56 +0000
commit4f753313226ff846e39f851bca67b3e929e2fb80 (patch)
tree5ea1b21294b3e39b876d909d29eaa2f3a7203aa3 /www/webhook/Makefile
parentee8313f42f1713c421b2f85c0dea56023ac13cb9 (diff)
downloadports-4f753313226ff846e39f851bca67b3e929e2fb80.tar.gz
ports-4f753313226ff846e39f851bca67b3e929e2fb80.zip
- Update to 2.7.0
- Switch to USES=go:modules PR: 246423 Submitted by: stb@lassitu.de (maintainer) Approved by: mentors (implicit) Changelog: https://github.com/adnanh/webhook/releases/tag/2.7.0
Notes
Notes: svn path=/head/; revision=535988
Diffstat (limited to 'www/webhook/Makefile')
-rw-r--r--www/webhook/Makefile21
1 files changed, 13 insertions, 8 deletions
diff --git a/www/webhook/Makefile b/www/webhook/Makefile
index 3d74255ea12d..800751960e2a 100644
--- a/www/webhook/Makefile
+++ b/www/webhook/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= webhook
-PORTVERSION= 2.6.9
-PORTREVISION= 2
+PORTVERSION= 2.7.0
CATEGORIES= www
MAINTAINER= stb@lassitu.de
@@ -11,11 +10,21 @@ COMMENT= Easily create HTTP endpoints (hooks) to execute shell commands
LICENSE= APACHE20 BSD3CLAUSE MIT
LICENSE_COMB= multi
-USES= go
+USES= gmake go:modules
GO_PKGNAME= github.com/${GH_ACCOUNT}/${PORTNAME}
USE_GITHUB= yes
GH_ACCOUNT= adnanh
-GH_TUPLE= golang:sys:fead79001313:golang_sys/vendor/golang.org/x/sys_fead79001313
+GH_TUPLE= \
+ clbanning:mxj:v1.8.4:clbanning_mxj/vendor/github.com/clbanning/mxj \
+ dustin:go-humanize:v1.0.0:dustin_go_humanize/vendor/github.com/dustin/go-humanize \
+ fsnotify:fsnotify:v1.4.2:fsnotify_fsnotify/vendor/gopkg.in/fsnotify.v1 \
+ ghodss:yaml:v1.0.0:ghodss_yaml/vendor/github.com/ghodss/yaml \
+ go-chi:chi:v4.0.2:go_chi_chi/vendor/github.com/go-chi/chi \
+ go-yaml:yaml:eb3733d160e7:go_yaml_yaml/vendor/gopkg.in/yaml.v2 \
+ gofrs:uuid:v3.2.0:gofrs_uuid/vendor/github.com/gofrs/uuid \
+ golang:sys:04cbcbbfeed8:golang_sys/vendor/golang.org/x/sys \
+ gorilla:mux:v1.7.3:gorilla_mux/vendor/github.com/gorilla/mux
+
USE_RC_SUBR= webhook
GO_TARGET= :${PREFIX}/sbin/webhook
@@ -32,10 +41,6 @@ DAEMONARGS= -f
SUB_LIST+= DAEMONARGS="${DAEMONARGS}"
-pre-build:
- ${RM} -r ${WRKSRC}/vendor/golang.org/x/sys
- ${MV} ${WRKSRC}/vendor/golang.org/x/sys_fead79001313 ${WRKSRC}/vendor/golang.org/x/sys
-
post-install:
${INSTALL_DATA} ${FILESDIR}/webhook.yaml ${STAGEDIR}${PREFIX}/etc/webhook.yaml.sample