aboutsummaryrefslogtreecommitdiff
path: root/www/webkit-qt4/Makefile
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2014-01-06 16:16:52 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2014-01-06 16:16:52 +0000
commit7d5e6b666c579d543fbf4c0996e309e23de8e02e (patch)
treee9ca925ce8537078366a02e4f615c5847746c0b5 /www/webkit-qt4/Makefile
parentb60b2bc8f43a72af43a1f5ff0df9828880c2b7a8 (diff)
downloadports-7d5e6b666c579d543fbf4c0996e309e23de8e02e.tar.gz
ports-7d5e6b666c579d543fbf4c0996e309e23de8e02e.zip
In preparation for Qt 5 ports:
Mk/Uses/qmake.mk: - Add support for out-of-source builds - Add support for Qt 5 ports - Respect WITH_DEBUG Mk/bsd.qt.mk: - Massive rework for Qt 5 ports - Remove '-phonon' from global configure args, thus allow qt4-designer and qt4-qtconfig to be built without Phonon support [1] devel/qmake4: - Improve mkspecs for gcc (mainly sync with linux version) and clang devel/qt4-corelib: - Convert to USES=iconv - Remove ancient patch devel/qt4-designer: - Remove reference to WRKSRC from installed pkgconfig files [2] - Don't build Qt Designer plugin for Phonon from outdated Qt sources. Separate port for plugin will be committed later devel/qt4-assistant-adp, devel/qt4-libqtassistantclient: - Convert to USES=qmake Clean up Qt4 ports: - Update comments - Update description; use common description - Consistently use QT_INCDIR, QT_LIBDIR, etc. - Use options helpers - Convert to new LIB_DEPENDS syntax - Update DESKTOP_ENTRIES to avoid conflicts with Qt 5 ports - Rename/move several ports for unification with Qt 5 ports PR: ports/184620 [1] Reported by: Kevin Zheng <kevinz5000@gmail.com> PR: ports/181141 [2] Reported by: thierry PR: ports/185101 Exp-run by: bdrewery This is mostly solely avilla's work in area51, kudos to him! And a couple commits from myself, so you know who's collecting pointyhats :)
Notes
Notes: svn path=/head/; revision=338902
Diffstat (limited to 'www/webkit-qt4/Makefile')
-rw-r--r--www/webkit-qt4/Makefile95
1 files changed, 95 insertions, 0 deletions
diff --git a/www/webkit-qt4/Makefile b/www/webkit-qt4/Makefile
new file mode 100644
index 000000000000..7242284267a7
--- /dev/null
+++ b/www/webkit-qt4/Makefile
@@ -0,0 +1,95 @@
+# Created by: danny@ricin.com
+# $FreeBSD$
+
+PORTNAME= webkit
+DISTVERSION= ${QT4_VERSION}
+PORTREVISION= 1
+CATEGORIES= www
+PKGNAMEPREFIX= qt4-
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Qt WebKit implementation
+
+USE_QT4= corelib declarative gui network \
+ qmake_build moc_build rcc_build
+QT_DIST= yes
+USE_XORG= xrender
+USES= pkgconfig
+
+HAS_CONFIGURE= yes
+USE_LDCONFIG= ${PREFIX}/${QT_LIBDIR_REL}
+
+ALL_TARGET= first
+CONFIGURE_ENV?= QTDIR=${WRKSRC} PATH=${WRKSRC}/bin:$$PATH
+MAKE_ENV?= QTDIR=${WRKSRC} LD_LIBRARY_PATH=${WRKSRC}/lib:$$LD_LIBRARY_PATH \
+ PATH=${WRKSRC}/bin:$$PATH MAKEOBJDIR=.
+
+DO_NOT_EXTRACT= demos doc examples mkspecs qmake tools translations \
+ src/activeqt src/dbus src/opengl src/openvg src/qt3support \
+ src/s60installs src/s60main src/scripttools src/sql src/svg \
+ src/testlib src/tools src/winmain src/3rdparty/clucene \
+ src/3rdparty/freetype src/3rdparty/libjpeg src/3rdparty/libmng \
+ src/3rdparty/libpng src/3rdparty/libtiff
+.for dne in ${DO_NOT_EXTRACT}
+EXTRACT_AFTER_ARGS+= --exclude '${DISTNAME}/${dne}'
+.endfor
+
+BUILD_WRKSRC= ${WRKSRC}/src/3rdparty/${PORTNAME}/Source
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
+
+CONFIGURE_ARGS+= -I../../../../include/Qt -I../../../../include
+
+OPTIONS_DEFINE= GSTREAMER
+OPTIONS_DEFAULT=GSTREAMER
+
+GSTREAMER_USE= GSTREAMER=yes
+
+.include <bsd.port.pre.mk>
+
+# Base ld(1) segfaults on PowerPC:
+# http://bugs.freebsd.org/173042
+.if ${ARCH} == "powerpc"
+BUILD_DEPENDS+= ${LOCALBASE}/bin/ld:${PORTSDIR}/devel/binutils
+.endif
+
+# Quick hack to avoid messing up qt_webkit_version.pri installation
+# directory. bsd.port.pre.mk is required to add the setting at the end.
+CONFIGURE_ENV+= QMAKEPATH=""
+MAKE_ENV+= QMAKEPATH=""
+
+pre-configure:
+ ${MKDIR} ${WRKSRC}/mkspecs
+ ${LN} -sf ${QMAKE} ${WRKSRC}/bin/qmake
+ ${LN} -sf ${MOC} ${WRKSRC}/bin/moc
+ ${LN} -sf ${RCC} ${WRKSRC}/bin/rcc
+ ${REINPLACE_CMD} -e 's|linux-\*|unix|g' \
+ ${BUILD_WRKSRC}/WebCore/features.pri \
+ ${BUILD_WRKSRC}/JavaScriptCore/wtf/wtf.pri
+.if ! ${PORT_OPTIONS:MGSTREAMER}
+ ${REINPLACE_CMD} -e 's|.*exists.*gstreamer.*|false {|' \
+ ${BUILD_WRKSRC}/WebCore/features.pri
+.endif
+# Avoid building and installing several tests. Should this be made an option?
+ ${REINPLACE_CMD} -e '/WebKit\/qt\/tests/ d' \
+ ${BUILD_WRKSRC}/WebKit.pro
+
+post-configure:
+ ${REINPLACE_CMD} \
+ -e 's|${PREFIX}/${QT_LIBDIR_REL}/pkgconfig|${PREFIX}/libdata/pkgconfig|g' \
+ -e 's|.*$$(QMAKE).*||g' \
+ -e '/^CFLAGS/ s|-I${LOCALBASE}/include ||g' \
+ -e '/^CXXFLAGS/ s|-I${LOCALBASE}/include ||g' \
+ ${BUILD_WRKSRC}/Makefile \
+ ${BUILD_WRKSRC}/WebCore/Makefile \
+ ${BUILD_WRKSRC}/WebKit/qt/Makefile
+ ${CP} ${BUILD_WRKSRC}/WebKit/qt/Makefile \
+ ${BUILD_WRKSRC}/WebKit/qt/Makefile.QtWebKit
+ ${REINPLACE_CMD} -E -e 's|-L.[^[:space:]]*qt-x11-opensource.[^[:space:]]*lib||g' \
+ -E -e 's|(.*location=).*moc|\1${PREFIX}/${QT_BINDIR_REL}/${MOC:T}|g' \
+ ${WRKSRC}/lib/pkgconfig/QtWebKit.pc
+# QtWebKit is statically linked with jscore, remove the latest.
+ ${REINPLACE_CMD} -e 's|-L../JavaScriptCore/release||; s|-ljscore||' \
+ ${WRKSRC}/lib/pkgconfig/QtWebKit.pc \
+ ${WRKSRC}/lib/libQtWebKit.la
+
+.include <bsd.port.post.mk>