aboutsummaryrefslogtreecommitdiff
path: root/www/yanopaste/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-09-23 08:13:17 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-09-23 08:13:17 +0000
commitebcf9e25c667fcea4bc3cbe64c59c0aaa69f558d (patch)
tree481b0c0dd93031f0cc2147b9dd00880d425a377c /www/yanopaste/Makefile
parenta7ab62f02d66cdebce5dc85fab03a324ffe69691 (diff)
downloadports-ebcf9e25c667fcea4bc3cbe64c59c0aaa69f558d.tar.gz
ports-ebcf9e25c667fcea4bc3cbe64c59c0aaa69f558d.zip
Yet Another Nopaste is a PHP implementation of nopaste, allowing copy / paste
of piece of code from numerous language to share it using a simple URL, optionally protected using a password. It uses GeSHi as highlighter back-end. It does not use database. WWW: http://sourceforge.net/projects/yanopaste/
Notes
Notes: svn path=/head/; revision=220516
Diffstat (limited to 'www/yanopaste/Makefile')
-rw-r--r--www/yanopaste/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/www/yanopaste/Makefile b/www/yanopaste/Makefile
new file mode 100644
index 000000000000..c01785f545f9
--- /dev/null
+++ b/www/yanopaste/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: yanopaste
+# Date created: 2008-09-15
+# Whom: Martin Wilke <miwi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= yanopaste
+PORTVERSION= 1.2.0
+CATEGORIES= www
+MASTER_SITES= SF
+
+MAINTAINER= miwi@FreeBSD.org
+COMMENT= Yet Another Nopaste
+
+NO_BUILD= yes
+USE_PHP= xsl
+SUB_FILES= pkg-message
+WWWDIR?= ${PREFIX}/www/${PORTNAME}
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+ ${FIND} ${WRKSRC} -name .svn -type d | ${XARGS} ${RM} -rf
+
+do-install:
+ @${MKDIR} ${WWWDIR}
+ ${CP} -R ${WRKSRC}/ ${WWWDIR}
+ @${TOUCH} ${WWWDIR}/config.php
+ @${CHOWN} ${WWWOWN} ${WWWDIR}/config.php
+ @${CAT} ${PKGMESSAGE}
+
+create-plist:
+ @${FIND} -s ${WRKSRC}/${file} -not -type d \
+ | ${SED} -e 's,^${WRKSRC},%%WWWDIR%%,' > ${PLIST}
+ @${ECHO_CMD} '@exec touch %D/%%WWWDIR%%/config.php;chown ${WWWOWN} %D/%%WWWDIR%%/config.php' >> ${PLIST}
+ @${ECHO_CMD} '@unexec if [ ! -s %D/%%WWWDIR%%/config.php ];then rm -f %D/%%WWWDIR%%/config.php;fi' >> ${PLIST}
+ @${FIND} -ds ${WRKSRC}/${file} -type d \
+ | ${SED} -e 's,^${WRKSRC},@dirrm %%WWWDIR%%,' >> ${PLIST}
+
+.include <bsd.port.post.mk>