aboutsummaryrefslogtreecommitdiff
path: root/www/zope-annotations
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-01-02 21:30:46 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-01-02 21:30:46 +0000
commitf109a281bf99109c4b9083f55a301509e87de591 (patch)
tree19e94f0b83ca3ab83962ff58ea0ff6bb012fd6a3 /www/zope-annotations
parentdd97b75cb2a89ca5df4d296b6f7e62ab98c41b7a (diff)
downloadports-f109a281bf99109c4b9083f55a301509e87de591.tar.gz
ports-f109a281bf99109c4b9083f55a301509e87de591.zip
Add zope-annotations, a generic way to add information to arbitrary Zope objects.
It is used by Silva Metadata to store metadata. WWW: http://www.zope.org/Members/infrae/Annotations PR: ports/60754 Submitted by: Tim Middleton <x@vex.net>
Notes
Notes: svn path=/head/; revision=97111
Diffstat (limited to 'www/zope-annotations')
-rw-r--r--www/zope-annotations/Makefile50
-rw-r--r--www/zope-annotations/distinfo1
-rw-r--r--www/zope-annotations/pkg-descr4
-rw-r--r--www/zope-annotations/pkg-message6
-rw-r--r--www/zope-annotations/pkg-plist27
5 files changed, 88 insertions, 0 deletions
diff --git a/www/zope-annotations/Makefile b/www/zope-annotations/Makefile
new file mode 100644
index 000000000000..ea13a3644364
--- /dev/null
+++ b/www/zope-annotations/Makefile
@@ -0,0 +1,50 @@
+# New ports collection makefile for: Annotations
+# Date created: 30 Dec 2003
+# Whom: Tim Middleton
+#
+# $FreeBSD$
+#
+
+PORTNAME= annotations
+PORTVERSION= 0.4.3
+CATEGORIES= www zope
+MASTER_SITES= http://zope.org/Members/infrae/Annotations/Annotations-${PORTVERSION}/
+PKGNAMEPREFIX= zope-
+DISTNAME= Annotations-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= x@Vex.Net
+COMMENT= A generic way to add information to arbitrary Zope objects
+
+USE_PYTHON= yes
+USE_ZOPE= yes
+DIST_SUBDIR= zope
+
+ZOPEPRODUCTNAME=Annotations
+
+# yes, some of us are running zope on python 2.3
+#PYTHON_VERSION= python2.3
+
+# You can change this in the environment if you like.
+#SZOPEBASEDIR?= www/Zope
+
+PLIST_SUB= ZOPEBASEDIR=${SZOPEBASEDIR}
+WRKSRC= ${WRKDIR}/${ZOPEPRODUCTNAME}
+CPIO= cpio --quiet -pdum -R
+
+do-build:
+ @${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}
+
+do-install:
+ @ ${CHMOD} -R og+rX ${WRKSRC}/
+ @ ${MKDIR} ${ZOPEBASEDIR}/${ZOPEPRODUCTDIR}/${ZOPEPRODUCTNAME}
+ @ cd ${WRKSRC} && ${FIND} . \
+ | ${CPIO} ${BINOWN}:${BINGRP} \
+ ${ZOPEBASEDIR}/${ZOPEPRODUCTDIR}/${ZOPEPRODUCTNAME}
+
+post-install:
+.if !defined(BATCH)
+ @${CAT} ${PKGMESSAGE}
+.endif
+
+.include <bsd.port.mk>
diff --git a/www/zope-annotations/distinfo b/www/zope-annotations/distinfo
new file mode 100644
index 000000000000..859ac84fa750
--- /dev/null
+++ b/www/zope-annotations/distinfo
@@ -0,0 +1 @@
+MD5 (zope/Annotations-0.4.3.tgz) = 4970b498ad761e8c0c3ebc54214eb732
diff --git a/www/zope-annotations/pkg-descr b/www/zope-annotations/pkg-descr
new file mode 100644
index 000000000000..6e9ae7ebb21a
--- /dev/null
+++ b/www/zope-annotations/pkg-descr
@@ -0,0 +1,4 @@
+Annotations is a generic way to add information to arbitrary Zope objects.
+It is used by Silva Metadata to store metadata.
+
+WWW: http://www.zope.org/Members/infrae/Annotations
diff --git a/www/zope-annotations/pkg-message b/www/zope-annotations/pkg-message
new file mode 100644
index 000000000000..a87d08747443
--- /dev/null
+++ b/www/zope-annotations/pkg-message
@@ -0,0 +1,6 @@
+To complete the installation of Annotations:
+
+ - Restart Zope. This may be done from the Zope Control Panel.
+
+ - Verify that the Annotations product is loaded properly by
+ examining them in Control_Panel/Products.
diff --git a/www/zope-annotations/pkg-plist b/www/zope-annotations/pkg-plist
new file mode 100644
index 000000000000..8a0f069fdcd5
--- /dev/null
+++ b/www/zope-annotations/pkg-plist
@@ -0,0 +1,27 @@
+%%ZOPEBASEDIR%%/lib/python/Products/Annotations/AnnotationTool.py
+%%ZOPEBASEDIR%%/lib/python/Products/Annotations/AnnotationTool.pyc
+%%ZOPEBASEDIR%%/lib/python/Products/Annotations/CREDITS.txt
+%%ZOPEBASEDIR%%/lib/python/Products/Annotations/Compatibility.py
+%%ZOPEBASEDIR%%/lib/python/Products/Annotations/Compatibility.pyc
+%%ZOPEBASEDIR%%/lib/python/Products/Annotations/Configuration.py
+%%ZOPEBASEDIR%%/lib/python/Products/Annotations/Configuration.pyc
+%%ZOPEBASEDIR%%/lib/python/Products/Annotations/Extensions/Install.py
+%%ZOPEBASEDIR%%/lib/python/Products/Annotations/Extensions/Install.pyc
+%%ZOPEBASEDIR%%/lib/python/Products/Annotations/Extensions/SilvaInstall.py
+%%ZOPEBASEDIR%%/lib/python/Products/Annotations/Extensions/SilvaInstall.pyc
+%%ZOPEBASEDIR%%/lib/python/Products/Annotations/Extensions/__init__.py
+%%ZOPEBASEDIR%%/lib/python/Products/Annotations/Extensions/__init__.pyc
+%%ZOPEBASEDIR%%/lib/python/Products/Annotations/HISTORY.txt
+%%ZOPEBASEDIR%%/lib/python/Products/Annotations/INSTALL.txt
+%%ZOPEBASEDIR%%/lib/python/Products/Annotations/LICENSE.txt
+%%ZOPEBASEDIR%%/lib/python/Products/Annotations/README.txt
+%%ZOPEBASEDIR%%/lib/python/Products/Annotations/__init__.py
+%%ZOPEBASEDIR%%/lib/python/Products/Annotations/__init__.pyc
+%%ZOPEBASEDIR%%/lib/python/Products/Annotations/helpers.py
+%%ZOPEBASEDIR%%/lib/python/Products/Annotations/helpers.pyc
+%%ZOPEBASEDIR%%/lib/python/Products/Annotations/homepage.html
+%%ZOPEBASEDIR%%/lib/python/Products/Annotations/version.txt
+%%ZOPEBASEDIR%%/lib/python/Products/Annotations/www/annotations.png
+@dirrm %%ZOPEBASEDIR%%/lib/python/Products/Annotations/Extensions
+@dirrm %%ZOPEBASEDIR%%/lib/python/Products/Annotations/www
+@dirrm %%ZOPEBASEDIR%%/lib/python/Products/Annotations/