aboutsummaryrefslogtreecommitdiff
path: root/www/zope-proxyindex
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-01-02 21:35:48 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-01-02 21:35:48 +0000
commit388d2443af89085fd7d5e7a00eff312ef1538386 (patch)
tree07cda81403cf1c75462e11e138bc4b6e6c7dbb4b /www/zope-proxyindex
parent12126dd0d7e9469e27608e79966f9272aa1786ab (diff)
downloadports-388d2443af89085fd7d5e7a00eff312ef1538386.tar.gz
ports-388d2443af89085fd7d5e7a00eff312ef1538386.zip
Add zope-proxyindex, a plugin catalog index. It uses a TALES expression instead
of an attribute lookup/call to retrieve the value to index from an object. The value retrieved can then be indexed by any available plugin index. WWW: http://www.zope.org/Members/infrae/ProxyIndex PR: ports/60755 Submitted by: Tim Middleton <x@vex.net>
Notes
Notes: svn path=/head/; revision=97115
Diffstat (limited to 'www/zope-proxyindex')
-rw-r--r--www/zope-proxyindex/Makefile50
-rw-r--r--www/zope-proxyindex/distinfo1
-rw-r--r--www/zope-proxyindex/pkg-descr5
-rw-r--r--www/zope-proxyindex/pkg-message6
-rw-r--r--www/zope-proxyindex/pkg-plist24
5 files changed, 86 insertions, 0 deletions
diff --git a/www/zope-proxyindex/Makefile b/www/zope-proxyindex/Makefile
new file mode 100644
index 000000000000..22f6242a1de1
--- /dev/null
+++ b/www/zope-proxyindex/Makefile
@@ -0,0 +1,50 @@
+# New ports collection makefile for: ProxyIndex
+# Date created: 30 Dec 2003
+# Whom: Tim Middleton
+#
+# $FreeBSD$
+#
+
+PORTNAME= proxyindex
+PORTVERSION= 1.1.2
+CATEGORIES= www zope
+MASTER_SITES= http://zope.org/Members/infrae/ProxyIndex/ProxyIndex-${PORTVERSION}/
+PKGNAMEPREFIX= zope-
+DISTNAME= ProxyIndex-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= x@Vex.Net
+COMMENT= Plugin catalog index using TALES instead attribute lookup/call
+
+USE_PYTHON= yes
+USE_ZOPE= yes
+DIST_SUBDIR= zope
+
+ZOPEPRODUCTNAME=ProxyIndex
+
+# yes, some of us are running zope on python 2.3
+#PYTHON_VERSION= python2.3
+
+# You can change this in the environment if you like.
+#SZOPEBASEDIR?= www/Zope
+
+PLIST_SUB= ZOPEBASEDIR=${SZOPEBASEDIR}
+WRKSRC= ${WRKDIR}/${ZOPEPRODUCTNAME}
+CPIO= cpio --quiet -pdum -R
+
+do-build:
+ @${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}
+
+do-install:
+ @ ${CHMOD} -R og+rX ${WRKSRC}/
+ @ ${MKDIR} ${ZOPEBASEDIR}/${ZOPEPRODUCTDIR}/${ZOPEPRODUCTNAME}
+ @ cd ${WRKSRC} && ${FIND} . \
+ | ${CPIO} ${BINOWN}:${BINGRP} \
+ ${ZOPEBASEDIR}/${ZOPEPRODUCTDIR}/${ZOPEPRODUCTNAME}
+
+post-install:
+.if !defined(BATCH)
+ @${CAT} ${PKGMESSAGE}
+.endif
+
+.include <bsd.port.mk>
diff --git a/www/zope-proxyindex/distinfo b/www/zope-proxyindex/distinfo
new file mode 100644
index 000000000000..2bbe53b3b152
--- /dev/null
+++ b/www/zope-proxyindex/distinfo
@@ -0,0 +1 @@
+MD5 (zope/ProxyIndex-1.1.2.tgz) = ca2ff3ce5ccea5b09d28201827b618f9
diff --git a/www/zope-proxyindex/pkg-descr b/www/zope-proxyindex/pkg-descr
new file mode 100644
index 000000000000..46d07eae172f
--- /dev/null
+++ b/www/zope-proxyindex/pkg-descr
@@ -0,0 +1,5 @@
+ProxyIndex is a plugin catalog index. It uses a TALES expression instead
+of an attribute lookup/call to retrieve the value to index from an object.
+The value retrieved can then be indexed by any available plugin index.
+
+WWW: http://www.zope.org/Members/infrae/ProxyIndex
diff --git a/www/zope-proxyindex/pkg-message b/www/zope-proxyindex/pkg-message
new file mode 100644
index 000000000000..cff42a83f4a7
--- /dev/null
+++ b/www/zope-proxyindex/pkg-message
@@ -0,0 +1,6 @@
+To complete the installation of ProxyIndex:
+
+ - Restart Zope. This may be done from the Zope Control Panel.
+
+ - Verify that the ProxyIndex product is loaded properly by
+ examining them in Control_Panel/Products.
diff --git a/www/zope-proxyindex/pkg-plist b/www/zope-proxyindex/pkg-plist
new file mode 100644
index 000000000000..1437b14d27b3
--- /dev/null
+++ b/www/zope-proxyindex/pkg-plist
@@ -0,0 +1,24 @@
+%%ZOPEBASEDIR%%/lib/python/Products/ProxyIndex/CREDITS.txt
+%%ZOPEBASEDIR%%/lib/python/Products/ProxyIndex/Expression.py
+%%ZOPEBASEDIR%%/lib/python/Products/ProxyIndex/Expression.pyc
+%%ZOPEBASEDIR%%/lib/python/Products/ProxyIndex/HISTORY.txt
+%%ZOPEBASEDIR%%/lib/python/Products/ProxyIndex/INSTALL.txt
+%%ZOPEBASEDIR%%/lib/python/Products/ProxyIndex/LICENSE.txt
+%%ZOPEBASEDIR%%/lib/python/Products/ProxyIndex/ProxyIndex.py
+%%ZOPEBASEDIR%%/lib/python/Products/ProxyIndex/ProxyIndex.pyc
+%%ZOPEBASEDIR%%/lib/python/Products/ProxyIndex/README.txt
+%%ZOPEBASEDIR%%/lib/python/Products/ProxyIndex/__init__.py
+%%ZOPEBASEDIR%%/lib/python/Products/ProxyIndex/__init__.pyc
+%%ZOPEBASEDIR%%/lib/python/Products/ProxyIndex/homepage.html
+%%ZOPEBASEDIR%%/lib/python/Products/ProxyIndex/tests/__init__.py
+%%ZOPEBASEDIR%%/lib/python/Products/ProxyIndex/tests/__init__.pyc
+%%ZOPEBASEDIR%%/lib/python/Products/ProxyIndex/tests/testProxyIndex.py
+%%ZOPEBASEDIR%%/lib/python/Products/ProxyIndex/tests/testProxyIndex.pyc
+%%ZOPEBASEDIR%%/lib/python/Products/ProxyIndex/ui/ProxyIndexAddForm.dtml
+%%ZOPEBASEDIR%%/lib/python/Products/ProxyIndex/ui/ProxyIndexView.dtml
+%%ZOPEBASEDIR%%/lib/python/Products/ProxyIndex/version.txt
+%%ZOPEBASEDIR%%/lib/python/Products/ProxyIndex/www/index.gif
+@dirrm %%ZOPEBASEDIR%%/lib/python/Products/ProxyIndex/www
+@dirrm %%ZOPEBASEDIR%%/lib/python/Products/ProxyIndex/ui
+@dirrm %%ZOPEBASEDIR%%/lib/python/Products/ProxyIndex/tests
+@dirrm %%ZOPEBASEDIR%%/lib/python/Products/ProxyIndex/