aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorDirk Froemberg <dirk@FreeBSD.org>2001-06-25 21:06:10 +0000
committerDirk Froemberg <dirk@FreeBSD.org>2001-06-25 21:06:10 +0000
commit0801433ca01d7f1fa97454046c538f98bb6b0517 (patch)
treee8761d37de03fd4bb87e5c1e78c38f94cbd4dccd /www
parent881ede7395e81eb7e5276a4c79dc39fba77e660a (diff)
downloadports-0801433ca01d7f1fa97454046c538f98bb6b0517.tar.gz
ports-0801433ca01d7f1fa97454046c538f98bb6b0517.zip
ming support was included in php-4.0.6.
Notes
Notes: svn path=/head/; revision=44427
Diffstat (limited to 'www')
-rw-r--r--www/mod_php4/Makefile2
-rw-r--r--www/mod_php4/files/ming-config-m438
-rw-r--r--www/mod_php4/files/patch-aa11
-rw-r--r--www/mod_php4/scripts/configure.php20
-rw-r--r--www/mod_php5/Makefile2
-rw-r--r--www/mod_php5/files/ming-config-m438
-rw-r--r--www/mod_php5/files/patch-aa11
-rw-r--r--www/mod_php5/scripts/configure.php20
8 files changed, 28 insertions, 114 deletions
diff --git a/www/mod_php4/Makefile b/www/mod_php4/Makefile
index 523d4a7fa3ca..2d88e295eaf7 100644
--- a/www/mod_php4/Makefile
+++ b/www/mod_php4/Makefile
@@ -7,7 +7,7 @@
PORTNAME?= mod_php4
PORTVERSION= 4.0.6
-PORTREVISION?= 2
+PORTREVISION?= 3
CATEGORIES?= www
MASTER_SITES= http://us.php.net/${PHP_DISTDIR}/ \
http://php.he.net/${PHP_DISTDIR}/ \
diff --git a/www/mod_php4/files/ming-config-m4 b/www/mod_php4/files/ming-config-m4
deleted file mode 100644
index 8228fe54805f..000000000000
--- a/www/mod_php4/files/ming-config-m4
+++ /dev/null
@@ -1,38 +0,0 @@
-dnl $Id: config.m4,v 1.2 2001/02/08 21:41:29 opaque_ndst Exp $
-dnl config.m4 for extension libming
-dnl don't forget to call PHP_EXTENSION(ming)
-dnl This file is a modified version of config.m4
-dnl in php4/ext/mcrypt
-
-PHP_ARG_WITH(ming, for ming support,
-[ --with-ming[=DIR] Include ming support])
-
-if test "$PHP_MING" != "no"; then
- for i in /usr/lib /usr/local/ /usr/local/lib /usr $PHP_MING $PHP_MING/lib; do
- if test -r $i/libming.so; then
- MING_LIB_DIR=$i
- fi
- done
-
- if test -z "$MING_LIB_DIR"; then
- AC_MSG_ERROR(Please reinstall libming.so - I cannot find libming.so)
- fi
-
- for i in /usr/include /usr/local/include $PHP_MING $PHP_MING/include $PHP_MING/include/ming; do
- if test -r $i/ming.h; then
- MING_INC_DIR=$i
- fi
- done
-
- if test -z "$MING_INC_DIR"; then
- AC_MSG_ERROR(Please reinstall ming.h - I cannot find ming.h)
- fi
-
- AC_ADD_INCLUDE($MING_INC_DIR)
-
- AC_ADD_LIBRARY_WITH_PATH(ming, $MING_LIB_DIR, MING_SHARED_LIBADD)
- PHP_SUBST(MING_SHARED_LIBADD)
- AC_DEFINE(HAVE_MING,1,[ ])
-
- PHP_EXTENSION(ming, $ext_shared)
-fi
diff --git a/www/mod_php4/files/patch-aa b/www/mod_php4/files/patch-aa
new file mode 100644
index 000000000000..572d063ef340
--- /dev/null
+++ b/www/mod_php4/files/patch-aa
@@ -0,0 +1,11 @@
+--- ext/ming/php_ming.h.orig Mon May 28 02:09:57 2001
++++ ext/ming/php_ming.h Mon Jun 25 22:58:57 2001
+@@ -28,7 +28,7 @@
+
+ #if HAVE_MING
+
+-#include "ming.h"
++#include "ming/ming.h"
+
+ extern zend_module_entry ming_module_entry;
+ #define ming_module_ptr &ming_module_entry
diff --git a/www/mod_php4/scripts/configure.php b/www/mod_php4/scripts/configure.php
index 96e34687d33b..6d4450488241 100644
--- a/www/mod_php4/scripts/configure.php
+++ b/www/mod_php4/scripts/configure.php
@@ -241,24 +241,8 @@ EOF
echo "CONFIGURE_ARGS+=--with-hyperwave=yes"
;;
\"ming\")
- ${CAT} << EOF
-CONFIGURE_ARGS+=--with-ming=\${PREFIX}
-BUILD_DEPENDS+= /nonexistent:\${PORTSDIR}/graphics/ming:extract
-BUILD_DEPENDS+= automake:\${PORTSDIR}/devel/automake
-BUILD_DEPENDS+= autoconf:\${PORTSDIR}/devel/autoconf
-LIB_DEPENDS+= ming.2:\${PORTSDIR}/graphics/ming
-POSTEXTRACT+= post-extract-ming
-
-post-extract-ming:
- [ -d \`cd \${PORTSDIR}/graphics/ming && \${MAKE} -V WRKSRC\`/../php_ext ] && \\
- (cd \${WRKSRC}; \\
- \${MKDIR} \${WRKSRC}/ext/ming; \\
- \${CP} \`cd \${PORTSDIR}/graphics/ming && \${MAKE} -V WRKSRC\`/../php_ext/* \${WRKSRC}/ext/ming; \\
- \${CP} \${FILESDIR}/ming-config-m4 \${WRKSRC}/ext/ming/config.m4; \\
- \${RM} configure; \\
- ./buildconf)
-
-EOF
+ echo "LIB_DEPENDS+= ming.2:\${PORTSDIR}/graphics/ming"
+ echo "CONFIGURE_ARGS+=--with-ming=\${PREFIX}"
;;
\"sockets\")
echo "CONFIGURE_ARGS+=--enable-sockets"
diff --git a/www/mod_php5/Makefile b/www/mod_php5/Makefile
index 523d4a7fa3ca..2d88e295eaf7 100644
--- a/www/mod_php5/Makefile
+++ b/www/mod_php5/Makefile
@@ -7,7 +7,7 @@
PORTNAME?= mod_php4
PORTVERSION= 4.0.6
-PORTREVISION?= 2
+PORTREVISION?= 3
CATEGORIES?= www
MASTER_SITES= http://us.php.net/${PHP_DISTDIR}/ \
http://php.he.net/${PHP_DISTDIR}/ \
diff --git a/www/mod_php5/files/ming-config-m4 b/www/mod_php5/files/ming-config-m4
deleted file mode 100644
index 8228fe54805f..000000000000
--- a/www/mod_php5/files/ming-config-m4
+++ /dev/null
@@ -1,38 +0,0 @@
-dnl $Id: config.m4,v 1.2 2001/02/08 21:41:29 opaque_ndst Exp $
-dnl config.m4 for extension libming
-dnl don't forget to call PHP_EXTENSION(ming)
-dnl This file is a modified version of config.m4
-dnl in php4/ext/mcrypt
-
-PHP_ARG_WITH(ming, for ming support,
-[ --with-ming[=DIR] Include ming support])
-
-if test "$PHP_MING" != "no"; then
- for i in /usr/lib /usr/local/ /usr/local/lib /usr $PHP_MING $PHP_MING/lib; do
- if test -r $i/libming.so; then
- MING_LIB_DIR=$i
- fi
- done
-
- if test -z "$MING_LIB_DIR"; then
- AC_MSG_ERROR(Please reinstall libming.so - I cannot find libming.so)
- fi
-
- for i in /usr/include /usr/local/include $PHP_MING $PHP_MING/include $PHP_MING/include/ming; do
- if test -r $i/ming.h; then
- MING_INC_DIR=$i
- fi
- done
-
- if test -z "$MING_INC_DIR"; then
- AC_MSG_ERROR(Please reinstall ming.h - I cannot find ming.h)
- fi
-
- AC_ADD_INCLUDE($MING_INC_DIR)
-
- AC_ADD_LIBRARY_WITH_PATH(ming, $MING_LIB_DIR, MING_SHARED_LIBADD)
- PHP_SUBST(MING_SHARED_LIBADD)
- AC_DEFINE(HAVE_MING,1,[ ])
-
- PHP_EXTENSION(ming, $ext_shared)
-fi
diff --git a/www/mod_php5/files/patch-aa b/www/mod_php5/files/patch-aa
new file mode 100644
index 000000000000..572d063ef340
--- /dev/null
+++ b/www/mod_php5/files/patch-aa
@@ -0,0 +1,11 @@
+--- ext/ming/php_ming.h.orig Mon May 28 02:09:57 2001
++++ ext/ming/php_ming.h Mon Jun 25 22:58:57 2001
+@@ -28,7 +28,7 @@
+
+ #if HAVE_MING
+
+-#include "ming.h"
++#include "ming/ming.h"
+
+ extern zend_module_entry ming_module_entry;
+ #define ming_module_ptr &ming_module_entry
diff --git a/www/mod_php5/scripts/configure.php b/www/mod_php5/scripts/configure.php
index 96e34687d33b..6d4450488241 100644
--- a/www/mod_php5/scripts/configure.php
+++ b/www/mod_php5/scripts/configure.php
@@ -241,24 +241,8 @@ EOF
echo "CONFIGURE_ARGS+=--with-hyperwave=yes"
;;
\"ming\")
- ${CAT} << EOF
-CONFIGURE_ARGS+=--with-ming=\${PREFIX}
-BUILD_DEPENDS+= /nonexistent:\${PORTSDIR}/graphics/ming:extract
-BUILD_DEPENDS+= automake:\${PORTSDIR}/devel/automake
-BUILD_DEPENDS+= autoconf:\${PORTSDIR}/devel/autoconf
-LIB_DEPENDS+= ming.2:\${PORTSDIR}/graphics/ming
-POSTEXTRACT+= post-extract-ming
-
-post-extract-ming:
- [ -d \`cd \${PORTSDIR}/graphics/ming && \${MAKE} -V WRKSRC\`/../php_ext ] && \\
- (cd \${WRKSRC}; \\
- \${MKDIR} \${WRKSRC}/ext/ming; \\
- \${CP} \`cd \${PORTSDIR}/graphics/ming && \${MAKE} -V WRKSRC\`/../php_ext/* \${WRKSRC}/ext/ming; \\
- \${CP} \${FILESDIR}/ming-config-m4 \${WRKSRC}/ext/ming/config.m4; \\
- \${RM} configure; \\
- ./buildconf)
-
-EOF
+ echo "LIB_DEPENDS+= ming.2:\${PORTSDIR}/graphics/ming"
+ echo "CONFIGURE_ARGS+=--with-ming=\${PREFIX}"
;;
\"sockets\")
echo "CONFIGURE_ARGS+=--enable-sockets"