aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2013-07-31 06:54:09 +0000
committerAndrej Zverev <az@FreeBSD.org>2013-07-31 06:54:09 +0000
commit0c32f397115d6a7e639ed1f8b4228848bd5cc96c (patch)
treece66d6984b8e2580d19a3e478f618b13623e3080 /www
parentc37aa810ab6b2dec5c29293ea60ad8f84d8effda (diff)
downloadports-0c32f397115d6a7e639ed1f8b4228848bd5cc96c.tar.gz
ports-0c32f397115d6a7e639ed1f8b4228848bd5cc96c.zip
- Convert to new Uses/perl5.mk framework
- Resolve issues with implicit lang/perl in extract and patch dependencies - Trim Makefile header Reviewed by: bapt@ (exp-run) Approved by: bapt@ (portmrg@)
Notes
Notes: svn path=/head/; revision=324007
Diffstat (limited to 'www')
-rw-r--r--www/p5-AMF-Perl/Makefile3
-rw-r--r--www/p5-Apache-Admin-Config/Makefile3
-rw-r--r--www/p5-CGI-SpeedyCGI/Makefile3
-rw-r--r--www/p5-Catalyst-Model-DBIC-Schema/Makefile3
-rw-r--r--www/p5-Catalyst-Plugin-Cache/Makefile3
-rw-r--r--www/p5-Catalyst-Plugin-Session-State-Cookie/Makefile3
-rw-r--r--www/p5-Catalyst-Plugin-Session/Makefile3
-rw-r--r--www/p5-HTTP-MHTTP/Makefile9
-rw-r--r--www/p5-Maypole-Authentication-UserSessionCookie/Makefile8
-rw-r--r--www/p5-Maypole-Component/Makefile8
10 files changed, 23 insertions, 23 deletions
diff --git a/www/p5-AMF-Perl/Makefile b/www/p5-AMF-Perl/Makefile
index c6dddd1f9206..9434130dbeec 100644
--- a/www/p5-AMF-Perl/Makefile
+++ b/www/p5-AMF-Perl/Makefile
@@ -15,7 +15,8 @@ COMMENT= Flash Remoting in Perl
RUN_DEPENDS= p5-Exception-Class>=0:${PORTSDIR}/devel/p5-Exception-Class \
p5-DBI>=0:${PORTSDIR}/databases/p5-DBI
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure patch
NO_MANCOMPRESS= no
MAN3= AMF::Perl.3 AMF::Perl::App::Executive.3 \
diff --git a/www/p5-Apache-Admin-Config/Makefile b/www/p5-Apache-Admin-Config/Makefile
index 499ceb261a54..8703cc5dfae2 100644
--- a/www/p5-Apache-Admin-Config/Makefile
+++ b/www/p5-Apache-Admin-Config/Makefile
@@ -10,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Perl module to manipulate Apache configuration files
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure patch
MAN3= Apache::Admin::Config.3
diff --git a/www/p5-CGI-SpeedyCGI/Makefile b/www/p5-CGI-SpeedyCGI/Makefile
index fced4ce3308d..a16481d19090 100644
--- a/www/p5-CGI-SpeedyCGI/Makefile
+++ b/www/p5-CGI-SpeedyCGI/Makefile
@@ -12,7 +12,8 @@ MAINTAINER= lth@FreeBSD.org
COMMENT= Speed up perl CGI scripts by running them persistently
MAKE_JOBS_UNSAFE= yes
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure patch
OPTIONS_DEFINE= APACHE
OPTIONS_DEFAULT=APACHE
diff --git a/www/p5-Catalyst-Model-DBIC-Schema/Makefile b/www/p5-Catalyst-Model-DBIC-Schema/Makefile
index a99f1a147f94..0210f4144dbc 100644
--- a/www/p5-Catalyst-Model-DBIC-Schema/Makefile
+++ b/www/p5-Catalyst-Model-DBIC-Schema/Makefile
@@ -33,7 +33,8 @@ TEST_DEPENDS= p5-DBD-SQLite>=0:${PORTSDIR}/databases/p5-DBD-SQLite \
p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception \
p5-Test-Requires>=0:${PORTSDIR}/devel/p5-Test-Requires
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure extract
MAN3= Catalyst::Helper::Model::DBIC::Schema.3 \
Catalyst::Model::DBIC::Schema.3 \
diff --git a/www/p5-Catalyst-Plugin-Cache/Makefile b/www/p5-Catalyst-Plugin-Cache/Makefile
index 8ac8a3a63bad..13f4bc99ec59 100644
--- a/www/p5-Catalyst-Plugin-Cache/Makefile
+++ b/www/p5-Catalyst-Plugin-Cache/Makefile
@@ -19,7 +19,8 @@ TEST_DEPENDS= p5-Test-Deep>=0:${PORTSDIR}/devel/p5-Test-Deep \
p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception \
p5-Test-WWW-Mechanize-Catalyst>=0:${PORTSDIR}/devel/p5-Test-WWW-Mechanize-Catalyst
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure patch
MAN3= Catalyst::Plugin::Cache.3 \
Catalyst::Plugin::Cache::Backend.3 \
diff --git a/www/p5-Catalyst-Plugin-Session-State-Cookie/Makefile b/www/p5-Catalyst-Plugin-Session-State-Cookie/Makefile
index aa6d0c993f34..ee93640dcb07 100644
--- a/www/p5-Catalyst-Plugin-Session-State-Cookie/Makefile
+++ b/www/p5-Catalyst-Plugin-Session-State-Cookie/Makefile
@@ -18,7 +18,8 @@ RUN_DEPENDS= \
p5-namespace-autoclean>0:${PORTSDIR}/devel/p5-namespace-autoclean
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure extract
MAN3= Catalyst::Plugin::Session::State::Cookie.3
diff --git a/www/p5-Catalyst-Plugin-Session/Makefile b/www/p5-Catalyst-Plugin-Session/Makefile
index 1b5d4fd9f332..8cde94077998 100644
--- a/www/p5-Catalyst-Plugin-Session/Makefile
+++ b/www/p5-Catalyst-Plugin-Session/Makefile
@@ -24,7 +24,8 @@ TEST_DEPENDS= p5-Test-Deep>=0:${PORTSDIR}/devel/p5-Test-Deep \
p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception \
p5-Test-WWW-Mechanize-PSGI>=0:${PORTSDIR}/devel/p5-Test-WWW-Mechanize-PSGI
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure extract
MAN3= Catalyst::Plugin::Session.3 \
Catalyst::Plugin::Session::State.3 \
diff --git a/www/p5-HTTP-MHTTP/Makefile b/www/p5-HTTP-MHTTP/Makefile
index e3168fb5dcc3..8dc630cb9f64 100644
--- a/www/p5-HTTP-MHTTP/Makefile
+++ b/www/p5-HTTP-MHTTP/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: HTTP-MHTTP
-# Date created: 22 January 2004
-# Whom: Sergey Skvortsov <skv@protey.ru>
-#
+# Created by: Sergey Skvortsov <skv@protey.ru>
# $FreeBSD$
-#
PORTNAME= HTTP-MHTTP
PORTVERSION= 0.15
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Low level access to the HTTP protocol
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure patch
USE_OPENSSL= yes
CONFIGURE_ENV= GOTSSL=yes
CONFIGURE_ARGS= --default
diff --git a/www/p5-Maypole-Authentication-UserSessionCookie/Makefile b/www/p5-Maypole-Authentication-UserSessionCookie/Makefile
index 779774cfe8d0..f06982008c92 100644
--- a/www/p5-Maypole-Authentication-UserSessionCookie/Makefile
+++ b/www/p5-Maypole-Authentication-UserSessionCookie/Makefile
@@ -1,7 +1,4 @@
-# New ports collection makefile for: p5-Maypole-Authentication-UserSessionCookie
-# Date created: Aug 21 2004
-# Whom: Marc G. Fournier
-#
+# Created by: Marc G. Fournier
# $FreeBSD$
PORTNAME= Maypole-Authentication-UserSessionCookie
@@ -15,7 +12,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Track sessions and, optionally, users
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure patch
MAN3= Maypole::Authentication::UserSessionCookie.3
diff --git a/www/p5-Maypole-Component/Makefile b/www/p5-Maypole-Component/Makefile
index 6075cf70ba96..d9753d83d50e 100644
--- a/www/p5-Maypole-Component/Makefile
+++ b/www/p5-Maypole-Component/Makefile
@@ -1,7 +1,4 @@
-# New ports collection makefile for: p5-Maypole-Component
-# Date created: Aug 26 2004
-# Whom: Marc G. Fournier
-#
+# Created by: Marc G. Fournier
# $FreeBSD$
PORTNAME= Maypole-Component
@@ -14,7 +11,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Run Maypole sub-requests as components
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure patch
MAN3= Maypole::Component.3