aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1999-05-03 03:10:28 +0000
committerSteve Price <steve@FreeBSD.org>1999-05-03 03:10:28 +0000
commit11ee396bcfde3734dc2166e367173bd7c471239b (patch)
treed8a0d81cc149827dbc8b2a2bc567294b821c967d /www
parentf1092a8b24e55958e7b38ae147748e3f3565a514 (diff)
downloadports-11ee396bcfde3734dc2166e367173bd7c471239b.tar.gz
ports-11ee396bcfde3734dc2166e367173bd7c471239b.zip
Initial import of evg version 1.0.1.
Create index pages in HTML for photo galleries. PR: 11214 Submitted by: Dima Sivachenko <dima@chg.ru>
Notes
Notes: svn path=/head/; revision=18383
Diffstat (limited to 'www')
-rw-r--r--www/evg/Makefile35
-rw-r--r--www/evg/distinfo1
-rw-r--r--www/evg/files/patch-aa19
-rw-r--r--www/evg/pkg-comment1
-rw-r--r--www/evg/pkg-descr9
-rw-r--r--www/evg/pkg-plist2
6 files changed, 67 insertions, 0 deletions
diff --git a/www/evg/Makefile b/www/evg/Makefile
new file mode 100644
index 000000000000..41602c84540f
--- /dev/null
+++ b/www/evg/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: evg
+# Version required: 1.0.1
+# Date created: 19 April 1999
+# Whom: Dima Sivachenko <dima@chg.ru>
+#
+# $Id $
+#
+
+DISTNAME= evg-1.01
+PKGNAME= evg-1.0.1
+CATEGORIES= www
+MASTER_SITES= ftp://ftp.uni-klu.ac.at/pub/projects/evg/ \
+ http://www.chg.ru/~dima/
+
+MAINTAINER= dima@Chg.RU
+
+RUN_DEPENDS= python:${PORTSDIR}/lang/python
+RUN_DEPENDS+= convert:${PORTSDIR}/graphics/ImageMagick
+RUN_DEPENDS+= xv:${PORTSDIR}/graphics/xv
+
+NO_BUILD= yes
+
+post-patch:
+ @ ${MV} ${WRKSRC}/evg.py ${WRKSRC}/evg.py.sed
+ @ ${SED} -e 's%!!PREFIX!!%${PREFIX}%' < ${WRKSRC}/evg.py.sed \
+ > ${WRKSRC}/evg.py.sed1
+ @ ${SED} -e 's%!!XPREF!!%${X11BASE}%' < ${WRKSRC}/evg.py.sed1 \
+ > ${WRKSRC}/evg.py
+
+do-install:
+ @ ${MKDIR} ${PREFIX}/lib/python1.5/site-packages
+ @ ${INSTALL_SCRIPT} ${WRKSRC}/eclipthtml.py ${PREFIX}/lib/python1.5/site-packages
+ @ ${INSTALL_SCRIPT} ${WRKSRC}/evg.py ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/www/evg/distinfo b/www/evg/distinfo
new file mode 100644
index 000000000000..bc6de8e58dc1
--- /dev/null
+++ b/www/evg/distinfo
@@ -0,0 +1 @@
+MD5 (evg-1.01.tar.gz) = e56a7557bccfe008bd4d5d45b2abb7a6
diff --git a/www/evg/files/patch-aa b/www/evg/files/patch-aa
new file mode 100644
index 000000000000..2db7bf056ecb
--- /dev/null
+++ b/www/evg/files/patch-aa
@@ -0,0 +1,19 @@
+--- evg.py.orig Sun Apr 18 18:55:42 1999
++++ evg.py Sun Apr 18 18:57:00 1999
+@@ -1,4 +1,4 @@
+-#!/usr/local/bin/python
++#!!!PREFIX!!/bin/python
+ # EVG - ECLiPt Virtual Gallery Creator
+ # (c) 1999 by Emanuel Pirker <epirker@edu.uni-klu.ac.at>
+ # Distributed under the GNU GPL.
+@@ -10,8 +10,8 @@
+ # ----------------------------------------------------------------------
+ # Constants
+
+-CONVERTCMD = '/usr/X11R6/bin/convert'
+-VIEWERCMD = '/usr/bin/ee'
++CONVERTCMD = '!!PREFIX!!/bin/convert'
++VIEWERCMD = '!!XPREF!!/bin/xv'
+ THUMBNAILDIR = 'thumbnails'
+ THUMBPERCENT = '20%'
+ SERDBFILE = "serdb"
diff --git a/www/evg/pkg-comment b/www/evg/pkg-comment
new file mode 100644
index 000000000000..48b41b80aa7c
--- /dev/null
+++ b/www/evg/pkg-comment
@@ -0,0 +1 @@
+Create index pages in HTML for photo galleries.
diff --git a/www/evg/pkg-descr b/www/evg/pkg-descr
new file mode 100644
index 000000000000..95e339fb7be2
--- /dev/null
+++ b/www/evg/pkg-descr
@@ -0,0 +1,9 @@
+EVG addresses the needs of people who want to put photo galleries on their web
+pages. Most photo galleries on the Web are rather rude - EVG automatically
+generates nice index pages and hyperlinked per-image-pages. Thumbnails are
+generated automatically, as well as adding or removing images is easy.
+
+http://eclipt.uni-klu.ac.at/projects/evg/
+
+--Dima
+dima@chg.ru
diff --git a/www/evg/pkg-plist b/www/evg/pkg-plist
new file mode 100644
index 000000000000..e4c8c6117b22
--- /dev/null
+++ b/www/evg/pkg-plist
@@ -0,0 +1,2 @@
+bin/evg.py
+lib/python1.5/site-packages/eclipthtml.py