aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2019-09-06 14:53:57 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2019-09-06 14:53:57 +0000
commit17c3511c93654a716771328d7253086a402942b3 (patch)
tree9d30d14e5b9440abe1df5bec769379b10ef5b54c /www
parentde4fa2bd657feea778113365872116f4eb5329cd (diff)
downloadports-17c3511c93654a716771328d7253086a402942b3.tar.gz
ports-17c3511c93654a716771328d7253086a402942b3.zip
www/py-django-dpaste: Update to 3.3.1
Notes
Notes: svn path=/head/; revision=511318
Diffstat (limited to 'www')
-rw-r--r--www/py-django-dpaste/Makefile24
-rw-r--r--www/py-django-dpaste/distinfo6
-rw-r--r--www/py-django-dpaste/files/patch-runtests.py12
-rw-r--r--www/py-django-dpaste/files/patch-setup.py34
4 files changed, 15 insertions, 61 deletions
diff --git a/www/py-django-dpaste/Makefile b/www/py-django-dpaste/Makefile
index 895e677d40e0..92f2ec330cdb 100644
--- a/www/py-django-dpaste/Makefile
+++ b/www/py-django-dpaste/Makefile
@@ -2,32 +2,32 @@
# $FreeBSD$
PORTNAME= dpaste
-PORTVERSION= 2.13
+PORTVERSION= 3.3.1
CATEGORIES= www python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}django-
MAINTAINER= koobs@FreeBSD.org
-COMMENT= Django based pastebin
+COMMENT= Django based pastebin for text and code
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django111>0:www/py-django111@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pygments>=1.6:textproc/py-pygments@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}django22>=1.11:www/py-django22@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pygments>=1.6:textproc/py-pygments@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}dj22-django_csp>=3.3:www/py-dj22-django_csp@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}django-staticinline>=1.0:www/py-django-staticinline@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}jsx-lexer=0.0.7:textproc/py-jsx-lexer@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}docutils>0:textproc/py-docutils@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}misaka>=2.1.0:textproc/py-misaka@${PY_FLAVOR}
-OPTIONS_DEFINE= MIGRATIONS
-
-MIGRATIONS_DESC= Schema and data migration support (via south)
-
-MIGRATIONS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}south>=0.8.2:databases/py-south@${PY_FLAVOR}
-
-USES= python
+USES= python:3.4+
USE_PYTHON= distutils autoplist
NO_ARCH= yes
do-test:
- @cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
+ @cd ${WRKSRC} && ${PYTHON_CMD} runtests.py
.include <bsd.port.mk>
diff --git a/www/py-django-dpaste/distinfo b/www/py-django-dpaste/distinfo
index a411eb1d17d5..ed0d0cde46bf 100644
--- a/www/py-django-dpaste/distinfo
+++ b/www/py-django-dpaste/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1524057868
-SHA256 (dpaste-2.13.tar.gz) = 983271f34e0c62f93f1c6d23a10e12853383d8d2d58bed6648c9244a258636d8
-SIZE (dpaste-2.13.tar.gz) = 131994
+TIMESTAMP = 1567751862
+SHA256 (dpaste-3.3.1.tar.gz) = 398bd5522fbaf7dde93ebaa224e033d0c7e5ecd70d3f32b275d80a978db0196a
+SIZE (dpaste-3.3.1.tar.gz) = 218357
diff --git a/www/py-django-dpaste/files/patch-runtests.py b/www/py-django-dpaste/files/patch-runtests.py
deleted file mode 100644
index e675cbbb404e..000000000000
--- a/www/py-django-dpaste/files/patch-runtests.py
+++ /dev/null
@@ -1,12 +0,0 @@
---- runtests.py.orig 2016-08-15 03:40:49 UTC
-+++ runtests.py
-@@ -63,8 +63,7 @@ def runtests(*test_args):
-
- test_runner = TestRunner(verbosity=1)
- failures = test_runner.run_tests(['dpaste'])
-- if failures:
-- sys.exit(failures)
-+ sys.exit(failures)
-
- if __name__ == '__main__':
- runtests(*sys.argv[1:])
diff --git a/www/py-django-dpaste/files/patch-setup.py b/www/py-django-dpaste/files/patch-setup.py
deleted file mode 100644
index afd0a3900474..000000000000
--- a/www/py-django-dpaste/files/patch-setup.py
+++ /dev/null
@@ -1,34 +0,0 @@
---- setup.py.orig 2016-08-15 03:37:55 UTC
-+++ setup.py
-@@ -4,19 +4,6 @@ from sys import exit
- from setuptools import find_packages, setup
- from setuptools.command.test import test as TestCommand
-
--
--class Tox(TestCommand):
-- def finalize_options(self):
-- TestCommand.finalize_options(self)
-- self.test_args = []
-- self.test_suite = True
--
-- def run_tests(self):
-- #import here, cause outside the eggs aren't loaded
-- import tox
-- errno = tox.cmdline(self.test_args)
-- exit(errno)
--
- long_description = u'\n\n'.join((
- open('README.rst').read(),
- open('CHANGELOG').read()
-@@ -54,10 +41,5 @@ setup(
- 'pygments>=1.6',
- 'requests>=2.0.0',
- ],
-- tests_require=[
-- 'tox>=1.6.1'
-- ],
-- cmdclass={
-- 'test': Tox
-- },
-+ test_suite='runtests.runtests',
- )