aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2016-03-02 22:49:48 +0000
committerJan Beich <jbeich@FreeBSD.org>2016-03-02 22:49:48 +0000
commit182b35fa9c1b22af0bdf370ab7c0c6cde70cc3ad (patch)
treed72c3e282032ffb29975cc904a6f4e4b1270220e /www
parentf424fb7bf7fd2fe8b288cb5d0d50dbba8b46ef1a (diff)
downloadports-182b35fa9c1b22af0bdf370ab7c0c6cde70cc3ad.tar.gz
ports-182b35fa9c1b22af0bdf370ab7c0c6cde70cc3ad.zip
gecko: unify unchanging options into bsd.gecko.mk
PR: 205741 (alternative)
Notes
Notes: svn path=/head/; revision=409979
Diffstat (limited to 'www')
-rw-r--r--www/firefox-esr/Makefile19
-rw-r--r--www/firefox/Makefile19
-rw-r--r--www/libxul/Makefile19
-rw-r--r--www/seamonkey/Makefile12
4 files changed, 3 insertions, 66 deletions
diff --git a/www/firefox-esr/Makefile b/www/firefox-esr/Makefile
index 6b68f810e970..c42d2ea9b508 100644
--- a/www/firefox-esr/Makefile
+++ b/www/firefox-esr/Makefile
@@ -55,26 +55,9 @@ OPTIONS_SINGLE+= TOOLKIT
OPTIONS_SINGLE_TOOLKIT= GTK2 GTK3
.include "${.CURDIR}/../../www/firefox/Makefile.options"
-.include <bsd.port.pre.mk>
WRKSRC:= ${WRKDIR}/mozilla-esr38
-.if ${PORT_OPTIONS:MALSA}
-RUN_DEPENDS+= alsa-lib>=1.0.27.2_1:${PORTSDIR}/audio/alsa-lib
-.endif
-
-.if ! ${PORT_OPTIONS:MBUNDLED_CAIRO}
-BUILD_DEPENDS+= cairo>=1.12.16_1,2:${PORTSDIR}/graphics/cairo
-.endif
-
-.if ${PORT_OPTIONS:MGSTREAMER}
-RUN_DEPENDS+= gstreamer1-libav>=1.2.4_1:${PORTSDIR}/multimedia/gstreamer1-libav
-.endif
-
-.if ${PORT_OPTIONS:MGTK3}
-BUILD_DEPENDS+= gtk3>=3.14.6:${PORTSDIR}/x11-toolkits/gtk30
-.endif
-
post-extract:
@${SED} -e 's|@FIREFOX_ICON@|${FIREFOX_ICON}|' -e 's|@MOZILLA@|${MOZILLA}|' \
-e 's|@MOZILLA_NAME@|${MOZILLA_NAME}|' \
@@ -95,4 +78,4 @@ post-install:
${INSTALL_DATA} ${WRKDIR}/${MOZILLA}.desktop ${STAGEDIR}${PREFIX}/share/applications/
${LN} -sf ${FIREFOX_ICON_SRC} ${STAGEDIR}${PREFIX}/share/pixmaps/${FIREFOX_ICON}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index 16885262d81e..67c731478189 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -55,26 +55,9 @@ OPTIONS_SINGLE+= TOOLKIT
OPTIONS_SINGLE_TOOLKIT= GTK2 GTK3
.include "${.CURDIR}/../../www/firefox/Makefile.options"
-.include <bsd.port.pre.mk>
WRKSRC:= ${WRKDIR}/${PORTNAME}-${DISTVERSION}
-.if ${PORT_OPTIONS:MALSA}
-RUN_DEPENDS+= alsa-lib>=1.0.27.2_1:${PORTSDIR}/audio/alsa-lib
-.endif
-
-.if ! ${PORT_OPTIONS:MBUNDLED_CAIRO}
-BUILD_DEPENDS+= cairo>=1.12.16_1,2:${PORTSDIR}/graphics/cairo
-.endif
-
-.if ${PORT_OPTIONS:MGSTREAMER}
-RUN_DEPENDS+= gstreamer1-libav>=1.2.4_1:${PORTSDIR}/multimedia/gstreamer1-libav
-.endif
-
-.if ${PORT_OPTIONS:MGTK3}
-BUILD_DEPENDS+= gtk3>=3.14.6:${PORTSDIR}/x11-toolkits/gtk30
-.endif
-
post-extract:
@${SED} -e 's|@FIREFOX_ICON@|${FIREFOX_ICON}|' -e 's|@MOZILLA@|${MOZILLA}|' \
-e 's|@MOZILLA_NAME@|${MOZILLA_NAME}|' \
@@ -95,4 +78,4 @@ post-install:
${INSTALL_DATA} ${WRKDIR}/${MOZILLA}.desktop ${STAGEDIR}${PREFIX}/share/applications/
${LN} -sf ${FIREFOX_ICON_SRC} ${STAGEDIR}${PREFIX}/share/pixmaps/${FIREFOX_ICON}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/libxul/Makefile b/www/libxul/Makefile
index 03f2bdcb4f51..fbaabd0c94df 100644
--- a/www/libxul/Makefile
+++ b/www/libxul/Makefile
@@ -55,28 +55,11 @@ OPTIONS_SINGLE+= TOOLKIT
OPTIONS_SINGLE_TOOLKIT= GTK2 GTK3
.include "${.CURDIR}/../../www/firefox/Makefile.options"
-.include <bsd.port.pre.mk>
.if ${USE_MOZILLA:M-nss}
MOZ_PKGCONFIG_FILES+= mozilla-nss
.endif
-.if ${PORT_OPTIONS:MALSA}
-RUN_DEPENDS+= alsa-lib>=1.0.27.2_1:${PORTSDIR}/audio/alsa-lib
-.endif
-
-.if ! ${PORT_OPTIONS:MBUNDLED_CAIRO}
-BUILD_DEPENDS+= cairo>=1.12.16_1,2:${PORTSDIR}/graphics/cairo
-.endif
-
-.if ${PORT_OPTIONS:MGSTREAMER}
-RUN_DEPENDS+= gstreamer1-libav>=1.2.4_1:${PORTSDIR}/multimedia/gstreamer1-libav
-.endif
-
-.if ${PORT_OPTIONS:MGTK3}
-BUILD_DEPENDS+= gtk3>=3.14.6:${PORTSDIR}/x11-toolkits/gtk30
-.endif
-
post-patch:
@${REINPLACE_CMD} -e '/MOZPNG/s/=[0-9]*/=10511/' \
${WRKSRC}/configure.in
@@ -93,4 +76,4 @@ post-build:
s|%%MOZ_LIBDIR%%|${PREFIX}/lib/${MOZILLA}|g" \
${WRKSRC}/xulrunner/installer/*.pc.in || ${TRUE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/seamonkey/Makefile b/www/seamonkey/Makefile
index 1bf44dc2bcab..7cb1ec953c08 100644
--- a/www/seamonkey/Makefile
+++ b/www/seamonkey/Makefile
@@ -76,18 +76,6 @@ MOZSRC:= ${WRKSRC}/mozilla
XPI_LIBDIR= ${PREFIX}/lib/xpi
-.if ${PORT_OPTIONS:MALSA}
-RUN_DEPENDS+= alsa-lib>=1.0.27.2_1:${PORTSDIR}/audio/alsa-lib
-.endif
-
-.if ! ${PORT_OPTIONS:MBUNDLED_CAIRO}
-BUILD_DEPENDS+= cairo>=1.12.16_1,2:${PORTSDIR}/graphics/cairo
-.endif
-
-.if ${PORT_OPTIONS:MGSTREAMER}
-RUN_DEPENDS+= gstreamer1-libav>=1.2.4_1:${PORTSDIR}/multimedia/gstreamer1-libav
-.endif
-
.if ! ${PORT_OPTIONS:MMAILNEWS}
MOZ_OPTIONS+= --disable-ldap --disable-mailnews
.else