aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2014-01-09 21:32:12 +0000
committerGabor Pali <pgj@FreeBSD.org>2014-01-09 21:32:12 +0000
commit1a75cb1d44d0e805336b016a92a4b2d8d564fdda (patch)
tree604f06bea271b71fb7be1993c1c2ba323b4506e1 /www
parentf27ca4d0f1e1df6ff92a7455ddea39730ec30f60 (diff)
downloadports-1a75cb1d44d0e805336b016a92a4b2d8d564fdda.tar.gz
ports-1a75cb1d44d0e805336b016a92a4b2d8d564fdda.zip
- Stagify lang/ghc and all the Haskell Cabal ports
- Update HACKAGE_SITE to follow changes in upstream - MAKE_ENV now sets LC_ALL and DESTDIR for Haskell Cabal ports - Further minor cosmetical changes: replace USE_GMAKE with USES, get rid of ${DO_NADA}, some refactoring Obtained from: FreeBSD Haskell
Notes
Notes: svn path=/head/; revision=339286
Diffstat (limited to 'www')
-rw-r--r--www/hs-HTTP/Makefile1
-rw-r--r--www/hs-activehs/Makefile1
-rw-r--r--www/hs-authenticate/Makefile1
-rw-r--r--www/hs-cgi/Makefile1
-rw-r--r--www/hs-cookie/Makefile1
-rw-r--r--www/hs-css-text/Makefile1
-rw-r--r--www/hs-fastcgi/Makefile1
-rw-r--r--www/hs-gitit/Makefile1
-rw-r--r--www/hs-hS3/Makefile1
-rw-r--r--www/hs-hamlet/Makefile1
-rw-r--r--www/hs-happstack-server/Makefile1
-rw-r--r--www/hs-happstack/Makefile1
-rw-r--r--www/hs-heist/Makefile1
-rw-r--r--www/hs-hjsmin/Makefile1
-rw-r--r--www/hs-http-conduit/Makefile1
-rw-r--r--www/hs-http-date/Makefile1
-rw-r--r--www/hs-http-reverse-proxy/Makefile1
-rw-r--r--www/hs-http-server/Makefile7
-rw-r--r--www/hs-http-server/files/pkg-message.in7
-rw-r--r--www/hs-http-types/Makefile1
-rw-r--r--www/hs-oeis/Makefile1
-rw-r--r--www/hs-path-pieces/Makefile1
-rw-r--r--www/hs-recaptcha/Makefile1
-rw-r--r--www/hs-scgi/Makefile1
-rw-r--r--www/hs-shakespeare-css/Makefile1
-rw-r--r--www/hs-shakespeare-i18n/Makefile1
-rw-r--r--www/hs-shakespeare-js/Makefile1
-rw-r--r--www/hs-shakespeare-text/Makefile1
-rw-r--r--www/hs-shakespeare/Makefile1
-rw-r--r--www/hs-snap-core/Makefile1
-rw-r--r--www/hs-snap-server/Makefile1
-rw-r--r--www/hs-snap/Makefile1
-rw-r--r--www/hs-url/Makefile1
-rw-r--r--www/hs-wai-app-static/Makefile1
-rw-r--r--www/hs-wai-extra/Makefile1
-rw-r--r--www/hs-wai-logger/Makefile1
-rw-r--r--www/hs-wai-test/Makefile1
-rw-r--r--www/hs-wai/Makefile1
-rw-r--r--www/hs-warp/Makefile1
-rw-r--r--www/hs-webkit/Makefile1
-rw-r--r--www/hs-xss-sanitize/Makefile1
-rw-r--r--www/hs-yesod-auth/Makefile1
-rw-r--r--www/hs-yesod-core/Makefile1
-rw-r--r--www/hs-yesod-form/Makefile1
-rw-r--r--www/hs-yesod-persistent/Makefile1
-rw-r--r--www/hs-yesod-platform/Makefile1
-rw-r--r--www/hs-yesod-routes/Makefile1
-rw-r--r--www/hs-yesod-static/Makefile1
-rw-r--r--www/hs-yesod-test/Makefile1
-rw-r--r--www/hs-yesod/Makefile1
50 files changed, 9 insertions, 53 deletions
diff --git a/www/hs-HTTP/Makefile b/www/hs-HTTP/Makefile
index bfbf15f483da..ca9a9b02fdec 100644
--- a/www/hs-HTTP/Makefile
+++ b/www/hs-HTTP/Makefile
@@ -13,6 +13,5 @@ LICENSE= BSD
USE_CABAL= mtl network parsec
-NO_STAGE= yes
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/www/hs-activehs/Makefile b/www/hs-activehs/Makefile
index 725dbeb20f5c..211b85ec9154 100644
--- a/www/hs-activehs/Makefile
+++ b/www/hs-activehs/Makefile
@@ -21,6 +21,5 @@ USE_CABAL= activehs-base>=0.2 blaze-html>=0.5 blaze-markup>=0.5.1.0 \
STANDALONE= yes
EXECUTABLE= activehs
-NO_STAGE= yes
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/www/hs-authenticate/Makefile b/www/hs-authenticate/Makefile
index aecd17aeac22..601f094cbe18 100644
--- a/www/hs-authenticate/Makefile
+++ b/www/hs-authenticate/Makefile
@@ -15,6 +15,5 @@ USE_CABAL= aeson>=0.5 attoparsec blaze-builder case-insensitive>=0.2 \
tagsoup>=0.12 text transformers>=0.1 unordered-containers \
xml-conduit>=1.0
-NO_STAGE= yes
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/www/hs-cgi/Makefile b/www/hs-cgi/Makefile
index 6633309c5679..46166113371d 100644
--- a/www/hs-cgi/Makefile
+++ b/www/hs-cgi/Makefile
@@ -14,6 +14,5 @@ LICENSE= BSD
USE_CABAL= extensible-exceptions mtl>=1 network>=2 parsec>=2 xhtml>=3000
-NO_STAGE= yes
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/www/hs-cookie/Makefile b/www/hs-cookie/Makefile
index ee2ffb6507a1..605687d46d04 100644
--- a/www/hs-cookie/Makefile
+++ b/www/hs-cookie/Makefile
@@ -12,6 +12,5 @@ LICENSE= BSD
USE_CABAL= blaze-builder>=0.2.1 data-default text>=0.7
-NO_STAGE= yes
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/www/hs-css-text/Makefile b/www/hs-css-text/Makefile
index 0fd7b77cda81..9e082277961a 100644
--- a/www/hs-css-text/Makefile
+++ b/www/hs-css-text/Makefile
@@ -12,6 +12,5 @@ LICENSE= BSD
USE_CABAL= attoparsec>=0.10 text>=0.11
-NO_STAGE= yes
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/www/hs-fastcgi/Makefile b/www/hs-fastcgi/Makefile
index e05c8bc75d0c..e678bbde6ea9 100644
--- a/www/hs-fastcgi/Makefile
+++ b/www/hs-fastcgi/Makefile
@@ -15,6 +15,5 @@ USE_CABAL= cgi>=3000.0.0
LIB_DEPENDS= fcgi.0:${PORTSDIR}/www/fcgi
-NO_STAGE= yes
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/www/hs-gitit/Makefile b/www/hs-gitit/Makefile
index 7fc267474dc9..30cf0ad85794 100644
--- a/www/hs-gitit/Makefile
+++ b/www/hs-gitit/Makefile
@@ -20,6 +20,5 @@ USE_CABAL= base64-bytestring>=0.1 blaze-html>=0.4 cgi ConfigFile>=1 \
EXECUTABLE= expireGititCache gitit
-NO_STAGE= yes
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/www/hs-hS3/Makefile b/www/hs-hS3/Makefile
index 5ac574035824..5643d6d554f7 100644
--- a/www/hs-hS3/Makefile
+++ b/www/hs-hS3/Makefile
@@ -15,6 +15,5 @@ USE_CABAL= Crypto>=4.1.0 dataenc HTTP>=4000.0.0 hxt>=9.0.0 \
EXECUTABLE= hs3
-NO_STAGE= yes
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/www/hs-hamlet/Makefile b/www/hs-hamlet/Makefile
index 5aab70212249..62921b6e3e72 100644
--- a/www/hs-hamlet/Makefile
+++ b/www/hs-hamlet/Makefile
@@ -13,6 +13,5 @@ LICENSE= MIT
USE_CABAL= blaze-builder>=0.2 blaze-html>=0.5 blaze-markup>=0.5.1 \
failure>=0.1 parsec>=2 shakespeare>=1.0.1 text>=0.7
-NO_STAGE= yes
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/www/hs-happstack-server/Makefile b/www/hs-happstack-server/Makefile
index ecf16ecbc6ef..b401e033f194 100644
--- a/www/hs-happstack-server/Makefile
+++ b/www/hs-happstack-server/Makefile
@@ -16,6 +16,5 @@ USE_CABAL= base64-bytestring blaze-html>=0.5 extensible-exceptions \
threads>=0.5 time-compat transformers>=0.1.3 \
transformers-base>=0.4 utf8-string>=0.3.4 xhtml zlib
-NO_STAGE= yes
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/www/hs-happstack/Makefile b/www/hs-happstack/Makefile
index 76d71d720619..99418343caad 100644
--- a/www/hs-happstack/Makefile
+++ b/www/hs-happstack/Makefile
@@ -12,6 +12,5 @@ LICENSE= BSD
USE_CABAL= happstack-server>=7.0
-NO_STAGE= yes
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/www/hs-heist/Makefile b/www/hs-heist/Makefile
index cd8750900f10..567e2cb645db 100644
--- a/www/hs-heist/Makefile
+++ b/www/hs-heist/Makefile
@@ -16,6 +16,5 @@ USE_CABAL= aeson>=0.6 attoparsec>=0.10 blaze-builder>=0.2 \
random>=1.0.1.0 text>=0.10 unordered-containers>=0.1.4 \
vector>=0.9 xmlhtml>=0.1.6
-NO_STAGE= yes
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/www/hs-hjsmin/Makefile b/www/hs-hjsmin/Makefile
index 7e35c4429391..0c9d3244d3af 100644
--- a/www/hs-hjsmin/Makefile
+++ b/www/hs-hjsmin/Makefile
@@ -12,6 +12,5 @@ LICENSE= BSD
USE_CABAL= blaze-builder>=0.2 language-javascript>=0.5.1 text>=0.8
-NO_STAGE= yes
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/www/hs-http-conduit/Makefile b/www/hs-http-conduit/Makefile
index a4d6a00016ba..e536cb219cc9 100644
--- a/www/hs-http-conduit/Makefile
+++ b/www/hs-http-conduit/Makefile
@@ -20,6 +20,5 @@ USE_CABAL= asn1-data>=0.5.1 base64-bytestring>=0.1 blaze-builder>=0.2.1 \
transformers-base>=0.4 utf8-string>=0.3.4 void>=0.5.5 \
zlib-conduit>=0.5
-NO_STAGE= yes
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/www/hs-http-date/Makefile b/www/hs-http-date/Makefile
index d03d15195fb8..0de6c3fd8265 100644
--- a/www/hs-http-date/Makefile
+++ b/www/hs-http-date/Makefile
@@ -12,6 +12,5 @@ LICENSE= BSD
USE_CABAL= attoparsec
-NO_STAGE= yes
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/www/hs-http-reverse-proxy/Makefile b/www/hs-http-reverse-proxy/Makefile
index dcf71c703529..b2fcf01f4f4f 100644
--- a/www/hs-http-reverse-proxy/Makefile
+++ b/www/hs-http-reverse-proxy/Makefile
@@ -15,6 +15,5 @@ USE_CABAL= blaze-builder>=0.3 case-insensitive>=0.4 classy-prelude>=0.3 \
lifted-base>=0.1 monad-control>=0.3 network network-conduit>=0.6 \
text>=0.11 wai>=1.3 warp>=1.3.4 word8>=0.0
-NO_STAGE= yes
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/www/hs-http-server/Makefile b/www/hs-http-server/Makefile
index 71316b1653f8..2a539cba4684 100644
--- a/www/hs-http-server/Makefile
+++ b/www/hs-http-server/Makefile
@@ -14,17 +14,18 @@ LICENSE= BSD
USE_CABAL= HTTP>=4000.2.0 mime>=0.3 network>=2 url>=2 utf8-string>=0.3.4
INSTALL_PORTEXAMPLES= cd ${WRKSRC}/example && \
- ${COPYTREE_SHARE} \* ${EXAMPLESDIR}
+ ${COPYTREE_SHARE} \* ${STAGEDIR}${EXAMPLESDIR}
OPTIONS_DEFINE= EXAMPLES
OPTIONS_DEFAULT= EXAMPLES
-NO_STAGE= yes
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.options.mk"
.if ${PORT_OPTIONS:MEXAMPLES}
SUB_FILES= pkg-message
-SHOW_PKGMSG= yes
+
+post-install::
+ @${CAT} ${PKGMESSAGE}
.endif
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
diff --git a/www/hs-http-server/files/pkg-message.in b/www/hs-http-server/files/pkg-message.in
index 0932f20ea899..d549047b1b56 100644
--- a/www/hs-http-server/files/pkg-message.in
+++ b/www/hs-http-server/files/pkg-message.in
@@ -1,5 +1,8 @@
- You have installed the directory:
+
+------------------------------------------------------------------------
+Note that the examples have been installed into this directory:
%%EXAMPLESDIR%%
- you'll have to install the port converters/hs-json to use it.
+The port converters/hs-json has to be installed in order to use them.
+------------------------------------------------------------------------
diff --git a/www/hs-http-types/Makefile b/www/hs-http-types/Makefile
index 7bccbaec638b..abbb92e533f6 100644
--- a/www/hs-http-types/Makefile
+++ b/www/hs-http-types/Makefile
@@ -12,6 +12,5 @@ LICENSE= BSD
USE_CABAL= blaze-builder>=0.2.1.4 case-insensitive>=0.2 text>=0.11.0.2
-NO_STAGE= yes
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/www/hs-oeis/Makefile b/www/hs-oeis/Makefile
index 6adeb19715a2..87e6053f931c 100644
--- a/www/hs-oeis/Makefile
+++ b/www/hs-oeis/Makefile
@@ -13,6 +13,5 @@ LICENSE= BSD
USE_CABAL= HTTP>=4000.0.2 network>=2
-NO_STAGE= yes
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/www/hs-path-pieces/Makefile b/www/hs-path-pieces/Makefile
index 0af640f85960..35727555ab03 100644
--- a/www/hs-path-pieces/Makefile
+++ b/www/hs-path-pieces/Makefile
@@ -12,6 +12,5 @@ LICENSE= BSD
USE_CABAL= text>=0.5
-NO_STAGE= yes
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/www/hs-recaptcha/Makefile b/www/hs-recaptcha/Makefile
index 2db55d6d908e..bbc1fccc4a22 100644
--- a/www/hs-recaptcha/Makefile
+++ b/www/hs-recaptcha/Makefile
@@ -12,6 +12,5 @@ LICENSE= BSD
USE_CABAL= HTTP>=3001.1.4 network>=2.2.0.1 xhtml>=3000.0
-NO_STAGE= yes
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/www/hs-scgi/Makefile b/www/hs-scgi/Makefile
index 2d0919c1a3f1..24a5544d8a38 100644
--- a/www/hs-scgi/Makefile
+++ b/www/hs-scgi/Makefile
@@ -15,6 +15,5 @@ LICENSE= BSD
USE_CABAL= cgi network>=2.2.3
-NO_STAGE= yes
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/www/hs-shakespeare-css/Makefile b/www/hs-shakespeare-css/Makefile
index da57e26293bc..f0e66e55c78d 100644
--- a/www/hs-shakespeare-css/Makefile
+++ b/www/hs-shakespeare-css/Makefile
@@ -12,6 +12,5 @@ LICENSE= MIT
USE_CABAL= parsec>=2 shakespeare>=1.0 text>=0.11.1.1 transformers
-NO_STAGE= yes
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/www/hs-shakespeare-i18n/Makefile b/www/hs-shakespeare-i18n/Makefile
index 96a7084bb3cc..28f23ad5a869 100644
--- a/www/hs-shakespeare-i18n/Makefile
+++ b/www/hs-shakespeare-i18n/Makefile
@@ -12,6 +12,5 @@ LICENSE= MIT
USE_CABAL= parsec shakespeare>=1.0 text>=0.7
-NO_STAGE= yes
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/www/hs-shakespeare-js/Makefile b/www/hs-shakespeare-js/Makefile
index 030fef775305..1e5e3e4599b0 100644
--- a/www/hs-shakespeare-js/Makefile
+++ b/www/hs-shakespeare-js/Makefile
@@ -12,6 +12,5 @@ LICENSE= MIT
USE_CABAL= aeson>=0.5 shakespeare>=1.0.5 text>=0.7
-NO_STAGE= yes
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/www/hs-shakespeare-text/Makefile b/www/hs-shakespeare-text/Makefile
index 93f1b0271e2e..cd1741b92b1b 100644
--- a/www/hs-shakespeare-text/Makefile
+++ b/www/hs-shakespeare-text/Makefile
@@ -12,6 +12,5 @@ LICENSE= MIT
USE_CABAL= shakespeare>=1.0 text>=0.7
-NO_STAGE= yes
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/www/hs-shakespeare/Makefile b/www/hs-shakespeare/Makefile
index 51ae3abfb0e0..dfe06966239e 100644
--- a/www/hs-shakespeare/Makefile
+++ b/www/hs-shakespeare/Makefile
@@ -13,6 +13,5 @@ LICENSE= MIT
USE_CABAL= parsec>=2 system-fileio>=0.3 system-filepath>=0.4 \
text>=0.7
-NO_STAGE= yes
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/www/hs-snap-core/Makefile b/www/hs-snap-core/Makefile
index 6762f6a0dd4e..5d1f6919dc23 100644
--- a/www/hs-snap-core/Makefile
+++ b/www/hs-snap-core/Makefile
@@ -17,6 +17,5 @@ USE_CABAL= attoparsec>=0.10 attoparsec-enumerator>=0.3 \
regex-posix>=0.95 text>=0.11 unix-compat>=0.2 \
unordered-containers>=0.1.4.3 vector>=0.6 zlib-enum>=0.2.1
-NO_STAGE= yes
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/www/hs-snap-server/Makefile b/www/hs-snap-server/Makefile
index 85298e228df4..fc2dcbcc9af7 100644
--- a/www/hs-snap-server/Makefile
+++ b/www/hs-snap-server/Makefile
@@ -20,7 +20,6 @@ OPTIONS_DEFINE= OPENSSL
OPENSSL_DESC= Enable HTTPS support using the HsOpenSSL library
-NO_STAGE= yes
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.options.mk"
.if ${PORT_OPTIONS:MOPENSSL}
diff --git a/www/hs-snap/Makefile b/www/hs-snap/Makefile
index 0586300e9fa4..b86c5867d162 100644
--- a/www/hs-snap/Makefile
+++ b/www/hs-snap/Makefile
@@ -23,6 +23,5 @@ EXECUTABLE= snap
IGNORE_DYNAMIC= yes
-NO_STAGE= yes
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/www/hs-url/Makefile b/www/hs-url/Makefile
index a1959ff2df93..9722ba342b45 100644
--- a/www/hs-url/Makefile
+++ b/www/hs-url/Makefile
@@ -13,6 +13,5 @@ LICENSE= BSD
USE_CABAL= utf8-string>=0.3.4
-NO_STAGE= yes
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/www/hs-wai-app-static/Makefile b/www/hs-wai-app-static/Makefile
index 60d139eeeb6f..fb54e0b50a89 100644
--- a/www/hs-wai-app-static/Makefile
+++ b/www/hs-wai-app-static/Makefile
@@ -16,6 +16,5 @@ USE_CABAL= base64-bytestring>=0.1 blaze-builder>=0.2.1.4 blaze-html>=0.5 \
mime-types>=0.1 system-fileio>=0.3 system-filepath>=0.4 \
text>=0.7 transformers>=0.2.2 unix-compat>=0.2 wai>=1.3
-NO_STAGE= yes
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/www/hs-wai-extra/Makefile b/www/hs-wai-extra/Makefile
index 42311940804b..01697e361bff 100644
--- a/www/hs-wai-extra/Makefile
+++ b/www/hs-wai-extra/Makefile
@@ -17,6 +17,5 @@ USE_CABAL= ansi-terminal blaze-builder>=0.2.1.4 blaze-builder-conduit>=0.5 \
text>=0.7 transformers>=0.2.2 void>=0.5 wai>=1.3 \
wai-logger>=0.2 word8 zlib-conduit>=0.5
-NO_STAGE= yes
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/www/hs-wai-logger/Makefile b/www/hs-wai-logger/Makefile
index 7e82607cbdd7..c2420a46d047 100644
--- a/www/hs-wai-logger/Makefile
+++ b/www/hs-wai-logger/Makefile
@@ -13,6 +13,5 @@ LICENSE= BSD
USE_CABAL= blaze-builder byteorder case-insensitive date-cache>=0.3 \
fast-logger>=0.3 http-types network wai
-NO_STAGE= yes
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/www/hs-wai-test/Makefile b/www/hs-wai-test/Makefile
index e1617a576df1..1b86ca9124d2 100644
--- a/www/hs-wai-test/Makefile
+++ b/www/hs-wai-test/Makefile
@@ -15,6 +15,5 @@ USE_CABAL= blaze-builder>=0.2.1.4 blaze-builder-conduit>=0.5 \
http-types>=0.7 HUnit>=1.2 network text>=0.7 \
transformers>=0.2.2 wai>=1.3
-NO_STAGE= yes
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/www/hs-wai/Makefile b/www/hs-wai/Makefile
index bc17c4b6241f..a30cddd17178 100644
--- a/www/hs-wai/Makefile
+++ b/www/hs-wai/Makefile
@@ -13,6 +13,5 @@ LICENSE= BSD
USE_CABAL= blaze-builder>=0.2.1.4 conduit>=0.5 http-types>=0.7 \
network>=2.2.1.5 text>=0.7 transformers>=0.2.2 vault>=0.1
-NO_STAGE= yes
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/www/hs-warp/Makefile b/www/hs-warp/Makefile
index 7a87e6626c17..73949f6629cf 100644
--- a/www/hs-warp/Makefile
+++ b/www/hs-warp/Makefile
@@ -16,6 +16,5 @@ USE_CABAL= blaze-builder>=0.2.1.4 blaze-builder-conduit>=0.5 \
simple-sendfile>=0.2.7 transformers>=0.2.2 unix-compat>=0.2 \
void wai>=1.3
-NO_STAGE= yes
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/www/hs-webkit/Makefile b/www/hs-webkit/Makefile
index 107c2faab691..0d4b19d7914e 100644
--- a/www/hs-webkit/Makefile
+++ b/www/hs-webkit/Makefile
@@ -14,6 +14,5 @@ USES= pkgconfig
USE_CABAL= cairo>=0.12 glib>=0.12 gtk>=0.12 mtl pango>=0.12
BUILD_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/webkit-1.0.pc:${PORTSDIR}/www/webkit-gtk2
-NO_STAGE= yes
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/www/hs-xss-sanitize/Makefile b/www/hs-xss-sanitize/Makefile
index 74f52b7e2f79..35bd8053124c 100644
--- a/www/hs-xss-sanitize/Makefile
+++ b/www/hs-xss-sanitize/Makefile
@@ -13,6 +13,5 @@ LICENSE= BSD
USE_CABAL= attoparsec>=0.10.0.3 css-text>=0.1.1 network>=2 \
tagsoup>=0.12.2 text>=0.11 utf8-string>=0.3
-NO_STAGE= yes
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/www/hs-yesod-auth/Makefile b/www/hs-yesod-auth/Makefile
index 8bd8159573f5..188c980f2168 100644
--- a/www/hs-yesod-auth/Makefile
+++ b/www/hs-yesod-auth/Makefile
@@ -20,6 +20,5 @@ USE_CABAL= aeson>=0.5 authenticate>=1.3 blaze-html>=0.5 \
unordered-containers wai>=1.4 yesod-core>=1.2 yesod-form>=1.3 \
yesod-persistent>=1.2
-NO_STAGE= yes
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/www/hs-yesod-core/Makefile b/www/hs-yesod-core/Makefile
index 3f2a8edb89e2..03146cf321b8 100644
--- a/www/hs-yesod-core/Makefile
+++ b/www/hs-yesod-core/Makefile
@@ -22,6 +22,5 @@ USE_CABAL= aeson>=0.5 attoparsec-conduit blaze-builder>=0.2.1.4 \
vector>=0.9 wai>=1.4 wai-extra>=1.3 warp>=1.3.8 \
yesod-routes>=1.2
-NO_STAGE= yes
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/www/hs-yesod-form/Makefile b/www/hs-yesod-form/Makefile
index ed97124df973..382a6f7e02dc 100644
--- a/www/hs-yesod-form/Makefile
+++ b/www/hs-yesod-form/Makefile
@@ -17,6 +17,5 @@ USE_CABAL= aeson attoparsec>=0.10 blaze-builder>=0.2.1.4 blaze-html>=0.5 \
text>=0.9 transformers>=0.2.2 wai>=1.3 xss-sanitize>=0.3.0.1 \
yesod-core>=1.2 yesod-persistent>=1.2
-NO_STAGE= yes
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/www/hs-yesod-persistent/Makefile b/www/hs-yesod-persistent/Makefile
index 4eec9f71a925..e10f3d537000 100644
--- a/www/hs-yesod-persistent/Makefile
+++ b/www/hs-yesod-persistent/Makefile
@@ -14,6 +14,5 @@ USE_CABAL= blaze-builder conduit lifted-base persistent>=1.2 \
persistent-template>=1.2 pool-conduit resourcet \
transformers>=0.2.2 yesod-core>=1.2
-NO_STAGE= yes
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/www/hs-yesod-platform/Makefile b/www/hs-yesod-platform/Makefile
index 6526472fc2b0..c169c6b00316 100644
--- a/www/hs-yesod-platform/Makefile
+++ b/www/hs-yesod-platform/Makefile
@@ -137,6 +137,5 @@ USE_CABAL= aeson==0.6.1.0_4 \
zlib-bindings==0.1.1.3_3 \
zlib-conduit==1.0.0_3
-NO_STAGE= yes
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/www/hs-yesod-routes/Makefile b/www/hs-yesod-routes/Makefile
index 80659bcbb012..cf46882d88e9 100644
--- a/www/hs-yesod-routes/Makefile
+++ b/www/hs-yesod-routes/Makefile
@@ -12,6 +12,5 @@ LICENSE= MIT
USE_CABAL= path-pieces>=0.1 text>=0.5 vector>=0.8
-NO_STAGE= yes
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/www/hs-yesod-static/Makefile b/www/hs-yesod-static/Makefile
index bf1c8cb71e88..aac803a7845e 100644
--- a/www/hs-yesod-static/Makefile
+++ b/www/hs-yesod-static/Makefile
@@ -17,6 +17,5 @@ USE_CABAL= base64-bytestring>=0.1.0.1 cereal>=0.3 conduit>=0.5 \
transformers>=0.2.2 unix-compat>=0.2 wai>=1.3 \
wai-app-static>=1.3 yesod-core>=1.2
-NO_STAGE= yes
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/www/hs-yesod-test/Makefile b/www/hs-yesod-test/Makefile
index 33aabff17537..93b4696d1b2e 100644
--- a/www/hs-yesod-test/Makefile
+++ b/www/hs-yesod-test/Makefile
@@ -17,6 +17,5 @@ USE_CABAL= attoparsec>=0.10 blaze-builder blaze-html>=0.5 \
transformers>=0.2.2 wai>=1.3 wai-test>=1.3 xml-conduit>=1.0 \
xml-types>=0.3 yesod-core>=1.2
-NO_STAGE= yes
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/www/hs-yesod/Makefile b/www/hs-yesod/Makefile
index c3ffcb205e37..e84e80ae4cfc 100644
--- a/www/hs-yesod/Makefile
+++ b/www/hs-yesod/Makefile
@@ -17,6 +17,5 @@ USE_CABAL= aeson blaze-html>=0.5 blaze-markup>=0.5.1 data-default \
wai-extra>=1.3 warp>=1.3 yaml yesod-auth>=1.2 yesod-core>=1.2 \
yesod-form>=1.3 yesod-persistent>=1.2
-NO_STAGE= yes
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>