aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2018-03-30 22:19:51 +0000
committerMathieu Arnold <mat@FreeBSD.org>2018-03-30 22:19:51 +0000
commit1f4fec42969873f709b90dc18dac0f06be986cf5 (patch)
tree3b8f3819b54658198250a7f35d685f007ec771ec /www
parentaeec0597ec38080318d87e2b9a9c9167c4be9afe (diff)
downloadports-1f4fec42969873f709b90dc18dac0f06be986cf5.tar.gz
ports-1f4fec42969873f709b90dc18dac0f06be986cf5.zip
Cleanup a bit.
Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=466008
Diffstat (limited to 'www')
-rw-r--r--www/mattermost-server/Makefile10
-rw-r--r--www/mattermost-webapp/Makefile7
2 files changed, 6 insertions, 11 deletions
diff --git a/www/mattermost-server/Makefile b/www/mattermost-server/Makefile
index 326906ca7d72..d9ccb84d9423 100644
--- a/www/mattermost-server/Makefile
+++ b/www/mattermost-server/Makefile
@@ -32,8 +32,6 @@ MATTERMOSTD_GROUP= mattermost
USERS= ${MATTERMOSTD_USER}
GROUPS= ${MATTERMOSTD_GROUP}
-.include <bsd.port.pre.mk>
-
pre-build:
@${MKDIR} ${WRKSRC}/src/github.com/${GH_ACCOUNT_DEFAULT}/${PORTNAME}
@cd ${WRKSRC} && \
@@ -48,10 +46,8 @@ do-build:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bin/platform ${STAGEDIR}${PREFIX}/bin/mattermostd
${MKDIR} ${STAGEDIR}${PREFIX}/etc/mattermost
- ${CP} ${WRKSRC}/config/default.json ${STAGEDIR}${PREFIX}/etc/mattermost/config.json.sample
+ ${INSTALL_DATA} ${WRKSRC}/config/default.json ${STAGEDIR}${PREFIX}/etc/mattermost/config.json.sample
${MKDIR} ${STAGEDIR}${WWWDIR}
- ${CP} -R ${WRKSRC}/fonts ${STAGEDIR}${WWWDIR}
- ${CP} -R ${WRKSRC}/i18n ${STAGEDIR}${WWWDIR}
- ${CP} -R ${WRKSRC}/templates ${STAGEDIR}${WWWDIR}
+ cd ${WRKSRC} && ${COPYTREE_SHARE} 'fonts i18n templates' ${STAGEDIR}${WWWDIR}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/mattermost-webapp/Makefile b/www/mattermost-webapp/Makefile
index bbb3ef631dbc..eb7c6f2ac848 100644
--- a/www/mattermost-webapp/Makefile
+++ b/www/mattermost-webapp/Makefile
@@ -13,6 +13,7 @@ COMMENT= Webapp of Mattermost server
LICENSE= APACHE20
NO_BUILD= yes
+NO_ARCH= yes
WWWDIR= ${PREFIX}/www/mattermost
@@ -25,11 +26,9 @@ GROUPS= ${MATTERMOSTD_GROUP}
PLIST_SUB= MATTERMOSTD_USER=${MATTERMOSTD_USER} \
MATTERMOSTD_GROUP=${MATTERMOSTD_GROUP}
-.include <bsd.port.pre.mk>
-
do-install:
${MKDIR} ${STAGEDIR}${WWWDIR}
- ${CP} -R ${WRKDIR}/mattermost/client ${STAGEDIR}${WWWDIR}
+ cd ${WRKDIR}/mattermost && ${COPYTREE_SHARE} client ${STAGEDIR}${WWWDIR}
${MKDIR} ${STAGEDIR}${WWWDIR}/client/plugins
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>