aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-09-21 03:06:24 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-09-21 03:35:09 +0000
commit2a0be5a989c0225ea59029396196f039bba27dfc (patch)
tree9d782379a81fd306b678fdc46fa6b8af8210d512 /www
parent35cd7c24c8ff5ebf496ac6a3e01bab7af1a088d5 (diff)
downloadports-2a0be5a989c0225ea59029396196f039bba27dfc.tar.gz
ports-2a0be5a989c0225ea59029396196f039bba27dfc.zip
www/py-quilt3: Add py-quilt3 3.5.0
Quilt is for data-driven teams and offers features for coders (data scientists, data engineers, developers) and business users alike. Quilt consists of a Python client, web catalog, lambda functions -- all of which are open source -- plus a suite of backend services and Docker containers orchestrated by CloudFormation. WWW: https://github.com/quiltdata/quilt
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/py-quilt3/Makefile35
-rw-r--r--www/py-quilt3/distinfo3
-rw-r--r--www/py-quilt3/files/patch-setup.py17
-rw-r--r--www/py-quilt3/pkg-descr8
5 files changed, 64 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 160f4ab43603..3269fe0f29f3 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1728,6 +1728,7 @@
SUBDIR += py-qt5-webkit
SUBDIR += py-qt5-webkitwidgets
SUBDIR += py-qt5-websockets
+ SUBDIR += py-quilt3
SUBDIR += py-rackspace-monitoring
SUBDIR += py-recaptcha
SUBDIR += py-requests
diff --git a/www/py-quilt3/Makefile b/www/py-quilt3/Makefile
new file mode 100644
index 000000000000..857f695ab13c
--- /dev/null
+++ b/www/py-quilt3/Makefile
@@ -0,0 +1,35 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+
+PORTNAME= quilt3
+PORTVERSION= 3.5.0
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Python client for Quilt data hub
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}appdirs>=1.4.0:devel/py-appdirs@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}aws-requests-auth>=0.4.2:devel/py-aws-requests-auth@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}boto3>=1.10.0:www/py-boto3@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}dnspython>=1.16.0:dns/py-dnspython@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}Flask>=0:www/py-flask@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}Flask-Cors>=0:www/py-flask-cors@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}flask-json>=0:www/py-flask-json@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}jsonlines>=1.2.0:devel/py-jsonlines@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}jsonschema>=3.0<4:devel/py-jsonschema@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}yaml>=5.1:devel/py-yaml@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>=2.12.4:www/py-requests@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests-futures>=1.0.0:www/py-requests-futures@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}tenacity>=5.1.1:devel/py-tenacity@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}tqdm>=4.32:misc/py-tqdm@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/www/py-quilt3/distinfo b/www/py-quilt3/distinfo
new file mode 100644
index 000000000000..dbc4c5ba67a3
--- /dev/null
+++ b/www/py-quilt3/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1632036834
+SHA256 (quilt3-3.5.0.tar.gz) = aa563971835a7e924d6996241e7d9690e1e1a95c7b76efad709f43773ea2d6ed
+SIZE (quilt3-3.5.0.tar.gz) = 99925
diff --git a/www/py-quilt3/files/patch-setup.py b/www/py-quilt3/files/patch-setup.py
new file mode 100644
index 000000000000..fad9e9091aad
--- /dev/null
+++ b/www/py-quilt3/files/patch-setup.py
@@ -0,0 +1,17 @@
+--- setup.py.orig 2021-09-07 10:31:49 UTC
++++ setup.py
+@@ -64,12 +64,12 @@ setup(
+ 'flask',
+ 'flask_cors',
+ 'flask_json',
+- 'jsonlines==1.2.0',
++ 'jsonlines>=1.2.0',
+ 'PyYAML>=5.1',
+ 'requests>=2.12.4',
+ 'tenacity>=5.1.1',
+ 'tqdm>=4.32',
+- 'requests_futures==1.0.0',
++ 'requests_futures>=1.0.0',
+ 'jsonschema==3.*',
+ ],
+ extras_require={
diff --git a/www/py-quilt3/pkg-descr b/www/py-quilt3/pkg-descr
new file mode 100644
index 000000000000..1d793824a2fe
--- /dev/null
+++ b/www/py-quilt3/pkg-descr
@@ -0,0 +1,8 @@
+Quilt is for data-driven teams and offers features for coders (data scientists,
+data engineers, developers) and business users alike.
+
+Quilt consists of a Python client, web catalog, lambda functions -- all of which
+are open source -- plus a suite of backend services and Docker containers
+orchestrated by CloudFormation.
+
+WWW: https://github.com/quiltdata/quilt