aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorKai Knoblich <kai@FreeBSD.org>2024-03-29 14:27:22 +0000
committerKai Knoblich <kai@FreeBSD.org>2024-03-29 14:31:57 +0000
commit2c1dcd6956975e490d9882c0af62ed848f59eab2 (patch)
treeed91f1e845fb7079fba1de33493f653dc0847d13 /www
parentc680b3f7f529f73f009e6640f99062e7792df7b4 (diff)
downloadports-2c1dcd6956975e490d9882c0af62ed848f59eab2.tar.gz
ports-2c1dcd6956975e490d9882c0af62ed848f59eab2.zip
www/py-django-storages: Update to 1.14.2
* Switch to the PEP517 build framework. * Add new options DROPBOX, GOOGLE, LIBCLOUD, S3 and SFTP for supported backends as indicated in pyproject.toml. Leave the options as non-default for now to keep the dependencies low and to see what the corresponding demand is for certain backends later on. PR: 276319 With hat: python
Diffstat (limited to 'www')
-rw-r--r--www/py-django-storages/Makefile22
-rw-r--r--www/py-django-storages/distinfo6
2 files changed, 23 insertions, 5 deletions
diff --git a/www/py-django-storages/Makefile b/www/py-django-storages/Makefile
index e7b9ece054d2..1d4cd54915cc 100644
--- a/www/py-django-storages/Makefile
+++ b/www/py-django-storages/Makefile
@@ -1,5 +1,5 @@
PORTNAME= django-storages
-PORTVERSION= 1.13.2
+PORTVERSION= 1.14.2
CATEGORIES= www python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -10,11 +10,29 @@ WWW= https://github.com/jschneier/django-storages
LICENSE= BSD3CLAUSE
+BUILD_DEPENDS= ${PY_SETUPTOOLS} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>0:devel/py-wheel@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django32>=3.2:www/py-django32@${PY_FLAVOR}
USES= python
-USE_PYTHON= autoplist concurrent distutils
+USE_PYTHON= autoplist concurrent pep517
NO_ARCH= yes
+# There is also an Azure backend (via AZURE option), but this requires a newer
+# version of py-azure-storage-blob.
+OPTIONS_DEFINE= DROPBOX GOOGLE LIBCLOUD S3 SFTP
+
+DROPBOX_DESC= Dropbox backend
+GOOGLE_DESC= Google Cloud Storage backend
+LIBCLOUD_DESC= Apache Libcloud backend
+S3_DESC= Amazon S3 backend
+SFTP_DESC= SFTP backend
+
+DROPBOX_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dropbox>=7.2.1:www/py-dropbox@${PY_FLAVOR}
+GOOGLE_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}google-cloud-storage>=1.27:www/py-google-cloud-storage@${PY_FLAVOR}
+LIBCLOUD_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}libcloud>0:net/py-libcloud@${PY_FLAVOR}
+S3_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}boto3>=1.4.4:www/py-boto3@${PY_FLAVOR}
+SFTP_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}paramiko>=1.15:security/py-paramiko@${PY_FLAVOR}
+
.include <bsd.port.mk>
diff --git a/www/py-django-storages/distinfo b/www/py-django-storages/distinfo
index 94fe0c3325ea..31d6fcfadf8a 100644
--- a/www/py-django-storages/distinfo
+++ b/www/py-django-storages/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1674590834
-SHA256 (django-storages-1.13.2.tar.gz) = cbadd15c909ceb7247d4ffc503f12a9bec36999df8d0bef7c31e57177d512688
-SIZE (django-storages-1.13.2.tar.gz) = 107522
+TIMESTAMP = 1704627222
+SHA256 (django-storages-1.14.2.tar.gz) = 51b36af28cc5813b98d5f3dfe7459af638d84428c8df4a03990c7d74d1bea4e5
+SIZE (django-storages-1.14.2.tar.gz) = 111090