aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-05-27 19:36:26 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-05-27 19:36:26 +0000
commit2db39414d77feec3ed7b8b98accc877e7f9024f9 (patch)
treeb0b7f286d1ff84f0f1108c21b128e6e5f30e4e47 /www
parent772728a3bc7bb832b4f7c01ad57ca8a34534d605 (diff)
downloadports-2db39414d77feec3ed7b8b98accc877e7f9024f9.tar.gz
ports-2db39414d77feec3ed7b8b98accc877e7f9024f9.zip
The intent of this is to allow an administrator to mark a Ticket as "Pending"
to indicate that information has been requested from the reporter. If the reporter doesn't reply with in the allotted timeframe, the ticket will automatically be closed. This works well when combined with the SimpleTicketPlugin WWW: http://trac-hacks.org/wiki/PendingTicketPlugin Submitted by: Gerrit Beine <gerrit.beine at gmx.de>
Notes
Notes: svn path=/head/; revision=192099
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/trac-pendingticket/Makefile34
-rw-r--r--www/trac-pendingticket/distinfo3
-rw-r--r--www/trac-pendingticket/files/close_old_pending.py.patch8
-rw-r--r--www/trac-pendingticket/pkg-descr8
-rw-r--r--www/trac-pendingticket/pkg-plist2
6 files changed, 56 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 4fbbcf7f6c4f..c6a51eb8339c 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1162,6 +1162,7 @@
SUBDIR += trac-macropost
SUBDIR += trac-nav
SUBDIR += trac-pagetopdf
+ SUBDIR += trac-pendingticket
SUBDIR += trac-privatetickets
SUBDIR += trac-remind
SUBDIR += trac-restrictedarea
diff --git a/www/trac-pendingticket/Makefile b/www/trac-pendingticket/Makefile
new file mode 100644
index 000000000000..804e75c74ced
--- /dev/null
+++ b/www/trac-pendingticket/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: trac-pendingticket
+# Date created: May 18 2007
+# Whom: Gerrit Beine <gerrit.beine@gmx.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pendingticket
+PORTVERSION= 0.0.1
+CATEGORIES= www devel python
+MASTER_SITES= http://www.gerritbeine.de/download/trac/
+PKGNAMEPREFIX= trac-
+DISTNAME= ${PORTNAME}plugin-${PORTVERSION}
+
+MAINTAINER= gerrit.beine@gmx.de
+COMMENT= Support for pending tickets
+
+BUILD_DEPENDS+= easy_install:${PORTSDIR}/devel/py-setuptools
+RUN_DEPENDS+= tracd:${PORTSDIR}/www/trac
+
+WRKSRC= ${WRKDIR}/${PORTNAME}plugin/removependingplugin
+NO_BUILD= yes
+USE_PYTHON= 2.3+
+USE_PYDISTUTILS=yes
+PLIST_SUB+= PORTVERSION=${PORTVERSION} PYTHONVERSION=${_PYTHON_VERSION}
+
+post-patch:
+ cd ${WRKDIR}/${PORTNAME}plugin && ${PATCH} < ${PATCHDIR}/close_old_pending.py.patch
+ ${REINPLACE_CMD} -e "s,%%PYTHON%%,${PYTHON_CMD}," ${WRKDIR}/${PORTNAME}plugin/close_old_pending.py
+
+post-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}plugin/close_old_pending.py ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/www/trac-pendingticket/distinfo b/www/trac-pendingticket/distinfo
new file mode 100644
index 000000000000..42140d018d17
--- /dev/null
+++ b/www/trac-pendingticket/distinfo
@@ -0,0 +1,3 @@
+MD5 (pendingticketplugin-0.0.1.tar.gz) = ca39c01a83f33b6790bf843062ff6fd5
+SHA256 (pendingticketplugin-0.0.1.tar.gz) = 401e958499f499d3ead98e4b44454914932f32c98c59bc77dd9305419473f76e
+SIZE (pendingticketplugin-0.0.1.tar.gz) = 2474
diff --git a/www/trac-pendingticket/files/close_old_pending.py.patch b/www/trac-pendingticket/files/close_old_pending.py.patch
new file mode 100644
index 000000000000..eca1f44a0186
--- /dev/null
+++ b/www/trac-pendingticket/files/close_old_pending.py.patch
@@ -0,0 +1,8 @@
+--- close_old_pending.py.orig Fri May 18 19:25:29 2007
++++ close_old_pending.py Fri May 18 20:59:01 2007
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!%%PYTHON%%
+
+ # Script to close old tickets that are in Pending status.
+ # Copyright 2007 Daniel A. Atallah <datallah@pidgin.im>
diff --git a/www/trac-pendingticket/pkg-descr b/www/trac-pendingticket/pkg-descr
new file mode 100644
index 000000000000..c07fa251c980
--- /dev/null
+++ b/www/trac-pendingticket/pkg-descr
@@ -0,0 +1,8 @@
+The intent of this is to allow an administrator to mark a Ticket as "Pending"
+to indicate that information has been requested from the reporter. If the
+reporter doesn't reply with in the allotted timeframe, the ticket will
+automatically be closed.
+
+This works well when combined with the SimpleTicketPlugin
+
+WWW: http://trac-hacks.org/wiki/PendingTicketPlugin
diff --git a/www/trac-pendingticket/pkg-plist b/www/trac-pendingticket/pkg-plist
new file mode 100644
index 000000000000..29bd25f5fe40
--- /dev/null
+++ b/www/trac-pendingticket/pkg-plist
@@ -0,0 +1,2 @@
+bin/close_old_pending.py
+%%PYTHON_SITELIBDIR%%/RemovePendingStatusPlugin-%%PORTVERSION%%-py%%PYTHONVERSION%%.egg