aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2013-08-05 15:05:29 +0000
committerAndrej Zverev <az@FreeBSD.org>2013-08-05 15:05:29 +0000
commit43f0c9f153cbb6a2e3db53e004582f6729057928 (patch)
tree6094da914716107bca7d35889c1b8aab5e6097c7 /www
parent51a9b4dec5856fd0ce0b884de19626c1cc420758 (diff)
downloadports-43f0c9f153cbb6a2e3db53e004582f6729057928.tar.gz
ports-43f0c9f153cbb6a2e3db53e004582f6729057928.zip
- Convert to new perl framework
- Trim Makefile header Approved by: tobez@ (maintainer)
Notes
Notes: svn path=/head/; revision=324276
Diffstat (limited to 'www')
-rw-r--r--www/p5-CGI-Compress-Gzip/Makefile3
-rw-r--r--www/p5-CGI-Prototype/Makefile9
-rw-r--r--www/p5-CGI.pm/Makefile3
-rw-r--r--www/p5-Continuity/Makefile9
-rw-r--r--www/p5-HTML-Lint/Makefile3
-rw-r--r--www/p5-HTML-TagCloud/Makefile9
-rw-r--r--www/p5-HTTP-Server-Simple-Recorder/Makefile9
-rw-r--r--www/p5-Scrappy/Makefile3
-rw-r--r--www/p5-Squatting/Makefile9
-rw-r--r--www/p5-Test-HTTP-Server-Simple/Makefile9
-rw-r--r--www/p5-URI-Sequin/Makefile9
-rw-r--r--www/p5-URI-Title/Makefile3
-rw-r--r--www/p5-WebService-Google-Sets/Makefile9
-rw-r--r--www/p5-Yahoo-Search/Makefile9
-rw-r--r--www/p5-pQuery/Makefile3
15 files changed, 39 insertions, 60 deletions
diff --git a/www/p5-CGI-Compress-Gzip/Makefile b/www/p5-CGI-Compress-Gzip/Makefile
index dfa6d86d4134..07eeceb1a290 100644
--- a/www/p5-CGI-Compress-Gzip/Makefile
+++ b/www/p5-CGI-Compress-Gzip/Makefile
@@ -15,7 +15,8 @@ COMMENT= CGI::Compress::Gzip - CGI with automatically compressed output
BUILD_DEPENDS= p5-IO-Zlib>=1.01:${PORTSDIR}/archivers/p5-IO-Zlib
RUN_DEPENDS= p5-IO-Zlib>=1.01:${PORTSDIR}/archivers/p5-IO-Zlib
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= CGI::Compress::Gzip.3 \
CGI::Compress::Gzip::FileHandle.3
diff --git a/www/p5-CGI-Prototype/Makefile b/www/p5-CGI-Prototype/Makefile
index 2081908e9488..ced95e57cb02 100644
--- a/www/p5-CGI-Prototype/Makefile
+++ b/www/p5-CGI-Prototype/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: www/p5-CGI-Prototype
-# Date created: 20 April 2006
-# Whom: Anton Berezin <tobez@FreeBSD.org>
-#
+# Created by: Anton Berezin <tobez@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= CGI-Prototype
PORTVERSION= 0.9054
@@ -19,7 +15,8 @@ COMMON_DEPENDS= p5-Class-Prototyped>0:${PORTSDIR}/devel/p5-Class-Prototyped \
BUILD_DEPENDS= ${COMMON_DEPENDS}
RUN_DEPENDS= ${COMMON_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= CGI::Prototype.3 \
CGI::Prototype::Hidden.3
diff --git a/www/p5-CGI.pm/Makefile b/www/p5-CGI.pm/Makefile
index 8e8226e1473d..f8734c8f7a14 100644
--- a/www/p5-CGI.pm/Makefile
+++ b/www/p5-CGI.pm/Makefile
@@ -14,7 +14,8 @@ COMMENT= Simple Common Gateway Interface Class for Perl
LICENSE= ART20 GPLv1
LICENSE_COMB= dual
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= CGI.3 CGI::Apache.3 CGI::Carp.3 CGI::Cookie.3 \
CGI::Fast.3 CGI::Pretty.3 CGI::Push.3 CGI::Switch.3 \
diff --git a/www/p5-Continuity/Makefile b/www/p5-Continuity/Makefile
index 3d456c15db58..b8f3174bc419 100644
--- a/www/p5-Continuity/Makefile
+++ b/www/p5-Continuity/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: www/p5-Continuity
-# Date created: 07 July 2008
-# Whom: Anton Berezin <tobez@FreeBSD.org>
-#
+# Created by: Anton Berezin <tobez@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Continuity
PORTVERSION= 1.5
@@ -23,7 +19,8 @@ COMMON_DEPENDS= p5-Event>0:${PORTSDIR}/devel/p5-Event \
BUILD_DEPENDS= ${COMMON_DEPENDS}
RUN_DEPENDS= ${COMMON_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Continuity.3 \
Continuity::Adapt::FCGI.3 \
diff --git a/www/p5-HTML-Lint/Makefile b/www/p5-HTML-Lint/Makefile
index e718efbe4508..9fb5abea1b79 100644
--- a/www/p5-HTML-Lint/Makefile
+++ b/www/p5-HTML-Lint/Makefile
@@ -16,7 +16,8 @@ BUILD_DEPENDS= p5-HTML-Tagset>0:${PORTSDIR}/www/p5-HTML-Tagset \
p5-HTML-Parser>0:${PORTSDIR}/www/p5-HTML-Parser
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= HTML::Lint.3 \
HTML::Lint::Error.3 \
diff --git a/www/p5-HTML-TagCloud/Makefile b/www/p5-HTML-TagCloud/Makefile
index 52f6cea59f5f..1c8e925cd162 100644
--- a/www/p5-HTML-TagCloud/Makefile
+++ b/www/p5-HTML-TagCloud/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: www/p5-HTML-TagCloud
-# Date created: 06 October 2005
-# Whom: Anton Berezin <tobez@FreeBSD.org>
-#
+# Created by: Anton Berezin <tobez@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= HTML-TagCloud
PORTVERSION= 0.37
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= tobez@FreeBSD.org
COMMENT= HTML::TagCloud - Generate An HTML Tag Cloud
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= HTML::TagCloud.3
diff --git a/www/p5-HTTP-Server-Simple-Recorder/Makefile b/www/p5-HTTP-Server-Simple-Recorder/Makefile
index 464b96620ea8..07bab3572db9 100644
--- a/www/p5-HTTP-Server-Simple-Recorder/Makefile
+++ b/www/p5-HTTP-Server-Simple-Recorder/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: www/p5-HTTP-Server-Simple-Recorder
-# Date created: 27 December 2005
-# Whom: Anton Berezin <tobez@FreeBSD.org>
-#
+# Created by: Anton Berezin <tobez@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= HTTP-Server-Simple-Recorder
PORTVERSION= 0.03
@@ -19,7 +15,8 @@ BUILD_DEPENDS= p5-HTTP-Server-Simple>=0:${PORTSDIR}/www/p5-HTTP-Server-Simple \
p5-IO-Tee>=0:${PORTSDIR}/devel/p5-IO-Tee
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= HTTP::Server::Simple::Recorder.3
diff --git a/www/p5-Scrappy/Makefile b/www/p5-Scrappy/Makefile
index 8204e55f615a..b2cd8b588728 100644
--- a/www/p5-Scrappy/Makefile
+++ b/www/p5-Scrappy/Makefile
@@ -30,7 +30,8 @@ BUILD_DEPENDS= p5-File-ShareDir-Install>=0.03:${PORTSDIR}/devel/p5-File-ShareDir
p5-YAML-Syck>=0:${PORTSDIR}/textproc/p5-YAML-Syck
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= scrappy.1
MAN3= Scrappy.3 \
diff --git a/www/p5-Squatting/Makefile b/www/p5-Squatting/Makefile
index 19832ea763d5..367fdef62a0c 100644
--- a/www/p5-Squatting/Makefile
+++ b/www/p5-Squatting/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: www/p5-Squatting
-# Date created: 07 July 2008
-# Whom: Anton Berezin <tobez@FreeBSD.org>
-#
+# Created by: Anton Berezin <tobez@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Squatting
PORTVERSION= 0.81
@@ -28,7 +24,8 @@ COMMON_DEPENDS= p5-Continuity>=0.991:${PORTSDIR}/www/p5-Continuity \
BUILD_DEPENDS= ${COMMON_DEPENDS}
RUN_DEPENDS= ${COMMON_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= squatting.1
MAN3= \
diff --git a/www/p5-Test-HTTP-Server-Simple/Makefile b/www/p5-Test-HTTP-Server-Simple/Makefile
index d1596ba1f436..753e9b2cf8b3 100644
--- a/www/p5-Test-HTTP-Server-Simple/Makefile
+++ b/www/p5-Test-HTTP-Server-Simple/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: www/p5-Test-HTTP-Server-Simple
-# Date created: 27 December 2005
-# Whom: Anton Berezin <tobez@FreeBSD.org>
-#
+# Created by: Anton Berezin <tobez@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Test-HTTP-Server-Simple
PORTVERSION= 0.11
@@ -19,7 +15,8 @@ BUILD_DEPENDS= p5-HTTP-Server-Simple>=0:${PORTSDIR}/www/p5-HTTP-Server-Simple \
p5-URI>0:${PORTSDIR}/net/p5-URI
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Test::HTTP::Server::Simple.3
diff --git a/www/p5-URI-Sequin/Makefile b/www/p5-URI-Sequin/Makefile
index a87d7d2ab0b6..01224be201e2 100644
--- a/www/p5-URI-Sequin/Makefile
+++ b/www/p5-URI-Sequin/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: www/p5-URI-Sequin
-# Date created: 25 April 2001
-# Whom: Anton Berezin <tobez@tobez.org>
-#
+# Created by: Anton Berezin <tobez@tobez.org>
# $FreeBSD$
-#
PORTNAME= URI-Sequin
PORTVERSION= 1.2
@@ -15,7 +11,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= tobez@FreeBSD.org
COMMENT= Extract information from the URLs of Search-Engines
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= URI::Sequin.3
diff --git a/www/p5-URI-Title/Makefile b/www/p5-URI-Title/Makefile
index 3683f270ea30..449863eae5f2 100644
--- a/www/p5-URI-Title/Makefile
+++ b/www/p5-URI-Title/Makefile
@@ -20,7 +20,8 @@ COMMON_DEPENDS= p5-File-Type>=0.22:${PORTSDIR}/devel/p5-File-Type \
BUILD_DEPENDS= ${COMMON_DEPENDS}
RUN_DEPENDS= ${COMMON_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= URI::Title.3
diff --git a/www/p5-WebService-Google-Sets/Makefile b/www/p5-WebService-Google-Sets/Makefile
index eb51c0b2e348..3711fa3f5baa 100644
--- a/www/p5-WebService-Google-Sets/Makefile
+++ b/www/p5-WebService-Google-Sets/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: www/p5-WebService-Google-Sets
-# Date created: 14 August 2009
-# Whom: Anton Berezin <tobez@FreeBSD.org>
-#
+# Created by: Anton Berezin <tobez@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= WebService-Google-Sets
PORTVERSION= 0.03
@@ -18,7 +14,8 @@ COMMENT= Perl access to Google Labs Sets site
BUILD_DEPENDS= p5-libwww>0:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= WebService::Google::Sets.3
diff --git a/www/p5-Yahoo-Search/Makefile b/www/p5-Yahoo-Search/Makefile
index d9f36e190a7c..8815877461ec 100644
--- a/www/p5-Yahoo-Search/Makefile
+++ b/www/p5-Yahoo-Search/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: www/p5-Yahoo-Search
-# Date created: 21 March 2007
-# Whom: Anton Berezin <tobez@FreeBSD.org>
-#
+# Created by: Anton Berezin <tobez@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Yahoo-Search
PORTVERSION= 1.11.3
@@ -19,7 +15,8 @@ BUILD_DEPENDS= p5-URI>=1.54:${PORTSDIR}/net/p5-URI \
RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-Simple>=0.88:${PORTSDIR}/devel/p5-Test-Simple
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Yahoo::Search.3 \
Yahoo::Search::Request.3 \
diff --git a/www/p5-pQuery/Makefile b/www/p5-pQuery/Makefile
index f321cf66bc0b..d97bba02296f 100644
--- a/www/p5-pQuery/Makefile
+++ b/www/p5-pQuery/Makefile
@@ -14,7 +14,8 @@ COMMON_DEPENDS= p5-HTML-Tree>=0:${PORTSDIR}/www/p5-HTML-Tree
BUILD_DEPENDS= ${COMMON_DEPENDS}
RUN_DEPENDS= ${COMMON_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= pQuery.3 \
pQuery::DOM.3